Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 29th November 2007, 17:33
allwayson allwayson is offline
Junior Member
 
Join Date: Sep 2006
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default Same Problem

I must say I have been using ISPConfig for some time and have never had a problem until now. I recently did a clean install on a server with Fedora Core 8 and ISPConfig. Today I started seeing some strangeness and found this problem. My /etc/group and /etc/gshadow files are empty except the last entry put in by ISPConfig. All groups including system groups 0-500 were removed.

Seems to be a problem someplace.
Reply With Quote
Sponsored Links
  #22  
Old 30th November 2007, 14:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,714 Times in 2,556 Posts
Default

Are there any errors/warnings in /home/admispconfig/ispconfig/ispconfig.log?
What's the output of
Code:
ls -la /root/ispconfig
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #23  
Old 30th November 2007, 16:19
allwayson allwayson is offline
Junior Member
 
Join Date: Sep 2006
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default group file

I didn't see anything in the log which is troubling. It litterally took me an hour just to track down that it might be related to ISPConfig because nothing showed any errors in any logs.

Here is the result of ls -la /root/ispconfig:

[root@ron ~]# ls -la /root/ispconfig
total 108
drwxr-xr-x 9 root root 4096 Nov 29 15:27 .
drwxr-x--- 9 root root 4096 Nov 29 14:21 ..
-rwxr-xr-x 1 root root 40157 Nov 6 14:52 cronolog
-rwxr-xr-x 1 root root 9673 Nov 6 14:52 cronosplit
drwxr-xr-x 12 root root 4096 Nov 6 14:41 httpd
drwxr-xr-x 15 root root 4096 Nov 6 14:52 isp
-rw-r--r-- 1 root root 8 Nov 29 15:27 .old_path_httpd_root
drwxr-xr-x 6 root root 4096 Nov 6 14:38 openssl
drwxr-xr-x 6 root root 4096 Nov 6 14:45 php
drwxr-xr-x 4 root root 4096 Nov 6 14:52 scripts
drwxr-xr-x 4 root root 4096 Nov 6 14:52 standard_cgis
drwxr-xr-x 2 root root 4096 Nov 6 14:52 sv
-rwx------ 1 root root 9389 Nov 6 14:52 uninstall
[root@ron ~]#
Reply With Quote
  #24  
Old 30th November 2007, 16:25
allwayson allwayson is offline
Junior Member
 
Join Date: Sep 2006
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default warnings/errors

There are no errors that show in the log but I thought I would post the warnings in case there is anything in them that might give you a clue.

[root@ron ispconfig]# grep -i 'warn' ispconfig.log
08.11.2007 - 09:16:05 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: WARNING: could not /etc/rc.d/init.d/named restart &> /dev/null
08.11.2007 - 09:23:30 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: WARNING: could not /etc/rc.d/init.d/named restart &> /dev/null
08.11.2007 - 10:15:24 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: WARNING: could not /etc/rc.d/init.d/named restart &> /dev/null
15.11.2007 - 14:06:03 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: WARNING: could not /etc/rc.d/init.d/named restart &> /dev/null
15.11.2007 - 14:07:06 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: WARNING: could not /etc/rc.d/init.d/named restart &> /dev/null
15.11.2007 - 15:47:59 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2447: WARNING: could not httpd -t &> /dev/null
15.11.2007 - 15:47:59 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2458: httpd syntax seems to contain errors, reloading with old configuration
15.11.2007 - 15:49:10 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2447: WARNING: could not httpd -t &> /dev/null
15.11.2007 - 15:49:10 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2458: httpd syntax seems to contain errors, reloading with old configuration
20.11.2007 - 09:14:33 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: WARNING: could not /etc/rc.d/init.d/named restart &> /dev/null
20.11.2007 - 09:50:44 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: WARNING: could not /etc/rc.d/init.d/named restart &> /dev/null
20.11.2007 - 15:05:33 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2447: WARNING: could not httpd -t &> /dev/null
20.11.2007 - 15:05:33 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2458: httpd syntax seems to contain errors, reloading with old configuration
28.11.2007 - 15:19:07 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 289: WARNING: could not postmap hash:/etc/postfix/virtusertable
28.11.2007 - 15:19:07 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 289: WARNING: could not postmap hash:/etc/postfix/virtusertable
28.11.2007 - 15:19:28 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 289: WARNING: could not postmap hash:/etc/postfix/virtusertable
28.11.2007 - 15:25:38 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 289: WARNING: could not postmap hash:/etc/postfix/virtusertable
28.11.2007 - 15:30:40 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 289: WARNING: could not postmap hash:/etc/postfix/virtusertable
28.11.2007 - 23:59:01 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: WARNING: could not /etc/rc.d/init.d/proftpd start &> /dev/null
28.11.2007 - 23:59:02 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: WARNING: could not /etc/rc.d/init.d/postfix stop &> /dev/null
28.11.2007 - 23:59:04 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: WARNING: could not /etc/rc.d/init.d/postfix start &> /dev/null
29.11.2007 - 10:04:03 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: WARNING: could not /etc/rc.d/init.d/httpd restart &> /dev/null
29.11.2007 - 10:04:04 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: WARNING: could not /etc/rc.d/init.d/postfix stop &> /dev/null
29.11.2007 - 10:04:06 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: WARNING: could not /etc/rc.d/init.d/postfix start &> /dev/null
29.11.2007 - 10:04:06 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: WARNING: could not /etc/rc.d/init.d/named stop &> /dev/null
29.11.2007 - 10:04:06 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: WARNING: could not /etc/rc.d/init.d/proftpd restart &> /dev/null
29.11.2007 - 10:50:11 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: WARNING: could not /etc/rc.d/init.d/named stop &> /dev/null
29.11.2007 - 11:14:55 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: WARNING: could not /etc/rc.d/init.d/named stop &> /dev/null
[root@ron ispconfig]#
Reply With Quote
  #25  
Old 1st December 2007, 13:00
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,714 Times in 2,556 Posts
Default

I guess the warnings come from the group file being empty. But there's no indication why the group file is empty...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #26  
Old 1st December 2007, 15:58
allwayson allwayson is offline
Junior Member
 
Join Date: Sep 2006
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default It is strange

Yes no indication as to why. However I can say that I have 3 servers running ISPConfig they are all the exact same set up except that this is the newest one and it is running 2.2.18 and my others are 2.2.6. Not sure if something has changed between these version as far as creating accounts?

Just to clarify the group file was not entirely empty it simply only had the last entry in it that was created by ISPConfig.
Reply With Quote
  #27  
Old 2nd December 2007, 19:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,714 Times in 2,556 Posts
Default

Do you have a backup of your group fle from before the groups were removed?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #28  
Old 2nd December 2007, 20:10
allwayson allwayson is offline
Junior Member
 
Join Date: Sep 2006
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default amature

Nooooo. Amature mistake. I have backups now of that systems group/passwd/gshadow files but I did not before this happened. I used the systems groups from another of my servers (fortunatly I use similar setups on all my boxes). I only had to manually add back in the 10 groups that had been added by ISPConfig since I had built this system. This system has only been online a couple of weeks also in case I had not mentioned that before.
Reply With Quote
  #29  
Old 21st April 2008, 09:35
Morons Morons is offline
Senior Member
 
Join Date: Aug 2006
Posts: 189
Thanks: 8
Thanked 15 Times in 7 Posts
 
Default

Quote:
Originally Posted by till
Are the users duplicated or are there users with duplicate ID numbers while the usernames are not identical? Did you ever reinstall ISPConfig after you created users with a prior ISPConfig version which might be still on the server?
Sorry till, I did't see your question, sortoff missed it It could be caused by the fact that I only receive one message about replay's from the forum per day and this one was the second!

No only the group called users was duplicated, it seems an exact match and as far as I could see ISPC creadtes the 2nd Group entry and thus the shadow also duplicates it. This cause some need to manipulate the group and its shadow file manually before it works again.
I have migrated from one Destro to another and all users 0-500 were seen as been created by the systeminstall. I have ade no users manually before appending the users > 500 to the new passwd file as well as the group file. Both my source and destination was pwunconv/grpunconv before the manual appending and afterwards pwconv/grpconv afterwards. pwck and grpck was run to test before loading or re-starting ISPC/re-boot Remember the mySql data and the /var/www data was also restored. After the re-boots I found some conflicts with the std apache user that changed but as soon as i did some chown on the user web/mail directories all was well.

Last edited by Morons; 21st April 2008 at 09:43.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems getting through the installation klausagnoletti Installation/Configuration 4 26th September 2005 12:23
proftpd problems Ovidiu Installation/Configuration 5 21st September 2005 10:47
Problems installing ISPConfig Debian Sarge hschel Server Operation 4 22nd August 2005 19:46
Little problems setting up the ISPConfig Luciano Installation/Configuration 1 15th August 2005 20:17
apt problems bluntman HOWTO-Related Questions 1 29th July 2005 11:17


All times are GMT +2. The time now is 03:23.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.