#31  
Old 28th October 2006, 09:33
jnsc jnsc is offline
rotaredoM
 
Join Date: Mar 2006
Location: Lausanne, Switzerland
Posts: 525
Thanks: 10
Thanked 172 Times in 77 Posts
Default

For your problem in wich log did you check?

In /var/log/apache2/error.log (the path may vary form one distribution to another) or did you check in the log of your domain /home/www/webX/log/error.log?
Reply With Quote
Sponsored Links
  #32  
Old 29th October 2006, 01:48
djtremors djtremors is offline
Senior Member
 
Join Date: Apr 2006
Location: Sydney
Posts: 278
Thanks: 0
Thanked 12 Times in 10 Posts
Default Bugs

Besides my apache not being installed in /etc/apache but in redhats default /etc/httpd/conf/httpd.conf which you could make a simple test if either exists or use httpd -V to find it I found other issues.

1. /root/ispconfig/scripts/shell/awstats.php (Added double backslash to $file href)
PHP Code:
<?php
$dir 
".\";

if( \$dh = opendir(\$dir)) {
        while ((\$file = readdir(\$dh)) !== false) {
                \$pattern = 'awstats\..*\.[0-9]{4}-[0-9]{2}\.html';
                if (ereg(\$pattern, \$file)) {
                        echo \"<a href=\\"
$file">\$file</a><br />\";
                }
        }
}
# Arrgh forum is stripping my slashes.. 
# should be href= bsl bsl " 
$file bsl bsl "
?>
2. remember that this create multiple set of files (over night it was 248KB for 1 day), this will grow unlike the awstats mod I did which uses the DB lookup to any date/month/year dynamically. These files are owned by the admin user so the quotas apply.

At least the installer quite well done besides the apache problem I had.. still gotta get time to get mine done.

Last edited by djtremors; 29th October 2006 at 01:52.
Reply With Quote
  #33  
Old 31st October 2006, 15:25
jnsc jnsc is offline
rotaredoM
 
Join Date: Mar 2006
Location: Lausanne, Switzerland
Posts: 525
Thanks: 10
Thanked 172 Times in 77 Posts
Default

Thank's for you comments, I will have a look at your suggestions when I have a little bit more time.
Reply With Quote
  #34  
Old 5th November 2006, 01:20
rene.kirkegaard rene.kirkegaard is offline
Junior Member
 
Join Date: Nov 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Help Please

I just installed your script followed all the instructions on your website, but I have a problem with it.

When my server made the Awstas dir. it creates a bunch of files, and an Index.php file. (20 stats files)

When I try to enter the Awstas directory, i get this error.

Parse error: parse error, unexpected T_VARIABLE, expecting ',' or ';' in /var/www/web9/web/awstats/index.php on line 11


And heres the php file :

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<html>
<body>
<?php
$dir = ".";

if( $dh = opendir($dir)) {
while (($file = readdir($dh)) !== false) {
$pattern = 'awstats\..*\.[0-9]{4}-[0-9]{2}\.html';
if (ereg($pattern, $file)) {
echo "<a href="$file">$file</a><br />";
}
}
}
?>
</body>
</html>


Anyone who can help me out ??
Reply With Quote
  #35  
Old 5th November 2006, 01:27
djtremors djtremors is offline
Senior Member
 
Join Date: Apr 2006
Location: Sydney
Posts: 278
Thanks: 0
Thanked 12 Times in 10 Posts
Default

Read my post above. the line is missing a back slash and I got the same error.

You need to add another back slash to the slashes around the $file word in the "echo" statement.

I tried to put my example fix but this forum keeps stripping my slashes.
Reply With Quote
  #36  
Old 5th November 2006, 12:52
rene.kirkegaard rene.kirkegaard is offline
Junior Member
 
Join Date: Nov 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Did that and get this error now :

Parse error: parse error, unexpected T_VARIABLE in /var/www/web9/web/awstats/index.php on line 11
Reply With Quote
  #37  
Old 5th November 2006, 16:08
jnsc jnsc is offline
rotaredoM
 
Join Date: Mar 2006
Location: Lausanne, Switzerland
Posts: 525
Thanks: 10
Thanked 172 Times in 77 Posts
Default

As djtremors told you, you have to change the /root/ispconfig/scripts/shell/awstats.php file not the index.php. After that you have to remove your index.php file and run
Code:
/root/ispconfig/php/php /root/ispconfig/scripts/shell/awstats.php
that will regenerate your index.php file
Reply With Quote
  #38  
Old 5th November 2006, 17:01
jnsc jnsc is offline
rotaredoM
 
Join Date: Mar 2006
Location: Lausanne, Switzerland
Posts: 525
Thanks: 10
Thanked 172 Times in 77 Posts
Default

I updated the installer just do the following steps :

Code:
wget http://jnsc.ch/downloads/ISPConfig_awstats_pkg_alpha-5.tar.gz
Code:
 tar -xvzf ISPConfig_awstats_pkg_alpha-5.tar.gz
Code:
cd ISPConfig_awstats_pkg
Code:
cp awstats.php /root/ispconfig/scripts/shell/awstats.php
Code:
rm /home/www/web9/web/awstats/index.php
Code:
/root/ispconfig/php/php /root/ispconfig/scripts/shell/awstats.php

Last edited by jnsc; 2nd December 2008 at 17:07.
Reply With Quote
  #39  
Old 5th November 2006, 22:50
domino domino is offline
Senior Member
 
Join Date: Aug 2005
Posts: 364
Thanks: 0
Thanked 9 Times in 8 Posts
Default

I never got a chance to thank you for this. Soooo.. Thanks!! The update went well. Can you please post a changelog in future versions?

thank you
__________________
Shuttle XPC | Intel 865g | P4 3.2Ghz | ATI 9800 Pro
Hosts: Ubuntu 6.10 ~ XGL-Beryl SVN-Gnome | OS X 10.4.8 | WindowsXP
Virtual Appliances: Ubuntu Server 6.10 | WindowsXP | CentOS 4.4
Reply With Quote
  #40  
Old 5th November 2006, 22:58
jnsc jnsc is offline
rotaredoM
 
Join Date: Mar 2006
Location: Lausanne, Switzerland
Posts: 525
Thanks: 10
Thanked 172 Times in 77 Posts
 
Default

Yes, a changelog would be a good idea. Thank's for this sugestion.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Configuring Awstats for ispconfig feanor Installation/Configuration 26 23rd February 2009 19:14
AWStats as .pkg-AddOn-package TobiasTM Feature Requests 8 13th October 2006 17:27
Suse Ispconfig and AWstats shajazzi Installation/Configuration 4 15th May 2006 23:04
php-nuke installer... how to do it? danf.1979 General 8 20th December 2005 19:23
Help config Awstats domino Programming/Scripts 4 6th September 2005 06:47


All times are GMT +2. The time now is 05:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.