#51  
Old 12th November 2006, 15:44
jfruano jfruano is offline
Member
 
Join Date: Mar 2006
Posts: 95
Thanks: 9
Thanked 0 Times in 0 Posts
Default

Quote:
The line 1143 is just for "List of visible flags that links to other language translations." That means other translations of the AWStats-Sites. But to show this you can set the standard-language in line 891.
Thank you Tobias, the line has left it as was.

But doesn't reason show the countries that ip unknown and a1 ?

Thanks
Reply With Quote
Sponsored Links
  #52  
Old 13th November 2006, 12:45
jfruano jfruano is offline
Member
 
Join Date: Mar 2006
Posts: 95
Thanks: 9
Thanked 0 Times in 0 Posts
Default Generate awstats report for a old month

how to generate awstats report for a old month (previous) ?

any suggestions?

Thanks.
Reply With Quote
  #53  
Old 13th November 2006, 12:54
jnsc jnsc is offline
rotaredoM
 
Join Date: Mar 2006
Location: Lausanne, Switzerland
Posts: 525
Thanks: 10
Thanked 170 Times in 77 Posts
Default

Try this

Code:
perl /home/admispconfig/ispconfig/tools/awstats/tools/awstats_buildstaticpages.pl -year=2006 -month=10 -config=www.myhostname.com  -awstatsprog=/home/admispconfig/ispconfig/tools/awstats/wwwroot/cgi-bin/awstats.pl -builddate=2006-10 -dir=/home/www/webX/web/awstats
Don't forget to replace -config=www.myhostname.com with your hostname and -dir=/home/www/webX/web/awstats with the right directory
Reply With Quote
  #54  
Old 16th November 2006, 14:10
jfruano jfruano is offline
Member
 
Join Date: Mar 2006
Posts: 95
Thanks: 9
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by jnsc
Try this

Code:
perl /home/admispconfig/ispconfig/tools/awstats/tools/awstats_buildstaticpages.pl -year=2006 -month=10 -config=www.myhostname.com  -awstatsprog=/home/admispconfig/ispconfig/tools/awstats/wwwroot/cgi-bin/awstats.pl -builddate=2006-10 -dir=/home/www/webX/web/awstats
Don't forget to replace -config=www.myhostname.com with your hostname and -dir=/home/www/webX/web/awstats with the right directory
Thanks jnsc.

But doesn't work well, it generates the statistics but without any data of the month October

Any suggestion ?
Reply With Quote
  #55  
Old 16th November 2006, 16:21
jnsc jnsc is offline
rotaredoM
 
Join Date: Mar 2006
Location: Lausanne, Switzerland
Posts: 525
Thanks: 10
Thanked 170 Times in 77 Posts
Default

Try to add the following line to the command I already posted

Code:
-logfile=/home/www/webX/log/2006/10/web.log
Reply With Quote
  #56  
Old 18th November 2006, 12:59
IKShadow IKShadow is offline
Member
 
Join Date: Jan 2006
Location: Slovenia
Posts: 85
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to IKShadow
Exclamation

Hi

I installed latest version on my perect suse 10.1 + ispconfig.

At the end of instalation i saw error:
Code:
sed: can't read /etc/apache2/apache2.conf: No such file or directory
I run command to generate statistics and its working ... the only problem is ... there is no images (flags etc..)

How can I fix this.

Missing image's path is:
http://mydomain.com/icon/*/*.png

Actual web server path is:
/srv/www/web16/web ( the awstats folder was created in it)

I checked for path:
/etc/apache2/apache2.conf and the file its not there.

Then I tried to search for it (apache2.conf) but I could not find it.

Sorry Iam realy linux n00b.

Last edited by IKShadow; 18th November 2006 at 13:13.
Reply With Quote
  #57  
Old 18th November 2006, 13:43
IKShadow IKShadow is offline
Member
 
Join Date: Jan 2006
Location: Slovenia
Posts: 85
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to IKShadow
Default

update:

I found that /etc/apache2/httpd.conf includes default-server.conf.

In default-server.conf I remarked existing icons alias:
Code:
#Alias /icons/ "/usr/share/apache2/icons/"

#<Directory "/usr/share/apache2/icons">
#       Options Indexes MultiViews
#       AllowOverride None
#       Order allow,deny
#       Allow from all
#</Directory>
and copy this one:

Code:
Alias /icon/ "/home/admispconfig/ispconfig/tools/awstats/wwwroot/icon/"

<Directory "/home/admispconfig/ispconfig/tools/awstats/wwwroot/icon">
Options MultiViews
AllowOverride All
Order allow,deny
Allow from all
</Directory>
I restarted apache2 server ( /etc/init.d/apache2 restart ), but I still dont see images.

I try to open one from browser and i receive:
Code:
Forbidden
You don't have permission to access /icon/cpu/digital.png on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
Permissions:
Code:
krneki:/ # ls -la /home/admispconfig/ispconfig/tools/awstats/wwwroot/icon
total 40
drwxr-xr-x 9 1007 513 4096 2005-12-24 22:10 .
drwxr-xr-x 7 1007 513 4096 2005-12-24 22:10 ..
d-wx--x--x 2 1007 513 4096 2005-12-24 22:10 browser
d-wx--x--x 2 1007 513 4096 2005-12-24 22:10 clock
drwxrwxrwx 2 1007 513 4096 2005-12-24 22:10 cpu
d-wx--x--x 2 1007 513 8192 2005-12-24 22:10 flags
d-wx--x--x 2 1007 513 4096 2005-12-24 22:10 mime
d-wx--x--x 2 1007 513 4096 2005-12-24 22:10 os
d-wx--x--x 2 1007 513 4096 2005-12-24 22:10 other
krneki:/ # ls -la /home/admispconfig/ispconfig/tools/awstats/wwwroot
total 28
drwxr-xr-x 7 1007 513 4096 2005-12-24 22:10 .
drwxr-xr-x 5 1007 513 4096 2005-12-24 22:09 ..
drwxr-xr-x 5 1007 513 4096 2005-12-24 22:10 cgi-bin
drwxr-xr-x 3 1007 513 4096 2005-12-24 22:10 classes
drwxr-xr-x 2 1007 513 4096 2005-12-24 22:10 css
drwxr-xr-x 9 1007 513 4096 2005-12-24 22:10 icon
drwxr-xr-x 2 1007 513 4096 2005-12-24 22:10 js
krneki:/ # ls -la /home/admispconfig/ispconfig/tools/awstats
lrwxrwxrwx 1 root root 46 2006-11-18 12:29 /home/admispconfig/ispconfig/tools/awstats -> /home/admispconfig/ispconfig/tools/awstats-6.5
krneki:/ # ls -la /home/admispconfig/ispconfig/tools
total 36
drwxr-xr-x 9 admispconfig admispconfig 4096 2006-11-18 12:29 .
drwxr-xr-x 8 admispconfig admispconfig 4096 2006-11-18 13:46 ..
lrwxrwxrwx 1 root         root           46 2006-11-18 12:29 awstats -> /home/admispconfig/ispconfig/tools/awstats-6.5
drwxr-xr-x 5         1007          513 4096 2005-12-24 22:09 awstats-6.5
drwxr-xr-x 8 admispconfig admispconfig 4096 2006-11-16 00:12 clamav
drwxr-xr-x 4 admispconfig admispconfig 4096 2006-11-16 00:13 spamassassin
drwxr-xr-x 2 admispconfig admispconfig 4096 2006-11-16 00:16 tcpserver
drwxr-xr-x 2 admispconfig admispconfig 4096 2006-11-16 00:16 unzip
drwxr-xr-x 4 admispconfig admispconfig 4096 2006-11-16 00:14 uudeview
drwxr-xr-x 2 admispconfig admispconfig 4096 2006-11-16 00:16 zip
I chmoded 777 cpu and digital.png just to check if it works ... unfortunatly it does not


I would realy appriciate any help you can give me couse I dont have any idea now how to solve it.

Last edited by IKShadow; 18th November 2006 at 13:52.
Reply With Quote
  #58  
Old 19th November 2006, 21:57
jnsc jnsc is offline
rotaredoM
 
Join Date: Mar 2006
Location: Lausanne, Switzerland
Posts: 525
Thanks: 10
Thanked 170 Times in 77 Posts
Default

Hi,

This part is not necessary
Code:
<Directory "/home/admispconfig/ispconfig/tools/awstats/wwwroot/icon">
Options MultiViews
AllowOverride All
Order allow,deny
Allow from all
</Directory>
Try this
Code:
chown -R admispconfig:admispconfig /home/admispconfig/ispconfig/tools/awstats/wwwroot/icon/
And check your apache error logs.
Reply With Quote
  #59  
Old 20th November 2006, 09:26
IKShadow IKShadow is offline
Member
 
Join Date: Jan 2006
Location: Slovenia
Posts: 85
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to IKShadow
Default

Thanks for suggestion.

I still have same problem.


Here is copy/paste from LOG file:

[Mon Nov 20 09:18:25 2006] [error] [client 213.143.90.139] Symbolic link not allowed or link target not accessible: /home/admispconfig/ispconfig/tools/awstats, referer: http://www.ikshadow.com/awstats/awst...m.2006-11.html
[Mon Nov 20 09:18:37 2006] [error] [client 213.143.90.139] Symbolic link not allowed or link target not accessible: /home/admispconfig/ispconfig/tools/awstats
Reply With Quote
  #60  
Old 20th November 2006, 10:36
jnsc jnsc is offline
rotaredoM
 
Join Date: Mar 2006
Location: Lausanne, Switzerland
Posts: 525
Thanks: 10
Thanked 170 Times in 77 Posts
 
Default

Hi,

try to add "FollowSymLinks" to the "Options" line of of Apache's Directory section. Like Below.

Code:
<Directory "/home/admispconfig/ispconfig/tools/awstats/wwwroot/icon">
Options MultiViews FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all
</Directory>
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Configuring Awstats for ispconfig feanor Installation/Configuration 26 23rd February 2009 19:14
AWStats as .pkg-AddOn-package TobiasTM Feature Requests 8 13th October 2006 17:27
Suse Ispconfig and AWstats shajazzi Installation/Configuration 4 15th May 2006 23:04
php-nuke installer... how to do it? danf.1979 General 8 20th December 2005 19:23
Help config Awstats domino Programming/Scripts 4 6th September 2005 06:47


All times are GMT +2. The time now is 18:16.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.