#1  
Old 6th October 2006, 14:30
baboonish baboonish is offline
Junior Member
 
Join Date: Oct 2006
Posts: 6
Thanks: 1
Thanked 0 Times in 0 Posts
Default config.inc.php

Ok, I decided to try reinstalling ISPConfig 2.2.6 because of the problems I'd been experiencing.

When I do the install it completes without errors, however when I try going to the control panel login page I get errors saying that ../lib/config.inc.php and ./login/lib/lang/.lng cannot be found because they do not exist.

I'm using debian sarge 3.1

Can you suggest anything to help?
Reply With Quote
Sponsored Links
  #2  
Old 6th October 2006, 19:18
baboonish baboonish is offline
Junior Member
 
Join Date: Oct 2006
Posts: 6
Thanks: 1
Thanked 0 Times in 0 Posts
Default

So, I've resolved the above problem, now when I try to log in I get the following errors..

Warning: mysql_connect() [function.mysql-connect]: Client does not support authentication protocol requested by server; consider upgrading MySQL client in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77

Warning: mysql_connect() [function.mysql-connect]: Client does not support authentication protocol requested by server; consider upgrading MySQL client in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77

Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php:77) in /home/admispconfig/ispconfig/web/login/login.php on line 60

I'm using mysql5 on debian 3.1 and the server was installed using the perfect setup. mysql 5 is needed because some of the sites hosted on the box rely on it.

Can anyone help?
Reply With Quote
  #3  
Old 7th October 2006, 13:23
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by baboonish
So, I've resolved the above problem, now when I try to log in I get the following errors..

Warning: mysql_connect() [function.mysql-connect]: Client does not support authentication protocol requested by server; consider upgrading MySQL client in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77
Please update your MySQL client package and the MySQL-devel package. You might also need to recompile ISPConfig's PHP.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 7th October 2006, 15:21
baboonish baboonish is offline
Junior Member
 
Join Date: Oct 2006
Posts: 6
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Ok, I've got libmysqlclient15-dev and libmysqlclient15off both installed, I rebuilt ISPConfig and I get the same error when I try to log in.
Reply With Quote
  #5  
Old 7th October 2006, 18:24
baboonish baboonish is offline
Junior Member
 
Join Date: Oct 2006
Posts: 6
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Ok, got this solved thanks to the helpfulness of a friend.

What I had to do was log into the mysql console and use the following code to fix the problem:
Code:
UPDATE user SET password=OLD_PASSWORD('mypass') WHERE user = 'ispconfiguser';
This then solved the issue.
Reply With Quote
  #6  
Old 8th October 2006, 15:29
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Maybe this is also interesting for you: http://www.howtoforge.com/forums/showthread.php?t=7313
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
settings in config.inc.php Ovidiu Installation/Configuration 5 24th August 2006 17:14
"mail_" entries in config.inc.php Davide Installation/Configuration 1 2nd August 2006 09:50
Can't get Ispcontrol login screen Witton Installation/Configuration 8 27th December 2005 17:43


All times are GMT +2. The time now is 23:01.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.