Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th October 2006, 06:22
bluethunder82 bluethunder82 is offline
Member
 
Join Date: Sep 2006
Posts: 92
Thanks: 0
Thanked 9 Times in 5 Posts
Default Spamassassin Auto-generated Email

Hi, I have searched the forum and net now for too long. Time to break down and ask the forum. This should be really easy (I hope).

I have enabled spamassassin and it is working. HOWEVER, when I get an email tagged **SPAM** the body of the email directs me to ask questions to 1postmaster@bijouenhancements.com. This should read postmaster.

I have read through the perfect setup docs, looked in the spamassassin folders within /home/ . . ., the users .spamassassin, postfix config files. I am not sure where this address is coming from. Worse case I can just create an alias for 1postmaster but I'm thinking this was just a slip of the finger 'sometime' and I need to correct.

** from email **
Spam detection software, has identified this incoming email as possible spam. The original message has been attached to this so you can view it (if it isn't spam) or label similar future email. If you have any questions, see 1postmaster@bijouenhancements.com for details.
** end email **

Thanks for all the help.
Reply With Quote
Sponsored Links
  #2  
Old 5th October 2006, 10:51
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,186
Thanks: 829
Thanked 5,417 Times in 4,259 Posts
Default

The domain bijouenhancements.com is your domain?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 5th October 2006, 17:39
bluethunder82 bluethunder82 is offline
Member
 
Join Date: Sep 2006
Posts: 92
Thanks: 0
Thanked 9 Times in 5 Posts
Default

Yes bijouenhancements.com is my domain.

As I said above the problem lies in the email sending the user to 1postmaster instead of just postmaster.
Reply With Quote
  #4  
Old 5th October 2006, 19:02
fobicodam fobicodam is offline
Senior Member
 
Join Date: Apr 2006
Location: Argentina
Posts: 346
Thanks: 0
Thanked 1 Time in 1 Post
Send a message via MSN to fobicodam
Default

Isnt it the main postfix administrator's email? it should be on /etc/postfix/main.conf
Reply With Quote
  #5  
Old 5th October 2006, 22:34
bluethunder82 bluethunder82 is offline
Member
 
Join Date: Sep 2006
Posts: 92
Thanks: 0
Thanked 9 Times in 5 Posts
Default

I have already checked my main.cf file. Here is a copy anyways.

main.cf **
smtpd_banner = $myhostname ESMTP $mail_name
biff = no

append_dot_mydomain = no

smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = no
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

myhostname = nexis.shewchuk.ca
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
relayhost =
mynetworks = 127.0.0.0/8
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination,
reject_rbl_client sbl-xbl.spamhaus.org,
reject_rbl_client cbl.abuseat.org,
reject_rbl_client relays.ordb.org,
reject_rbl_client bl.spamcop.net

smtpd_tls_auth_only = no
smtp_use_tls = no
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = localhost, /etc/postfix/local-host-names, 127.0.0.1
**
Reply With Quote
  #6  
Old 6th October 2006, 14:23
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Please check your ISPConfig settings under Management -> Server -> Settings.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 6th October 2006, 14:28
bluethunder82 bluethunder82 is offline
Member
 
Join Date: Sep 2006
Posts: 92
Thanks: 0
Thanked 9 Times in 5 Posts
Default

That was the first area I checked. I don't have any postmaster email addresses present.

The fields that contain email addresses are:
Server,Email, DNS -> Admin Email

This really isn't making much sense. I don't even recall needing to enter postmaster@bijouenhancements.com before.
Reply With Quote
  #8  
Old 6th October 2006, 14:32
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Did you check in the mail's header that the mail really came from your server? Maybe it's just another spam attempt from someone else who tries to make the mail look like it was generated by your server.

Also, do you see anything in your mail log when you receive such a mail?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 7th October 2006, 03:52
bluethunder82 bluethunder82 is offline
Member
 
Join Date: Sep 2006
Posts: 92
Thanks: 0
Thanked 9 Times in 5 Posts
Default

The messages do appear correctly in my log. The Headers are also correct.

Under the email tab in Management where would my "Admin email address" be found saved?

Thanks for the ideas.
Reply With Quote
  #10  
Old 7th October 2006, 13:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Quote:
Originally Posted by bluethunder82
Under the email tab in Management where would my "Admin email address" be found saved?
It's in the isp_server table in the ISPConfig database.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix Email Delivery Problem sedat1903 HOWTO-Related Questions 2 22nd December 2008 11:19
Problem with 'CC' & 'BCC' email not being delivered. snowfly HOWTO-Related Questions 10 20th July 2006 12:36
config spamassassin hotchilli Server Operation 1 8th July 2006 12:03
Multiple MySQL Queries - with Postfix-mysql, courier-authmysql, maildrop-mysql... snowfly HOWTO-Related Questions 4 7th July 2006 04:19
email forwarding locally consumes all resources rdells General 20 1st May 2006 19:43


All times are GMT +2. The time now is 14:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.