#1  
Old 4th October 2006, 18:36
glasprilla glasprilla is offline
Junior Member
 
Join Date: Oct 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy PHP5 and Firebird on SUSE 10.1

Hi

I have try and try to compile PHP5 on SUSE 10,1 with support for Data Bases: Firebird - Interbase, with handling of sessions, has supported for MySQL, Postgres and also ISPConfig. Somebody has worked to him to the subject:
Compiling:
checking for new_aspell_config in - laspell… no
checking for libedit readline replacement… no
checking for readline support… yes checking for tgetent in - lncurses… no
checking for tgetent in - ltermcap… no
checking for readline in - lreadline… no form: error: readline library not found

Library readline library not found bu required.
Are there a modulate rpm php-firebird for SUSE 10.1?
Help please.
Reply With Quote
Sponsored Links
  #2  
Old 5th October 2006, 17:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

You can run
Code:
yast
and search for the appropriate package. But I think the package is named readline, so you can try to install it like this:
Code:
yast -i readline
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 6th October 2006, 05:35
glasprilla glasprilla is offline
Junior Member
 
Join Date: Oct 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Thumbs up PHP5 and Firebird 2.0 on SUSE 10.1 OK

Falko

Readline is not avaliable on repositories for SUSE, Error have not been the following packages in the support: readline, but already I solved it, as it follows:

Download of: www.rpmfind.net :

- Firebird/FirebirdSS- 2.0.0.127 24-ReleaseCandidate4.i686.rpm
Distrbution SourceForge.
- Firebird/php-firebird-5.1.6-1mdv2007.0.i586.rpm
Distribution Mandriva (Its Ok for SUSE)

Install them with:
---------------
rpm -Uvh Firebird/FirebirdSS- 2.0.0.127 24-ReleaseCandidate4.i686.rpm
rpm -Uvh Firebird/php-firebird-5.1.6-1mdv2007.0.i586.rpm
---------------
Verify if acceptance the Firebird module with command:
---------------
php5 - m
[PHP Modules]
bcmath
bz2
calendar
ctype
curl
date
dbase
dom
exif
filepro
ftp
gd
gettext
gmp
hash
iconv
imap
interbase
ldap
libxml
mbstring
mcrypt
mhash
mysql
mysqli
ncurses
odbc
openssl
pcntl
pcre
PDO
pgsql
posix
pspell
Reflection
session
shmop
SimpleXML
snmp
soap
sockets
SPL
SQLite
standard
sysvmsg
sysvsem
sysvshm
tokenizer
wddx
xml
xmlrpc
xsl
zlib

[Zend Modules]
--------------
Module listed as: interbase

Next: copy file interbase.so to extensions directory for PHP5, as follow:

cp /usr/lib/php/extensions/interbase.so /usr/lib/php5/extensions/

Next: copy 42_firebird.ini file to loader extensions for PHP5, as follow:

cp /etc/php.d/42_firebird.ini /etc/php5/conf.d/

Next: restart ISPConfig o Apache2

/etc/init.d/ispconfig_server restart
o
/etc/init.d/apache2 restart

Ready, OK
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 00:50.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.