Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th September 2006, 16:41
planet_fox planet_fox is offline
Senior Member
 
Join Date: Jun 2006
Location: Munic
Posts: 308
Thanks: 14
Thanked 6 Times in 4 Posts
Send a message via Skype™ to planet_fox
Default Thunderbird + Courier + sassl

I have use The Perfect Setup - Debian Sarge (3.1) use and ISPConfig.

I can recieve emails from webmail and send .

Thunderbird recive emails and can't send mail.
When I do connect to Server Login failed

Logfile mail.log

PHP Code:
Sep 27 16:26:33 localhost postfix/smtpd[18186]: connect from pd95b4b73.dip0.t-ipconnect.de[217.91.75.112]
Sep 27 16:26:37 localhost postfix/smtpd[18186]: warningSASL authentication failurePassword verification failed
Sep 27 16
:26:37 localhost postfix/smtpd[18186]: warningpd95b4b73.dip0.t-ipconnect.de[217.91.75.112]: SASL PLAIN authentication failed
Sep 27 16
:26:38 localhost postfix/smtpd[18186]: warningpd95b4b73.dip0.t-ipconnect.de[217.91.75.112]: SASL LOGIN authentication failed
Sep 27 16
:26:41 localhost postfix/smtpd[18186]: warningSASL authentication failurePassword verification failed
Sep 27 16
:26:41 localhost postfix/smtpd[18186]: warningpd95b4b73.dip0.t-ipconnect.de[217.91.75.112]: SASL PLAIN authentication failed
Sep 27 16
:26:42 localhost postfix/smtpd[18186]: warningpd95b4b73.dip0.t-ipconnect.de[217.91.75.112]: SASL LOGIN authentication failed
Sep 27 16
:26:45 localhost postfix/smtpd[18186]: warningSASL authentication failurePassword verification failed
Sep 27 16
:26:45 localhost postfix/smtpd[18186]: warningpd95b4b73.dip0.t-ipconnect.de[217.91.75.112]: SASL PLAIN authentication failed
Sep 27 16
:26:46 localhost postfix/smtpd[18186]: warningpd95b4b73.dip0.t-ipconnect.de[217.91.75.112]: SASL LOGIN authentication failed
Sep 27 16
:26:53 localhost courierpop3loginConnectionip=[::ffff:217.91.75.112]
Sep 27 16:26:54 localhost courierpop3loginLOGINuser=web34_admip=[::ffff:217.91.75.112]
Sep 27 16:26:55 localhost courierpop3loginLOGOUTuser=web34_admip=[::ffff:217.91.75.112], top=0retr=0time=
The Password is korect and here whats

PHP Code:
m:~# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.localdomain.
Escape character is '^]'.
220 myserver.de ESMTP Postfix (Debian/GNU)
ehlo localhost
250
-myserver.de
250
-PIPELINING
250
-SIZE 10240000
250
-VRFY
250
-ETRN
250
-AUTH LOGIN PLAIN
250
-AUTH=LOGIN PLAIN
250 8BITMIME 
Reply With Quote
Sponsored Links
  #2  
Old 28th September 2006, 21:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,711
Thanks: 1,900
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by planet_fox
The Password is korect and here whats

PHP Code:
m:~# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.localdomain.
Escape character is '^]'.
220 myserver.de ESMTP Postfix (Debian/GNU)
ehlo localhost
250
-myserver.de
250
-PIPELINING
250
-SIZE 10240000
250
-VRFY
250
-ETRN
250
-AUTH LOGIN PLAIN
250
-AUTH=LOGIN PLAIN
250 8BITMIME 
Are you sure you followed the "Perfect Setup" as close as possible? For example, I don't see a STARTTLS line in the telnet output, so you must have done something differently from the tutorial.
Please compare your /etc/default/saslauthd and /etc/init.d/saslauthd with the ones from the tutorial.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 28th September 2006, 23:47
planet_fox planet_fox is offline
Senior Member
 
Join Date: Jun 2006
Location: Munic
Posts: 308
Thanks: 14
Thanked 6 Times in 4 Posts
Send a message via Skype™ to planet_fox
Default

this is in my /etc/default/saslauthd and /etc/init.d/saslauthd

PHP Code:
# This needs to be uncommented before saslauthd will be run automatically
START=yes

PARAMS
="-m /var/spool/postfix/var/run/saslauthd -r"

# You must specify the authentication mechanisms you wish to use.
# This defaults to "pam" for PAM support, but may also include
# "shadow" or "sasldb", like this:
# MECHANISMS="pam shadow"

MECHANISMS="pam" 
Reply With Quote
  #4  
Old 29th September 2006, 10:42
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,624
Thanks: 793
Thanked 4,996 Times in 3,909 Posts
Default

Have you started sasl by running:

/etc/init.d/saslauthd start

If this wont help, please post the content of your /etc/postfix/main.cf, comments stripped.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 29th September 2006, 14:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,711
Thanks: 1,900
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by planet_fox
this is in my /etc/default/saslauthd and /etc/init.d/saslauthd

PHP Code:
# This needs to be uncommented before saslauthd will be run automatically
START=yes

PARAMS
="-m /var/spool/postfix/var/run/saslauthd -r"

# You must specify the authentication mechanisms you wish to use.
# This defaults to "pam" for PAM support, but may also include
# "shadow" or "sasldb", like this:
# MECHANISMS="pam shadow"

MECHANISMS="pam" 
You have this in /etc/default/saslauthd AND in /etc/init.d/saslauthd?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 29th September 2006, 22:17
planet_fox planet_fox is offline
Senior Member
 
Join Date: Jun 2006
Location: Munic
Posts: 308
Thanks: 14
Thanked 6 Times in 4 Posts
Send a message via Skype™ to planet_fox
Default

here is main.cf

PHP Code:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version

smtpd_banner $myhostname ESMTP $mail_name (Debian/GNU)
biff no

# appending .domain is the MUA's job.
append_dot_mydomain no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

myhostname myserver.de
alias_maps 
hash:/etc/aliases
alias_database 
hash:/etc/aliases
relayhost 
=
mynetworks 11.135.6.333127.0.0.0/8
mailbox_size_limit 
0
recipient_delimiter 
= +
inet_interfaces all
smtpd_sasl_local_domain 
=
smtpd_sasl_auth_enable yes
smtpd_sasl_security_options 
noanonymous
broken_sasl_auth_clients 
yes
smtpd_tls_auth_only 
no
smtp_use_tls 
yes
smtp_tls_note_starttls_offer 
yes
smtpd_tls_key_file 
= /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file 
= /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile 
= /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel 
1
smtpd_tls_received_header 
yes
smtpd_tls_session_cache_timeout 
3600s
tls_random_source 
dev:/dev/urandom
home_mailbox 
Maildir/
mailbox_command =

broken_sasl_auth_clients yes

virtual_maps 
hash:/etc/postfix/virtusertable

mydestination 
= /etc/postfix/local-host-names
inet_interfaces 
all
reject_code 
550



####################################
#Postgresy#
#################################

smtpd_recipient_restrictions permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination,check_policy_service inet:127.0.0.1:$


##########
#Amavis
###########

content_filter amavis:[127.0.0.1]:10024
receive_override_options 
no_address_mappings

######################### 
Reply With Quote
  #7  
Old 29th September 2006, 22:36
planet_fox planet_fox is offline
Senior Member
 
Join Date: Jun 2006
Location: Munic
Posts: 308
Thanks: 14
Thanked 6 Times in 4 Posts
Send a message via Skype™ to planet_fox
Default

I have this in /etc/init.d/saslauthd

You want this line ?

PIDFILE="/var/spool/postfix/var/run/${NAME}/saslauthd.pid"

PHP Code:
#!/bin/sh -e

NAME=saslauthd
DAEMON
="/usr/sbin/${NAME}"
DESC="SASL Authentication Daemon"
DEFAULTS=/etc/default/saslauthd
PWDIR
=/var/run/saslauthd
PIDFILE
="/var/spool/postfix/var/run/${NAME}/saslauthd.pid"

createdir() {
# $1 = user
# $2 = group
# $3 = permissions (octal)
# $4 = path to directory
        
[ -"$4" ] || mkdir -"$4"
        
chown --"$1:$2" "$4"
        
chmod -"$3" "$4"
}

test -"${DAEMON}" || exit 0

# Source defaults file; edit that file to configure this script.
if [ -"${DEFAULTS}" ]; then
    
"${DEFAULTS}"
fi

# If we're not to start the daemon, simply exit
if [ "${START}" != "yes" ]; then
    
exit 0
fi

# If we have no mechanisms defined
if [ "x${MECHANISMS}" "x" ]; then
    
echo "You need to configure ${DEFAULTS} with mechanisms to be used"
    
exit 0
fi

# Add our mechanimsms with the necessary flag
PARAMS="${PARAMS} -a ${MECHANISMS}"

START="--start --quiet --pidfile ${PIDFILE} --startas ${DAEMON} --name ${NAME} -- ${PARAMS}"

# Consider our options
case "${1}" in
  start
)
        echo -
"Starting ${DESC}: "
        
dir=`dpkg-statoverride --list $PWDIR`
        
test -"$dir" || createdir $dir
        
if start-stop-daemon ${START} >/dev/null 2>&then
                
echo "${NAME}."
        
else
                if 
start-stop-daemon --test ${START} >/dev/null 2>&1then
                        
echo "(failed)."
                        
exit 1
                
else
                        echo 
"${DAEMON} already running."
                        
exit 0
                fi
        fi
        
;;
  
stop)
        echo -
"Stopping ${DESC}: "
        
if start-stop-daemon --stop --quiet --pidfile "${PIDFILE}" 
                
--startas ${DAEMON} --retry 10 --name ${NAME
                >/
dev/null 2>&then
                        
echo "${NAME}."
        
else
                if 
start-stop-daemon --test ${START} >/dev/null 2>&1then
                        
echo "(not running)."
                        
exit 0
                
else
                        echo 
"(failed)."
                        
exit 1
                fi
        fi
        
;;
  
restart|force-reload)
        $
0 stop
        exec 
$0 start
        
;;

                        exit 
1
                
else
                        echo 
"${DAEMON} already running."
                        
exit 0
                fi
        fi
        
;;
  
stop)
        echo -
"Stopping ${DESC}: "
        
if start-stop-daemon --stop --quiet --pidfile "${PIDFILE}" 
                
--startas ${DAEMON} --retry 10 --name ${NAME
                >/
dev/null 2>&then
                        
echo "${NAME}."
        
else
                if 
start-stop-daemon --test ${START} >/dev/null 2>&1then
                        
echo "(not running)."
                        
exit 0
                
else
                        echo 
"(failed)."
                        
exit 1
                fi
        fi
        
;;
  
restart|force-reload)
        $
0 stop
        exec 
$0 start
        
;;
  *)
        echo 
"Usage: /etc/init.d/${NAME} {start|stop|restart|force-reload}" >&2
        
exit 1
        
;;
esac

exit 
Reply With Quote
  #8  
Old 29th September 2006, 22:39
planet_fox planet_fox is offline
Senior Member
 
Join Date: Jun 2006
Location: Munic
Posts: 308
Thanks: 14
Thanked 6 Times in 4 Posts
Send a message via Skype™ to planet_fox
Default

PHP Code:
myserver:/home/foo# ps ax|grep sasl
22460 ?        Ss     0:00 /usr/sbin/saslauthd -/var/spool/postfix/var/run/saslauthd --a pam
22461 
?        S      0:00 /usr/sbin/saslauthd -/var/spool/postfix/var/run/saslauthd --a pam
22462 
?        S      0:00 /usr/sbin/saslauthd -/var/spool/postfix/var/run/saslauthd --a pam
22463 
?        S      0:00 /usr/sbin/saslauthd -/var/spool/postfix/var/run/saslauthd --a pam
22464 
?        S      0:00 /usr/sbin/saslauthd -/var/spool/postfix/var/run/saslauthd --a pam
22527 pts
/0    R+     0:00 grep sasl 
Reply With Quote
  #9  
Old 29th September 2006, 23:06
planet_fox planet_fox is offline
Senior Member
 
Join Date: Jun 2006
Location: Munic
Posts: 308
Thanks: 14
Thanked 6 Times in 4 Posts
Send a message via Skype™ to planet_fox
Default

and I have don't understand in falco Howto Postfix what I do when I use ISP config in this file. Is a Problem ?

/etc/postfix/sasl/smtpd.conf

PHP Code:
pwcheck_methodsaslauthd
mech_list
plain login
allow_plaintext
true
auxprop_plugin
mysql
sql_hostnames
127.0.0.1
#sql_user: mail_admin
#sql_passwd: mail_admin_password
#sql_database: mail
#sql_select: select password from users where email = '%u' 
I don't is wrong when I install with perfect debian how to and install ISP config install and than I have do this howto

Virtual Users And Domains With Postfix, Courier And MySQL from Falco

And I must BBig Thanks say to you for help all days !!!
Reply With Quote
  #10  
Old 30th September 2006, 00:14
planet_fox planet_fox is offline
Senior Member
 
Join Date: Jun 2006
Location: Munic
Posts: 308
Thanks: 14
Thanked 6 Times in 4 Posts
Send a message via Skype™ to planet_fox
 
Default

Oh I have do this

cat /var/log/auth.log
is this the problem, and what must I type for the sql data in /etc/postfix/sasl/smtp.conf

PHP Code:
Sep 30 00:11:34 localhost postfix/smtpd[4888]: sql_select option missing
Sep 30 00
:11:34 localhost postfix/smtpd[4888]: auxpropfunc error no mechanism available
Sep 30 00
:11:34 localhost postfix/smtpd[4888]: _sasl_plugin_load failed on sasl_auxprop_plug_init for pluginsql
Sep 30 00
:11:35 localhost saslauthd[4652]: pam_mysqlMySQL err Access denied for user 'mail_admin'@'localhost.localdomain' (using passwordYES)
Sep 30 00:11:35 localhost saslauthd[4652]: DEBUGauth_pampam_authenticate failedAuthentication failure
Sep 30 00
:11:35 localhost saslauthd[4652]: do_auth         auth failure: [user=adm@myserver.de] [service=smtp] [realm=myserver.de] [mech=pam] [reason=PAM auth error]
Sep 30 00:11:36 localhost saslauthd[4653]: pam_mysqlMySQL err Access denied for user 'mail_admin'@'localhost.localdomain' (using passwordYES)
Sep 30 00:11:36 localhost saslauthd[4653]: DEBUGauth_pampam_authenticate failedAuthentication failure
Sep 30 00
:11:36 localhost saslauthd[4653]: do_auth         auth failure: [user=adm@myserver.de] [service=smtp] [realm=myserver.de] [mech=pam] [reason=PAM auth error]
Sep 30 00:11:37 localhost saslauthd[4649]: pam_mysqlMySQL err Access denied for user 'mail_admin'@'localhost.localdomain' (using passwordYES)
Sep 30 00:11:37 localhost saslauthd[4649]: DEBUGauth_pampam_authenticate failedAuthentication failure
Sep 30 00
:11:37 localhost saslauthd[4649]: do_auth         auth failure: [user=adm@myserver.de] [service=smtp] [realm=myserver.de] [mech=pam] [reason=PAM auth error
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix sassl and courier planet_fox Installation/Configuration 5 13th July 2006 12:24
Virtual Users And Domains With Postfix, Courier And MySQL [+ procmail ?] immobilia HOWTO-Related Questions 5 29th June 2006 23:20
Virtual Users And Domains With Postfix, Courier And MySQL Question neil6179 HOWTO-Related Questions 1 18th March 2006 11:14
Virtual Users And Domains With Postfix, Courier And MySQL - "apt-get" and Courier burritonator HOWTO-Related Questions 3 15th March 2006 20:11
postfix courier not running in ssl mode? shadowsa Server Operation 4 19th December 2005 13:20


All times are GMT +2. The time now is 04:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.