Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th September 2005, 21:36
zarkann zarkann is offline
Junior Member
 
Join Date: Sep 2005
Location: Montreal, Quebec
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default Incorrectly built binary wich accesses errno or h_errno directly

OK, i have this problem when i start ISPConfig
Quote:
$ /etc/rc.d/init.d/ispconfig_tcpserver restart
Stopping ispconfig_tcpserver
Starting ispconfig_tcpserver
Incorrectly built binary which accesses errno or h_errno directly. Needs to be
fixed.
Incorrectly built binary which accesses errno or h_errno directly. Needs to be
fixed.
$
i searched everywhere on the forum and couldnt find anything, also i found something on google that it can might be a sendmail, qmail or postfix, but i dont have any mail server on this system... i have sendmail but it's disabled.

someone have any clue ?

everythings working fine... my web server is fine, wins and samba too.

EDIT:

i went into the rc.d/init.d and restarted the 2 daemon

Quote:
[xxxx@xxxx init.d]# service ispconfig_server restart
Shutting down ISPConfig system...
/root/ispconfig/httpd/bin/apachectl stop: httpd stopped
ISPConfig system stopped!
Starting ISPConfig system...
/root/ispconfig/httpd/bin/apachectl startssl: httpd started
ISPConfig system is now up and running!
[xxxx@xxxx init.d]#

[xxxx@xxxx init.d]# service ispconfig_tcpserver restart
Stopping ispconfig_tcpserver
Starting ispconfig_tcpserverIncorrectly built binary which accesses errno or h_errno directly. Needs to be fixed.
Incorrectly built binary which accesses errno or h_errno directly. Needs to be fixed.
[xxxx@xxxx init.d]#

Last edited by zarkann; 30th September 2005 at 21:52.
Reply With Quote
Sponsored Links
  #2  
Old 1st October 2005, 01:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

I guess you're using vsftpd as ftp server. If the installer detects vsftpd it installs the ispconfig_tcpserver which makes it possible that vsftpd can have one anonymous ftp per IP address (otherwise it would only have one anonymous ftp at all).
ispconfig_tcpserver doesn't come as source code, it's already compiled, but this compiled binary isn't compatible with some newer distributions. That's why we recommend the use of proftpd instead of vsftpd. proftpd doesn't need the ispconfig_tcpserver.

Which distribution do you use? Did you follow any of the tutorials on HowtoForge for setting up your server?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 3rd October 2005, 04:05
zarkann zarkann is offline
Junior Member
 
Join Date: Sep 2005
Location: Montreal, Quebec
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
I guess you're using vsftpd as ftp server. If the installer detects vsftpd it installs the ispconfig_tcpserver which makes it possible that vsftpd can have one anonymous ftp per IP address (otherwise it would only have one anonymous ftp at all).
ispconfig_tcpserver doesn't come as source code, it's already compiled, but this compiled binary isn't compatible with some newer distributions. That's why we recommend the use of proftpd instead of vsftpd. proftpd doesn't need the ispconfig_tcpserver.

Which distribution do you use? Did you follow any of the tutorials on HowtoForge for setting up your server?
Hi Falko,

I see, yes of course i was using vsftp, but since i installed proftp on my other Fedora 3 it work great and is alots better.

I have used your easy guide for fedora 3 to install ISPConfig, it was pretty easy (if i forgot about my few mistype that i did).

Do you recommend to uninstall ISPConfig and VSFtp first, install proftp and then reinstall ISPConfig ?

Anyway, i have a little problems on few of my virtual website... i have some MYSql errors like that "; } mysql_free_result($result); ?>" and it looks like my CGI doesnt work... but the rest seems to work good.
Reply With Quote
  #4  
Old 3rd October 2005, 13:16
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Quote:
Originally Posted by zarkann
Do you recommend to uninstall ISPConfig and VSFtp first, install proftp and then reinstall ISPConfig ?
Yes, that's a good idea.
Quote:
Anyway, i have a little problems on few of my virtual website... i have some MYSql errors like that "; } mysql_free_result($result); ?>" and it looks like my CGI doesnt work...
Maybe a PHP syntax error in your PHP script?
Did you use the test files (http://www.howtoforge.com/forums/showthread.php?t=171) I provided?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 3rd October 2005, 15:51
zarkann zarkann is offline
Junior Member
 
Join Date: Sep 2005
Location: Montreal, Quebec
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yeah, it look like that...but it was working very good before i installed ISPConfig and requirements... I have uninstalled ISPConfig and restored my vsftp to see if it wirk. the FTP server was working but not some of my PHP scripts.

i have a website that the index have php codes and the name of the file is index.php . it will be read on the website but my counter is not working , as well as my sql database.

i typed this command in command line

php index.php

i saw all my html text and i saw that:

Code:
 <font color =black size = 1 face = Verdana>PHP Warning:  fclose(): supplied argument is not a valid stream resource in /home/miguel/public_html/counter.php on line 65
PHP Warning:  fclose(): supplied argument is not a valid stream resource in /home/miguel/public_html/counter.php on line 82
PHP Warning:  fclose(): supplied argument is not a valid stream resource in /home/miguel/public_html/counter.php on line 93
PHP Warning:  fclose(): supplied argument is not a valid stream resource in /home/miguel/public_html/counter.php on line 108
245 visitors since August 1st 2005 !<br /> This page has been visited 567 times !               <br>
it was working before thats for sure and i did not changed anything on this website since few days. In local mode with the PHP command line it work perfectly...my MySql database work and my php work...

i still have all my etc backed up before the first time i have installed ISPConfig. Do you know wich conf file i can restore to get my php working again ?

Last edited by zarkann; 3rd October 2005 at 16:29.
Reply With Quote
  #6  
Old 3rd October 2005, 16:39
zarkann zarkann is offline
Junior Member
 
Join Date: Sep 2005
Location: Montreal, Quebec
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Ok thats odd lol I swear it was working nice before

so, this is the update...

I restored my old httpd.conf backup

my php wasnt working...

i edited apache conf file and added
Quote:
AddType application/x-httpd-php .php
restarted apache

and it work...

the question there is how that line was removed on my backup file. and i tell you, i'm 100% sure that my database was working last thursday.

Anyway, i'm glad that it work now.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 16:55.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.