Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th June 2007, 14:37
danielos danielos is offline
Member
 
Join Date: Apr 2006
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Default Ubuntu 6.10 apache2-mpm-worker and php5

I'm facing a strange problem, I have installed:
apt-get install apache2 apache2-common apache2-doc apache2-mpm-worker apache2-utils libapr0 libexpat1 ssl-cert

and then
apt-get install libapache2-mod-php5 php5 php5-common

then I get:

The following packages will be REMOVED:
apache2-mpm-worker
The following NEW packages will be installed:
apache2-mpm-prefork libapache2-mod-php5 libxml2 php5-common


But I don't want to remove apache2-mpm-worker, does'nt the worker work with php5?

All help appreciated
Reply With Quote
Sponsored Links
  #2  
Old 29th June 2007, 18:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
 
Default

The PHP5 module (libapache2-mod-php5) works only with apache2-mpm-prefork.
If you want to install apache2-mpm-worker, you must use the CGI version of PHP.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 17:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.