Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 29th September 2006, 19:57
cmer cmer is offline
Junior Member
 
Join Date: Sep 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Problems with mod_deflate on Apache2

Hi!

I am trying to configure mod_deflate on Apache2/Ubuntu (apt-get was used for Apache) following the instructions found at http://www.howtoforge.com/apache2_mod_deflate.

Everything works fine... well, almost. I get no error or anything, but no content is mod_deflated either. Here's what I get in my log file:

"GET /static/css/ibox.css HTTP/1.1" -/- (-%)
"GET /static/css/ibox.css HTTP/1.1" -/- (-%)
"GET /static/css/olivegreenlover.css HTTP/1.1" -/- (-%)
"GET /static/css/olivegreenlover.css HTTP/1.0" -/- (-%)
"GET /static/css/olivegreenlover.css HTTP/1.0" -/- (-%)
"GET /static/css/olivegreenlover.css HTTP/1.0" -/- (-%)

Anybody has an idea of what might be going on? The module is enabled, and here's what I have in my apache2.conf file:

# mod_infoate settings
AddOutputFilterByType DEFLATE text/html text/plain text/xml
BrowserMatch ^Mozilla/4 gzip-only-text/html
BrowserMatch ^Mozilla/4\.0[678] no-gzip
BrowserMatch \bMSIE !no-gzip !gzip-only-text/html

# temporary
DeflateFilterNote Input input_info
DeflateFilterNote Output output_info
DeflateFilterNote Ratio ratio_info
LogFormat '"%r" %{output_info}n/%{input_info}n (%{ratio_info}n%%)' deflate
CustomLog /var/log/apache2/deflate_log deflate


Thanks!

Carl
Reply With Quote
Sponsored Links
  #2  
Old 1st October 2006, 00:50
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Quote:
Originally Posted by cmer
Anybody has an idea of what might be going on? The module is enabled, and here's what I have in my apache2.conf file:

# mod_infoate settings
AddOutputFilterByType DEFLATE text/html text/plain text/xml
BrowserMatch ^Mozilla/4 gzip-only-text/html
BrowserMatch ^Mozilla/4\.0[678] no-gzip
BrowserMatch \bMSIE !no-gzip !gzip-only-text/html

# temporary
DeflateFilterNote Input input_info
DeflateFilterNote Output output_info
DeflateFilterNote Ratio ratio_info
LogFormat '"%r" %{output_info}n/%{input_info}n (%{ratio_info}n%%)' deflate
CustomLog /var/log/apache2/deflate_log deflate


Thanks!

Carl
Please put it into your vhost configuration and restart Apache.
Also check your Apache's error log.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SSI with Apache2 on Debian jchaven Server Operation 7 25th August 2008 17:06
Problems with groups/grpconv linuxfast General 28 21st April 2008 09:35
Web server offline after php4 and apache2 upgrade dfriis Installation/Configuration 11 7th December 2006 16:14
PHP on Apache2 no longer works after ISPconfig azorman Installation/Configuration 6 23rd July 2006 22:06
Empty Recycle Bin jon335 General 40 6th May 2006 11:56


All times are GMT +2. The time now is 04:07.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.