Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd October 2006, 02:28
sjau sjau is offline
Local Meanie
 
Join Date: Apr 2006
Location: Switzerland
Posts: 1,146
Thanks: 4
Thanked 55 Times in 51 Posts
Default Postfix: cannot connect to saslauthd server

Hiya

I don't think I've done anything out of the ordinary but I just can't use SASL anymore. I'm at a loss because it used to work before:

Oct 2 02:26:34 t390 postfix/smtpd[23654]: warning: SASL authentication
failure: cannot connect to saslauthd server: No such file or directory
Oct 2 02:26:34 t390 postfix/smtpd[23654]: warning: SASL authentication failure: Password verification failed
Oct 2 02:26:34 t390 postfix/smtpd[23654]: warning: 84-75-65-53.dclient.hispeed.ch[84.75.65.53]: SASL PLAIN authentication failed

What could cause that?
Reply With Quote
Sponsored Links
  #2  
Old 2nd October 2006, 09:31
sjau sjau is offline
Local Meanie
 
Join Date: Apr 2006
Location: Switzerland
Posts: 1,146
Thanks: 4
Thanked 55 Times in 51 Posts
 
Default

Well, I reinstalled it according to Falko's Perfect Debian HowTo (http://www.howtoforge.com/perfect_setup_debian_sarge_p4) but there were still the same errors.

I had to edit /etc/postfix/sasl/smtpd.conf and alter the saslauth_path to:
Code:
saslauthd_path: /var/run/saslauthd/mux
and I had to enable chroot in the /etc/postfix/master.cf file:
Code:
# ==========================================================================
# service type  private unpriv  chroot  wakeup  maxproc command + args
#               (yes)   (yes)   (yes)   (never) (100)
# ==========================================================================
smtp      inet  n       -       y       -       -       smtpd
Now it works again like a charm
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 17:58
php Apps email not going through palkat General 8 21st September 2011 05:35
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
Email - Ueb-Miau mazhar Installation/Configuration 5 21st December 2005 10:01
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 02:30


All times are GMT +2. The time now is 03:56.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.