Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th September 2006, 12:15
EvdM EvdM is offline
Junior Member
 
Join Date: Feb 2006
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default Squirrelmail 10 Easy Steps Howto

Thanks for the article, just what I was looking for!
Only, I am afraid the 'Easy' bit does not fully apply to me...

I have set up according to the instructions (except in Step 3, I used '/home/www/web1' instead of '/var/www/web1'. Do I miss a symlink there, I run Perfect Setup Debian Sarge?)

Unfortunately, I do not find squirrelmail at: webmail.mydomain.nl. It just gives me an 'Firefox can't find the server at webmail.mydomain.nl'.
The regular 'www.mydomain.nl' works fine.

I have not selected the 'Create DNS' or 'Create DNS-MX' options for any of the sites which I host. Might that be the cause of this problem?

Thanks a lot for any suggestions!

Erik
Reply With Quote
Sponsored Links
  #2  
Old 30th September 2006, 14:46
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default

Hi,

I am happy that the "How to" is useful for you and of course for anybody else.

At the beginning of my "how to", i mentioned that i assume that your webs are stored under /var/www/.

This can be established, if you setup ISPConfig in "Expert" mode as descibed here: http://www.ispconfig.org/manual_installation.htm

I guess that you have setup ISPConfig in the "Default" mode, which means your webs are stored under /home/www instead of /var/www.

So, if you read /var in my "How to" it probably /home for you and it has nothing to do with symlinks.

Be sure that webmail.yourdomain.tld or better *.yourdomain.tld points to your webserver.
You can check this in the DNS-records of your DNS-provider.

I hope that i've answered your question now.
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005

Last edited by Hans; 30th September 2006 at 15:02.
Reply With Quote
  #3  
Old 1st October 2006, 22:41
EvdM EvdM is offline
Junior Member
 
Join Date: Feb 2006
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Hans
Be sure that webmail.yourdomain.tld or better *.yourdomain.tld points to your webserver.
You can check this in the DNS-records of your DNS-provider.
Thanks, I have settled things with my provider and the domain is on-line.
I still have one thing which bothers me; I need to point my browser to:

http://webmail.mydomain.nl/index.php

instead of what I would expect:

http://webmail.mydomain.nl

It seems that I still have a configuration issue somewhere.
Any further suggestions? Thanks a lot.

Erik
Reply With Quote
  #4  
Old 2nd October 2006, 04:04
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
Default

I think you should have used a subfolder within your web folder because if you setup a website, you'll have a problem with you index files.

You basically want squirrelmail in a subfolder because then you could setup a DNS entry that looks like this:

var/www/web1/web/squirrelmail <-- squirrelmail folder
DNS entry http://webmail.domain.tld --> http://www.domain.tld/squirrelmail/

With this configuration, you can open your webmail by going to webmail.domain.tld.

Hope this helps.
Reply With Quote
  #5  
Old 2nd October 2006, 06:38
EvdM EvdM is offline
Junior Member
 
Join Date: Feb 2006
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Rocky
I think you should have used a subfolder within your web folder because if you setup a website, you'll have a problem with you index files.

You basically want squirrelmail in a subfolder because then you could setup a DNS entry that looks like this:

var/www/web1/web/squirrelmail <-- squirrelmail folder
DNS entry http://webmail.domain.tld --> http://www.domain.tld/squirrelmail/
Thanks a lot. I see this point.
However, I still have 2 minor questions around this proposed solution:
  • I am not sure how to create the DNS entry which you specify. Can this be done in ISPConfig or should I contact my provider for that?

Please excuse all my ignorance...

Erik
Reply With Quote
  #6  
Old 2nd October 2006, 10:39
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default

In my Squirrelmail how to, i used http://webmail.mydomain.tld just as an example.
Of course you can setup in the web of your choiche.
If you want your Squirrelmail installed in a folder like http://www.mydomain.tld/webmail for example:

Create a folder in your web of your website, which is called webmail. (web/webmail).
In this folder you install Squirrelmail.
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005
Reply With Quote
  #7  
Old 2nd October 2006, 17:09
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
Default

If your provider hosts your DNS, then you will have to get them to create it for you. Just explain that you need an entry that points wemail.yourdomain.tld to http://www.yourdomain.tld/webmail/, webmail being the folder that you used to install squirrelmail in.
Reply With Quote
  #8  
Old 11th October 2006, 00:50
estokwa estokwa is offline
Junior Member
 
Join Date: Aug 2006
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i went tru the how to for squirelmail but when i am done and trying to access my mail.domian.tld it gives me the apache 2 test page. my file is located at /var/www/web1/web/
thanks,
Reply With Quote
  #9  
Old 11th October 2006, 08:09
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default

On an ISPConfig server, the Apache screen is always visible when you've setup your server,
while there is no web created (yet) in via ISPConfig.

It has nothing to do with the "within 10 easy steps howto itself".

I guess there's something wrong with your DNS settings, within your server and/or pointing to your server.
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005
Reply With Quote
  #10  
Old 11th October 2006, 13:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

Quote:
Originally Posted by estokwa
i went tru the how to for squirelmail but when i am done and trying to access my mail.domian.tld it gives me the apache 2 test page. my file is located at /var/www/web1/web/
thanks,
What's the output of
Code:
ifconfig
? What's in Vhosts_ispconfig.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HowTo install ISPConfig on a STRATO-Server with Debian 3.1 TobiasTM Tips/Tricks/Mods 12 15th July 2008 10:08
HOWTO SquirrelMail on debian sarge cccc HOWTO-Related Questions 9 10th October 2006 14:16
ILOHAMAIL in 10 easy steps Hans Tips/Tricks/Mods 12 24th September 2006 11:11
easy steps for FC3 mysql 4.0 to 4.1 lifeisboost HOWTO-Related Questions 3 25th June 2006 18:37
Virtual users, domains Postfix.. & Squirrelmail laser144 HOWTO-Related Questions 6 4th May 2006 23:23


All times are GMT +2. The time now is 04:16.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.