Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th September 2006, 01:56
atoulis atoulis is offline
Junior Member
 
Join Date: Sep 2006
Location: Markham, Canada
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default mysql.allow_persistent

mysql.allow_persistent = off in php.ini but I want to set it "on" only for specific sites. Does anyone know how this can be done through Apache Directives? I tried the following without success. The local value always remains off.

php_admin_value mysql.allow_persistent = on
php_admin_value allow_persistent = on

Thanks very much.
Alex
Reply With Quote
Sponsored Links
  #2  
Old 28th September 2006, 08:43
sjau sjau is offline
Local Meanie
 
Join Date: Apr 2006
Location: Switzerland
Posts: 1,146
Thanks: 4
Thanked 55 Times in 51 Posts
Default

Try this:

Code:
php_admin_value mysql.allow_persistent On
That should work. If not, then you need to check whether allow overwrite for this site is activated. (I normally check that by putting in a .htaccess that pops up a user/pwd box).
Reply With Quote
  #3  
Old 28th September 2006, 14:36
atoulis atoulis is offline
Junior Member
 
Join Date: Sep 2006
Location: Markham, Canada
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I tried the above but still no success. Other overrides such upload_max_filesize in Apache Directives are working fine. Its just the mysql.allow_persistent value that doesn't seem to work. Thanks.
Reply With Quote
  #4  
Old 28th September 2006, 16:32
sjau sjau is offline
Local Meanie
 
Join Date: Apr 2006
Location: Switzerland
Posts: 1,146
Thanks: 4
Thanked 55 Times in 51 Posts
Default

Strange, I think that should work... dunno what's wrong there...
Reply With Quote
  #5  
Old 28th September 2006, 22:08
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by atoulis
php_admin_value mysql.allow_persistent = on
php_admin_value allow_persistent = on
Try
Code:
php_admin_flag mysql.allow_persistent = on
php_admin_flag allow_persistent = on
instead.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 4th October 2006, 03:31
atoulis atoulis is offline
Junior Member
 
Join Date: Sep 2006
Location: Markham, Canada
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Falko,
I tried the two lines of code you suggested but received "# NOT SUPPORTED!" messages beside all Apache directives. I tried each line of code seperately and still got the same messages.
Reply With Quote
  #7  
Old 4th October 2006, 09:13
sjau sjau is offline
Local Meanie
 
Join Date: Apr 2006
Location: Switzerland
Posts: 1,146
Thanks: 4
Thanked 55 Times in 51 Posts
Default

Well, you could enable this in the php.ini if everything else fails
Reply With Quote
  #8  
Old 4th October 2006, 17:46
atoulis atoulis is offline
Junior Member
 
Join Date: Sep 2006
Location: Markham, Canada
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Thanks. I decided to set mysql.allow_persistent = off in php.ini. Setting it to 'on' might allow some sites to use too many connection resources. Not good in a shared environment.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 18:23.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.