Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th September 2006, 01:50
robbiewo robbiewo is offline
Junior Member
 
Join Date: Sep 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Skype™ to robbiewo
Default Msql Password setup problem

i am new to mysql setup and have looked for forums on this subject but if it does exist please redirect me to link

i have been folowing the howto perfect setup fedora5 server with isp config
and get problems with the mysql password setup.the commands are as follows

mysqladmin -u root password yourrootsqlpassword
mysqladmin -h server1.example.com -u root password yourrootsqlpassword



the first line works well and i can set root password but the second line i get the error
'Access denied for user 'root'@'localhost' (using password: NO)'

any help much apprecaited
Reply With Quote
Sponsored Links
  #2  
Old 27th September 2006, 11:03
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,786
Thanks: 840
Thanked 5,610 Times in 4,421 Posts
Default

You can ignore that. Complete the install and change the second mysql password with phpmyadmin after you finished the ISPConfig installation.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 23rd May 2007, 08:44
armitage armitage is offline
Junior Member
 
Join Date: May 2007
Location: Perth
Posts: 15
Thanks: 4
Thanked 0 Times in 0 Posts
Default etch

Hi,

I'm at this stage:
Please enter your MySQL server: E.G. localhost
Please enter your MySQL user: E.G. root
Please enter your MySQL password: Your MySQL password

I'm getting

ERROR 1045 (28000): Access denied for user 'root'@"blahblah.com' (using password: YES)
The provided MySQL password is wrong!

Is there anything I can do to not have to reinstall this again?
I triple checked the password at msql stage, it seems I must have been blind on the night.
thanks for your help again in advance

A
:d
Reply With Quote
  #4  
Old 24th May 2007, 18:23
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Can you log in with your password when you type in
Code:
mysql -u root -p
?
If not, does
Code:
mysql -u root
work?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 25th May 2007, 07:23
armitage armitage is offline
Junior Member
 
Join Date: May 2007
Location: Perth
Posts: 15
Thanks: 4
Thanked 0 Times in 0 Posts
Default

this is what I get

Code:
web:/# mysql -u root -p
Enter password:
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)
web:/# mysql -u root
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
Reply With Quote
  #6  
Old 26th May 2007, 20:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Then your password is wrong, or the Hostname column in the mysql.user table doesn't contain localhost.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
armitage (30th May 2007)
  #7  
Old 30th May 2007, 12:13
armitage armitage is offline
Junior Member
 
Join Date: May 2007
Location: Perth
Posts: 15
Thanks: 4
Thanked 0 Times in 0 Posts
Default

reinstall # 5 fixed it. using $ in password seemed to be the issue.
thanks
Reply With Quote
  #8  
Old 27th July 2007, 21:15
chez17 chez17 is offline
Junior Member
 
Join Date: Jul 2007
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am having the same issue, I checked the database and there are 3 users with the name root. I am doing your ubuntu 7.04 perfect setup tutorial. Each user with the name root has a different host. they are 127.0.0.1, localhost, and server1.example.com. So I do have a localhost listed and I do have the password right, it still wont let me connect on the command:

mysqladmin -h server1.example.com -u root password yourrootsqlpassword

If i already changed the password via mysql, do I even need to do this?
Reply With Quote
  #9  
Old 28th July 2007, 11:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

And is server1.example.com what you get when you run
Code:
hostname -f
? If not, you must change the hostname in the Host column.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 21st April 2008, 09:32
mhamed.hmimid mhamed.hmimid is offline
Junior Member
 
Join Date: Apr 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Arrow ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

Hello all
I use linux mandriva 2008.1
The computer is an acer notebook
I tried to install a local server
installed apache
worked
Installed php worked
mysql no
i tried to install the mysql gui tools
from terminal i tried the following codes:
#su
#root password
#service mysqld start ok
#exit
#
$mysql -u root -p
$password
$ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)
$mysql -u root
$ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
$hostname -f
$localhost
I ve been struggling to work with mysql for 2 months now but invain
But still i m testing installing and disinstalling mysql
the same problem

Last edited by falko; 22nd April 2008 at 18:26.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 13:20
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 16:16
How to install BFD (Brute Force Detection) domino Tips/Tricks/Mods 9 31st March 2006 23:40
Password Protected Directories Problem Median General 7 4th February 2006 18:15
Debian perfect setup network problem reddogg Installation/Configuration 2 18th January 2006 23:04


All times are GMT +2. The time now is 18:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.