#1  
Old 21st September 2006, 15:12
chris_knowles chris_knowles is offline
Junior Member
 
Join Date: Sep 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Question Bind9 Slave to Win2K DNS Server

I have Bind9 up and running and i think i have configured my files correctly but i will not transfer the zone files from windows. In the event log in windows, it says that the file has been successfully copied across, but there is nothing in the /var/lib/named/etc/bind/zones folder and therefore the slave server can't see it.

Quote:
zone "domain.co.uk" {
type slave;
file "/etc/bind/zones/domain.co.uk";
masters { 194.xxx.xxx.xxx; };
};
This is in my named.config.local file.

Please can someone tell me what i am doing wrong?

Thanks

Chris
Reply With Quote
Sponsored Links
  #2  
Old 22nd September 2006, 13:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Are there any errors in your logs?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 22nd September 2006, 14:44
chris_knowles chris_knowles is offline
Junior Member
 
Join Date: Sep 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i can't find any logs, i followed the instructions on how to set this up from this website, apart from the encrypted transfer of zones as that will confuse things with Windows i think. I thought i had set up the syslog as suggested but there is a log file there but it is 0 size.
Reply With Quote
  #4  
Old 23rd September 2006, 16:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Usually the log files are in the /var/log directory.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 26th September 2006, 11:07
chris_knowles chris_knowles is offline
Junior Member
 
Join Date: Sep 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have found some log files:

Quote:
Sep 26 10:00:12 dns2 named[1525]: transfer of 'domain.co.uk/IN' from 194.xxx.xxx.xxx#53: failed while receiving responses: permission denied
Sep 26 10:00:12 dns2 named[1525]: transfer of 'domain.co.uk/IN' from 194.xxx.xxx.xxx#53: end of transfer
Where do i need to set the permissions to get this to work?

Thanks
Reply With Quote
  #6  
Old 27th September 2006, 20:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

What's in your /etc/named.conf? Which distribution do you use?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
php Apps email not going through palkat General 8 21st September 2011 05:35
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
SuSE as master DNS server and Centos as slave DNS server... sthompson Server Operation 3 17th September 2006 13:24
Email - Ueb-Miau mazhar Installation/Configuration 5 21st December 2005 10:01
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 02:30


All times are GMT +2. The time now is 06:26.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.