Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 29th September 2005, 11:00
uralter_artifex uralter_artifex is offline
Junior Member
 
Join Date: Sep 2005
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default ISPConfig & typo3

Hello there,

still getting 403 here.
I will do some testing whether this problem is specific for typo3 on ISPConfig. Has anyone managed to install both on SuSE 9.3?

Thanks for your hints and suggestions.
Reply With Quote
Sponsored Links
  #12  
Old 17th February 2006, 15:40
jaffaizal jaffaizal is offline
Member
 
Join Date: Feb 2006
Posts: 43
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by rytech
I reinstalled SuSE on the machine, works fine now.

Thanks for the help
Rytech,

Did you have to reinstall ISPconfig again?
I am experiencing the same problem as 'uralter_artifex'.

BTW, I am using typo3 3.8.1
Placed the typo3_src-3.8.1 folder in '/home/www/web13'
Placed quickstart-3.8.1 folder in '/home/www/web13', then rename it to 'web'

Jaf
Reply With Quote
  #13  
Old 17th February 2006, 18:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by jaffaizal
BTW, I am using typo3 3.8.1
Placed the typo3_src-3.8.1 folder in '/home/www/web13'
Placed quickstart-3.8.1 folder in '/home/www/web13', then rename it to 'web'

Jaf
You must put all your files into /home/www/web13/web, not /home/www/web13.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #14  
Old 28th May 2006, 00:32
SkyBlueshoes SkyBlueshoes is offline
Junior Member
 
Join Date: May 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default having the same problem with Debian

I just transferred over my previous site and I'm getting some of these same errors. My index page is index.php and it reads fine, but it can't read the images from the subdirectory /home/www/web1/web/img/, nor is my php able to write to text files. I have a simple counter that uses flatfiles and it gives me this error:

Warning: fopen(ip.txt): failed to open stream: Permission denied in /home/www/web1/web/footer.php on line 29

I tried to go directly to the image file and I recieved a 500 internal server error, also getting this error when trying to access any files within subdirectories of docroot: eg: /home/www/web1/web/subdirectory/anyfile.php

I'm also having another problem when trying to add mailbox users for the site: The username is already in use.



Is there a solution to this? should Apache2 run as a different user:group?

Last edited by SkyBlueshoes; 28th May 2006 at 00:51.
Reply With Quote
  #15  
Old 28th May 2006, 10:24
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,389 Times in 4,234 Posts
Default

Quote:
Originally Posted by SkyBlueshoes
Is there a solution to this? should Apache2 run as a different user:group?
Thsts a common pronblem. Either you must make the directorys world writable, which is pretty insecure or you must run PHP as php-cgi with suexec or with the mod_suphp wrapper.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #16  
Old 17th June 2006, 14:23
elCorazon elCorazon is offline
Junior Member
 
Join Date: Jun 2006
Posts: 10
Thanks: 1
Thanked 0 Times in 0 Posts
Default are you serious?

Quote:
Originally Posted by till
Thsts a common pronblem. Either you must make the directorys world writable, which is pretty insecure or you must run PHP as php-cgi with suexec or with the mod_suphp wrapper.
Hi
did I get that right? If I want the webserver being able to read/write PHP and directories I have to make them world read/writable?

I installed ISPConfig a few days ago and it seemed to be a good system to me. But now I have some Problems:
1. I have to configure an open_basedir other than the users root itself. I solved that, by inserting it by hand in /root/ispconfig/scripts/lib/config.lib.php line 1363 (Version 2.2.3).
2. The permission problem: I don't want my webroots to be world readable least of all world writable. ISPConfig resets the permissions some way, but I'm not shure what it does and when. My favourite setup would be
/var/www/webX 775 webX_admin:webX
/var/www/webX/web 770 www-data:webX
/var/www/webX/web/all-dirs 770 www-data:webX
/var/www/webX/web/all-files 660 www-data:webX

Could one of the developers please write in short what ISPConfig does?
Thanks a lot!
Reply With Quote
  #17  
Old 17th June 2006, 16:15
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,389 Times in 4,234 Posts
Default

Quote:
Originally Posted by elCorazon
Hi
did I get that right? If I want the webserver being able to read/write PHP and directories I have to make them world read/writable?
No. You have just read the first part of the sentence. The alternative is:

Quote:
... or you must run PHP as php-cgi with suexec or with the mod_suphp wrapper.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #18  
Old 17th June 2006, 16:25
elCorazon elCorazon is offline
Junior Member
 
Join Date: Jun 2006
Posts: 10
Thanks: 1
Thanked 0 Times in 0 Posts
Default

OK, sorry for not writing that: ...with running PHP as module. My question was if a permission setting like the described would be possible or what ISPConfig sets the permissions to.
Reply With Quote
  #19  
Old 17th June 2006, 23:18
salamankero salamankero is offline
Junior Member
 
Join Date: Jun 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Access Forbidden

My issue seems to be similar to this, but not quite exact.

I installed this on an existing fedora core 3 system using the perfect install guide. When I setup a site and tried to access it, I would always get the default Apache site. After looking through the httpd.conf file I noticed there was no include for the Vhosts_ispconfig.conf file. I also looked at the Server Settings and noticed that the directory/filename for the httpd.conf file was wrong.

I added the correct path to the conf dir, and the full path to the httpd.conf file in Server Settings, deleted and recreated my site, and added an Include in Apache's httpd.conf file to include the Vhosts_ispconfig.conf file. When I do a reload of apache I get:

(13)Permission denied: httpd: could not open error log file /home/www/web6/log/error.log.
Unable to open logs


in my /etc/httpd/logs/error_log file and

Starting httpd: Warning: DocumentRoot [/home/www/web5/web] does not exist
[FAILED]


to the console.

I have tried playing with file permissions and ownerships, but nothing has helped. I am wondering if during the setup process ISPConfig didn't know where to find my httpd.conf file so some changes didn't get made there (say a Directory permission setting).

I was hoping someone could send me a copy of their httpd.conf file or give me a solution to my problem that I may not be thinking of.

Thanks in advance!

Sal...
Reply With Quote
  #20  
Old 18th June 2006, 13:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Quote:
Originally Posted by elCorazon
OK, sorry for not writing that: ...with running PHP as module. My question was if a permission setting like the described would be possible or what ISPConfig sets the permissions to.
ISPConfig sets all directories underneath /var/www/webX/web to webX_admin:webX, with the directories having permissions of 755.

You can make all webs use PHP Safe Mode, so that no PHP scripts can break out of their web site, and/or you can use suPHP: http://www.howtoforge.com/apache2_suphp_php4_php5
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
/stats doesn't work (password not accepted) Hellbound General 6 15th September 2005 15:34
Can't access ISPConfig by http://...:81 driftguy Installation/Configuration 7 14th September 2005 14:47
FTP Access ProTrooper Installation/Configuration 17 16th August 2005 17:53
Access Denied on Port: 81 nandhu Installation/Configuration 2 10th August 2005 14:05
Restrict access to my SystemImager server cornelius Installation/Configuration 1 7th June 2005 11:35


All times are GMT +2. The time now is 06:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.