Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 21st September 2006, 12:56
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Quote:
Originally Posted by vbrookie
I've googled and found a solution to this.
Code:
zone "example.com" {
        type slave;
        file "slave/sec.example.com";
        masters { 192.168.1.100; };
};
Thats exactly what ISPConfig uses, so I guess you did not create a slave record in the dns manager.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Sponsored Links
  #12  
Old 21st September 2006, 14:21
vbrookie vbrookie is offline
Junior Member
 
Join Date: May 2006
Posts: 16
Thanks: 2
Thanked 2 Times in 2 Posts
Default

I did create the slave record on dns manager, but "slave/..." did not get added when I created slave record.
It could've been buggy yast2 in openSuse 10.1 issue. It's my first time playing around with openSuse distro, and I am impressed by its ablility to support my old Symbios Scsi cards & HP netRaid cards right out of the box, but i am not so found of yast2 so far. I had to manually add update source in yast2 and I still can't find a way to add install sources on 2 servers. I had to use y2pmsh to manually install all the required programs.
Anyway...
Now everything is running extremly well and thanks for creating wonderful ISPConfig Package!
Reply With Quote
  #13  
Old 21st September 2006, 20:25
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Quote:
Originally Posted by vbrookie
I did create the slave record on dns manager, but "slave/..." did not get added when I created slave record.
If you have to add slave/, this means that the permissions of /var/lib/named are not ok, because otherwise the zones would be created in /var/lib/named instead of /var/lib/named/slave.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #14  
Old 31st May 2007, 11:26
Uno Uno is offline
Junior Member
 
Join Date: May 2007
Posts: 8
Thanks: 4
Thanked 0 Times in 0 Posts
Default

Hi,
first of all thanks for this magnificent job.
searching in the howto and the forum i have resolved all, also i have installed the remote framework.... but i have a problem con dns
the same of this thread

in slave dns, therefore ispconfig 2 / ns2

named.conf has:

zone "example.com" {
type slave;
file "sec.example.com";
masters { XXXXXXXXXXX; };
(1)
};


(1) IP ns1

but i do not see the file sec.example.com

therefore in syslog

May 31 07:50:42 ns2 named[14074]: zone example.com/IN: Transfer started.
May 31 07:53:51 ns2 named[14074]: transfer of 'example.com/IN' from XX.XX.XX.XX#53: failed to connect: timed ou

need other information?
as can i make works the transfer?


Thank for all

p.s. i have used howto "How To Run Your Own Name Servers With ISPConfig And GoDaddy"
Reply With Quote
  #15  
Old 1st June 2007, 19:22
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Quote:
Originally Posted by Uno
May 31 07:53:51 ns2 named[14074]: transfer of 'example.com/IN' from XX.XX.XX.XX#53: failed to connect: timed ou

[/COLOR]
Please make sure that the firewall on ns1 doesn't block port 53 (TCP and UDP).
Is named running on ns1? Are there any named errors in the ns1 logs?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #16  
Old 1st June 2007, 20:04
Uno Uno is offline
Junior Member
 
Join Date: May 2007
Posts: 8
Thanks: 4
Thanked 0 Times in 0 Posts
Default

Yes named on ns1 running, this a bit di syslog:

Code:
Jun  1 13:27:41 example named[32710]: starting BIND 9.3.4 -u bind -t /var/lib/named
Jun  1 13:27:41 example named[32710]: found 1 CPU, using 1 worker thread
Jun  1 13:27:41 example named[32710]: loading configuration from '/etc/bind/named.conf'
Jun  1 13:27:41 example named[32710]: no IPv6 interfaces found
Jun  1 13:27:41 example named[32710]: listening on IPv4 interface lo, 127.0.0.1#53
Jun  1 13:27:41 example named[32710]: listening on IPv4 interface venet0:0, XX.XX.XXX.XX#53
Jun  1 13:27:41 example named[32710]: command channel listening on 127.0.0.1#953
Jun  1 13:27:41 example named[32710]: zone 0.0.127.in-addr.arpa/IN: loaded serial 1
Jun  1 13:27:41 example named[32710]: zone 146.XX.XX.in-addr.arpa/IN: loaded serial 2007053001
Jun  1 13:27:41 example named[32710]: zone example.com/IN: loaded serial 2007060101
Jun  1 13:27:41 example named[32710]: running
Jun  1 13:27:41 example named[32710]: zone 146.XX.XX.in-addr.arpa/IN: sending notifies (serial 2007053001)
Jun  1 13:27:41 example named[32710]: zone example.com/IN: sending notifies (serial 2007060101)
I do not see errors

firewall on ns1 and ns2 is that of ispconfig with 53 tcp and upd open

I must add that today (10:30) I have reboot the real server Host (ns1 and ns2 are two vps with two external IPs and firewall on Host is open on 53 tcp udp) and file sec.example.com it has been created, but after the transfert it is blocked

syslog on ns2:
Code:
Jun  1 16:31:08 ns2 named[7336]: zone example.com/IN: Transfer started.
Jun  1 16:34:17 ns2 named[7336]: transfer of 'example.com/IN' from XX.XXX.XXX.XX#53: failed to connect: timed out
Jun  1 16:34:17 ns2 named[7336]: transfer of 'example.com/IN' from XX.XX.XX.XX#53: end of transfer
I do not succeed to understand, however thanks
Reply With Quote
  #17  
Old 2nd June 2007, 12:24
Uno Uno is offline
Junior Member
 
Join Date: May 2007
Posts: 8
Thanks: 4
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Uno
and file sec.example.com it has been created,
and trasfer of record is successful..... after it is blocked another time, now transfer is blocked infact on dns stuff:

The serial numbers reported by each DNS server are:
XX.XXX.XX.XX: 2007060101
XX.XXX.XXX.XXX: 2007053008


some idea?
Reply With Quote
  #18  
Old 2nd June 2007, 16:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

What's in sec.example.com (on ns2) and pri.example.com (on ns1)?
Any errors in your logs (on both ns1 and ns2)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #19  
Old 2nd June 2007, 21:53
Uno Uno is offline
Junior Member
 
Join Date: May 2007
Posts: 8
Thanks: 4
Thanked 0 Times in 0 Posts
 
Default

I have resolved after much job and tests, thanks

first the firewall on Host master (physical server) closed the transfert from ns1 (vps1) to ns2 (vps2)

strange because iptables it was opened on all from and towards the two IP (TPC and UDP)

after on ns2 syslog gave this line: refused notify from non-master

therefore I have added on ns2 named.conf allow-notify { IP ns2; };

now work... even if I must arrange better firewall on physical server


Hello boys, when I can to back, if i I will be able to contribute in some way.... thanks for the yours job.
This is the best free hosting panel and i have tested all on the web in the sector, also something to payment.

P.s. excuse me for my poor english
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ethereal Trouble mcrosby Installation/Configuration 8 25th June 2006 04:50
DNS Default TTL and Reverse Zone WEX General 2 16th June 2006 01:46
BIND broke adamluz Installation/Configuration 4 2nd June 2006 22:31
Zone transfer chrno Server Operation 1 1st May 2006 16:43
named.conf and zone files latcarf Server Operation 2 6th August 2005 16:00


All times are GMT +2. The time now is 21:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.