Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 23rd September 2006, 19:29
ikaros ikaros is offline
Member
 
Join Date: Aug 2006
Posts: 35
Thanks: 2
Thanked 1 Time in 1 Post
Default Using Apache to authenticate

I want to protect a folder with Apache, so when a user tries to access that folder, a username & password should be asked for. I use the following code in httpd.conf, but it doesn't work.

Code:
# Set up an authenticated directory, in this case foo
<Directory "/srv/www/foo">
	AuthType Basic
	AuthName "Efarmogi"
	AuthUserFile /srv/www/www.foo.gr/user/foo_user/allow.users
	require foo_user
</Directory>
Any ideas?
Reply With Quote
Sponsored Links
  #2  
Old 23rd September 2006, 19:50
sjau sjau is offline
Local Meanie
 
Join Date: Apr 2006
Location: Switzerland
Posts: 1,146
Thanks: 4
Thanked 55 Times in 51 Posts
Default

Try this:

Code:
# Set up an authenticated directory, in this case foo
<Directory "/srv/www/foo">

	AuthType Basic
	AuthName "Efarmogi"
	AuthUserFile /srv/www/www.foo.gr/user/foo_user/allow.users
	require valid-user
</Directory>
Reply With Quote
  #3  
Old 24th September 2006, 13:55
ikaros ikaros is offline
Member
 
Join Date: Aug 2006
Posts: 35
Thanks: 2
Thanked 1 Time in 1 Post
 
Default

According to this:

http://httpd.apache.org/docs/2.0/howto/auth.html

I have to install mod_auth, mod_access first, so I have to figure out how to do it in SLES 10.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache down every week (caught SIGTERM) jarkand Server Operation 6 15th July 2008 01:59
mod_mono apache 2.2 ColdDoT Server Operation 5 23rd May 2006 02:58
Problem with the installation of Dokeos (LMS) in ISPConfig jofranco General 4 28th April 2006 00:45
PHP/MySQL/Apache2/ISPConfig configuration issues? senzapaura General 21 25th December 2005 14:01
Apache 1.3 Support SleeperZ General 3 9th November 2005 11:10


All times are GMT +2. The time now is 05:40.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.