Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 12th September 2006, 00:47
adrenalinic adrenalinic is offline
Senior Member
 
Join Date: Jan 2006
Posts: 214
Thanks: 3
Thanked 4 Times in 4 Posts
Default

hi!
i have solved this problem.....(of example.com! )
but the problem of postfix remain:

The Postfix program

<admin@mysite.com>: mail for mysite.com loops back to
myself
_______________________________________
I have tryed to add mysite.com to local host name but when send email receive error message: user not in virtual table...and reject my request
Reply With Quote
Sponsored Links
  #12  
Old 12th September 2006, 12:17
adrenalinic adrenalinic is offline
Senior Member
 
Join Date: Jan 2006
Posts: 214
Thanks: 3
Thanked 4 Times in 4 Posts
Exclamation

Hi..
I not say how can is possible this problem....

all dns and A host is correctly configured...:

A Record
IP-Adresse Nome Host
100.100.100.100 www
100.100.100.100 mail

My MX is setting up to :

Mailserver Host
ASPMX5.GOOGLEMAIL.COM mail
ASPMX4.GOOGLEMAIL.COM mail
ASPMX3.GOOGLEMAIL.COM mail
ASPMX2.GOOGLEMAIL.COM mail
ALT1.ASPMX.L.GOOGLE.COM mail
ALT2.ASPMX.L.GOOGLE.COM mail
ASPMX.L.GOOGLE.COM mail



domain www.mysite.com is setting to "external mail server"
codomain mysite.com is setting to "esternal mail server"

in general postfix conf of ispconfig i not have selected voice "default mx"....i have to select this option?!

Error:
------------------------------------------------------
The Postfix program

<admin@mysite.com>: mail for mysite.com loops back to
myself

-----------------------------------------------------

Testing hostname mail.mysite.com

Getting MX record for mail.mysite.com (from local DNS server, may be cached)... Got it!

Host Preference IP(s) [Country]
aspmx.l.google.com. 10 66.249.93.27 [US]66.249.93.114 [US]
alt1.aspmx.l.google.com. 30 72.14.205.27 [US]
alt2.aspmx.l.google.com. 40 64.233.167.27 [US]64.233.167.114 [US]
aspmx2.googlemail.com. 50 64.233.183.27 [US]
aspmx3.googlemail.com. 60 64.233.167.27 [US]
aspmx4.googlemail.com. 70 66.249.93.27 [US]
aspmx5.googlemail.com. 80 66.249.83.27 [US]
-------------------------------------------------------------------------------

if try to send mail to admin@mysite.com:

Getting MX record for mysite.com (from local DNS server, may be cached)... There is no MX record for mysite.com! That's bad.
Checking for an A record... Got it!

Host Preference IP(s) [Country]
mysite.com 0 100.100.100.100 [US]

---------------------------------------------------------
My MX is correctly....


I do not know more what other to make
Someone has some possible idea ?

Last edited by adrenalinic; 12th September 2006 at 12:42.
Reply With Quote
  #13  
Old 12th September 2006, 12:50
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,001
Thanks: 840
Thanked 5,650 Times in 4,460 Posts
Default

Please check your postfix main.cf and /etc/hostname file if they contain mysite.com
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #14  
Old 12th September 2006, 13:11
adrenalinic adrenalinic is offline
Senior Member
 
Join Date: Jan 2006
Posts: 214
Thanks: 3
Thanked 4 Times in 4 Posts
Default

if add mysite to my local host name...server reject request because admin@mysite.com not is in local recipietn...obvious....

my main.cf is:

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = server3.myserver.org
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
#mydestination = server3.myserver.org, localhost.myserver.org, , localhost
relayhost =
mynetworks = 127.0.0.0/8
mailbox_command =
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
home_mailbox = Maildir/

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names
---------------------------------------------------------------
error persist..........
Reply With Quote
  #15  
Old 12th September 2006, 13:17
adrenalinic adrenalinic is offline
Senior Member
 
Join Date: Jan 2006
Posts: 214
Thanks: 3
Thanked 4 Times in 4 Posts
Default

new error in mail.log:

Sep 12 06:12:53 server3 postfix/cleanup[11689]: warning: database /etc/postfix/virtusertable.db is older than source file /etc/postfix/virtusertable

Reply With Quote
  #16  
Old 12th September 2006, 13:46
adrenalinic adrenalinic is offline
Senior Member
 
Join Date: Jan 2006
Posts: 214
Thanks: 3
Thanked 4 Times in 4 Posts
Default

i have see this post....
http://howtoforge.org/forums/showthread.php?t=1163
but have to make all this procedure to make my mail server external?!
Reply With Quote
  #17  
Old 12th September 2006, 13:56
adrenalinic adrenalinic is offline
Senior Member
 
Join Date: Jan 2006
Posts: 214
Thanks: 3
Thanked 4 Times in 4 Posts
Default

adding....mysite.com to local host names...have:

Sep 12 06:52:52 server3 postfix/smtpd[28269]: NOQUEUE: reject: RCPT from host188-12-static.29-87-b.business.telecomitalia.it[87.29.12.188]: 550 <admin@mysite.com>: Recipient address rejected: User unknown in local recipient table; from=<giuseppe@myste2.eu> to=<admin@mysite.com> proto=ESMTP helo=<[127.0.0.1]>
Sep 12 06:52:57 server3 postfix/smtpd[28269]: lost connection after RCPT from host188-12-static.29-87-b.business.telecomitalia.it[87.29.12.188]
Sep 12 06:52:57 server3 postfix/smtpd[28269]: disconnect from host188-12-static.29-87-b.business.telecomitalia.it[87.29.12.188]
Reply With Quote
  #18  
Old 12th September 2006, 14:08
adrenalinic adrenalinic is offline
Senior Member
 
Join Date: Jan 2006
Posts: 214
Thanks: 3
Thanked 4 Times in 4 Posts
Default

in my.cf of postfix have tryed to add:

mydestination = server3.myserver.org, localhost, mysite.com, mail.mysite.com, ASPMX2.GOOGLEMAIL.COM

whit any result....
Reply With Quote
  #19  
Old 12th September 2006, 18:22
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Quote:
Originally Posted by adrenalinic
When setting up the host "mail.mysite.com" in dns manager i have added IP address of my machine, and have hadded 5 mail server of Gmail in the MX section of DNS manager.

Quering host mail.mysite.com:

Getting MX record for mail.mysite.com (from local DNS server, may be cached)... Got it!

Host Preference IP(s) [Country]
alt1.aspmx.l.google.com. 10 72.14.205.27 [US]
alt2.aspmx.l.google.com. 20 64.233.167.114 [US]64.233.167.27 [US]

This test see correctly the MX address of Gmail server....

But.......
when send an email to test@mysite.com form email address hosted on the same server, it return this error postfix message:
I think what you want is an MX record for mysite.com instead of mail.mysite.com. Have a look at these two tutorials, and a lot of things should be clearer: http://www.howtoforge.com/ispconfig_dns_godaddy
http://www.howtoforge.com/traditional_dns_howto
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #20  
Old 12th September 2006, 19:13
adrenalinic adrenalinic is offline
Senior Member
 
Join Date: Jan 2006
Posts: 214
Thanks: 3
Thanked 4 Times in 4 Posts
 
Default

hi.
i have solved. all my dns setting is ok.
the problem was in MX listed server...
that server..will be write whitout the host "mail"....
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Statistic not working mzo Installation/Configuration 49 20th April 2011 13:19
Core 4: Error Messages on Fresh Install re CTX/SSL jjw Installation/Configuration 30 6th September 2006 13:16
Can not recieve mail with de virtual mail adress Mounir Installation/Configuration 9 25th July 2006 00:16
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 12:47
Can't get MX for external mail server to work semmelbroesel Installation/Configuration 4 25th November 2005 18:48


All times are GMT +2. The time now is 19:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.