#1  
Old 24th April 2007, 00:07
DrDon DrDon is offline
Junior Member
 
Join Date: Apr 2007
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
Send a message via ICQ to DrDon Send a message via MSN to DrDon
Default Again: Co/Sub-domain problem

Good evening guys and gals,


i have the following problem:

I own the domain team-hal.de and a dedicated server.
Both are hosted at Hetzner.
Team-hal.de is not using it's own nameservers. (nameservers are ns3.second-ns.de and ns.second-ns.de)

The server is running debian etch (The perfect Setup tutorial - Thanks!) and the newest version of ISPConfig.

Now, i want to create some subdomains (they should point to team-hal.de/~drdon i.e.)

So, after what i've read on the forums, i go to my web, click on co-domains, enter drdon as host an team-hal.de as the domain, forward it to team-hal.de/~drdon and hit save.

dont work.

if i enter drdon.team-hal.de in my browser, i wont get a site. just a "Server not found" message -.-

Since i'm kinda new to this, i don't even know if ISPConfig is wholly configured.

i did not enter any Master/Slave DNS under the "DNS Manager" tab - just the default ns1/ns2 under "Administration -> Server -> Preferences"

I dont want to create any new, independent webs for the subdomains - just a forward to the users directory.

The domain team-hal.de is working fine.

Thanks in advance

Regards,

DrDon


P.S.: Don't ask me why i talk so much of nameservers....i just suspect them to be the bad ones
Reply With Quote
Sponsored Links
  #2  
Old 24th April 2007, 09:35
todvard todvard is offline
Member
 
Join Date: Aug 2005
Posts: 85
Thanks: 1
Thanked 6 Times in 5 Posts
Default

The "drdon" hostname has to be configured in the DNS server as an A record. Ask your DNS provider to do it.
In the meantime you can test the forward function by adding drdon.team-hal.de to you hosts file (/etc/hosts - in linux; c:\windows\system32\drivers\etc\hosts - in windowsXP), but don't forget, by this way it will work only for you.
Reply With Quote
The Following User Says Thank You to todvard For This Useful Post:
DrDon (24th April 2007)
  #3  
Old 24th April 2007, 10:04
DrDon DrDon is offline
Junior Member
 
Join Date: Apr 2007
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
Send a message via ICQ to DrDon Send a message via MSN to DrDon
Default

Quote:
Originally Posted by todvard
The "drdon" hostname has to be configured in the DNS server as an A record. Ask your DNS provider to do it.
In the meantime you can test the forward function by adding drdon.team-hal.de to you hosts file (/etc/hosts - in linux; c:\windows\system32\drivers\etc\hosts - in windowsXP), but don't forget, by this way it will work only for you.

thank you!

Got it fixed, i can add them myself by editing the zonefiles (dont ask me why i did not found them yesterday ^^)

Now, theres just one question left.

Can i configure ISPConfig to add the A records to the Nameservers itself?
Reply With Quote
  #4  
Old 24th April 2007, 11:12
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,444
Thanks: 813
Thanked 5,209 Times in 4,085 Posts
 
Default

First, editing the zonefiles manually is a bad idea as ISPConfig will remove your changes if they are not at the bottom of the file.

You can easily add DNS A_REcords in the ISPConfig DNS-Manager, manual editing is not nescessary.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 16:59
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
Problem with Samba PDC and Windows domain padmx82 Server Operation 0 28th March 2007 19:35
Small domain and mail problem mphayesuk General 1 1st March 2007 15:12
Problem with Domain and Statistic thgenzel General 1 18th January 2007 07:45


All times are GMT +2. The time now is 16:24.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.