Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th September 2005, 10:29
xma xma is offline
Junior Member
 
Join Date: Sep 2005
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default Installation problem

Hi to all,

I'm trying to install ispconfig in a Suse BOX, but when the installation is ending I have the next problem:

Connected successfully to MySQL server
ERROR 1044 (42000): Access denied for user ''@'localhost' to database 'db_ispconfig'
ls: /etc/apache2/vhosts.d/*.conf: No existe el fichero o el directorio
ls: /etc/apache2/vhosts.d/*.conf: No existe el fichero o el directorio
Restarting some services...
which: no apachectl in (/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin
:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/libexec)

It seems that cannot connect to mysql server but when installation test the mysql server all works fine.
And it seems there is an apache problem also.

Can anyone help me?

Thanks to all
Reply With Quote
Sponsored Links
  #2  
Old 6th September 2005, 11:49
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,388
Thanks: 833
Thanked 5,485 Times in 4,317 Posts
Default

Quote:
Originally Posted by xma
Hi to all,

I'm trying to install ispconfig in a Suse BOX, but when the installation is ending I have the next problem:

Connected successfully to MySQL server
ERROR 1044 (42000): Access denied for user ''@'localhost' to database 'db_ispconfig'
ls: /etc/apache2/vhosts.d/*.conf: No existe el fichero o el directorio
ls: /etc/apache2/vhosts.d/*.conf: No existe el fichero o el directorio
Restarting some services...
which: no apachectl in (/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin
:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/libexec)

It seems that cannot connect to mysql server but when installation test the mysql server all works fine.
And it seems there is an apache problem also.

Can anyone help me?

Thanks to all

Do you have any special chars in your mysql password and do you used the mySQL root user or another user that has the permissions to create databases?

Tu run the installer again, delete the directorys:

/root/ispconfig
/home/admispconfig

and the install_ispconfig directory before you try to install again. Dont forget to unpack the installer tar.gz file again.
Reply With Quote
  #3  
Old 22nd September 2005, 05:44
dianer dianer is offline
Member
 
Join Date: Sep 2005
Location: Dover, PA, USA
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Angry installation question

Quote:
Originally Posted by till
Do you have any special chars in your mysql password and do you used the mySQL root user or another user that has the permissions to create databases?

Tu run the installer again, delete the directorys:

/root/ispconfig
/home/admispconfig

and the install_ispconfig directory before you try to install again. Dont forget to unpack the installer tar.gz file again.
I have installed isp config...i got the message, congratulations, your ispconfig system is now installed. However, I've gotten sever mssg that cd: cannot stat '/home/admisconfig/ispconfig/users': No such file or directory
there are several that state that....also I got the
Warning: main(config.inc.php): failed to open streat: No such file or directory in /root/install_ispconfig/install.php on line 624

Warning: main(): Failed opening 'config.inc/php' for inclusion (include_path='.: /root/ispconfig/php/lib/php') in /root/install_ispconfig/install.php on line 624

Warning: mysql_connect(): Access denied for user: 'root@localhost' (Using password: NO) in /root/install_ispconfig/install.php on line 634

Could not connect to db
Restarting some services...
./setup2: line 883 [: ==: unary operator expected
./setup2: line 901: /etc.init.d/ispconfig_server: No such file or directory

Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.

I cannot access my ISPConfig system.
Reply With Quote
  #4  
Old 22nd September 2005, 05:45
dianer dianer is offline
Member
 
Join Date: Sep 2005
Location: Dover, PA, USA
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Default ispconfig problem

Quote:
Originally Posted by till
Do you have any special chars in your mysql password and do you used the mySQL root user or another user that has the permissions to create databases?

Tu run the installer again, delete the directorys:

/root/ispconfig
/home/admispconfig

and the install_ispconfig directory before you try to install again. Dont forget to unpack the installer tar.gz file again.

I also never came to the section where is asks for this:

Afterwards the following information has to be provided:

Please enter your MySQL server: E.G. localhost
Please enter your MySQL user: E.G. root
Please enter your MySQL password: Your MySQL password
Please enter a name for the ISPConfig database: E.g. ispconfigdb
Please enter the IP address of the ISPConfig web: E.g. 192.168.0.1
Please enter the host name: E.g. www
Please enter the domain: E.g. xyz.de
Please select the protocol (http or https (SSL encryption)) to use to access the ISPConfig system: If you want to use your control panel with SSL, select 1. You can then access it under https://www.xyz.de:81. If you want to access it under http://www.xyz.de:81, choose 2.

What did I do wrong? What should I do now?
Reply With Quote
  #5  
Old 22nd September 2005, 09:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

I guess you tried to install ISPConfig several times, without deleting the original install_ispconfig directory first. If your first installation fails, then delete the directory install_ispconfig, unpack the tar.gz file again. go to the new install_ispconfig directory and start the installation again. In your case I'd suggest that you also delete /root/ispconfig and /home/ispconfig before.

BTW, there are 3 or 4 threads that deal with this problem... There's also a note in the installation instructions on http://www.ispconfig.org/manual_installation.htm:

Quote:
In case not all conditions are fulfilled the setup script stops. Install the missing software, delete the directoy install_ispconfig, unpack ISPConfig again and start from the beginning.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 22nd September 2005, 15:09
dianer dianer is offline
Member
 
Join Date: Sep 2005
Location: Dover, PA, USA
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Default ISPConfig

Quote:
Originally Posted by falko
I guess you tried to install ISPConfig several times, without deleting the original install_ispconfig directory first. If your first installation fails, then delete the directory install_ispconfig, unpack the tar.gz file again. go to the new install_ispconfig directory and start the installation again. In your case I'd suggest that you also delete /root/ispconfig and /home/ispconfig before.

BTW, there are 3 or 4 threads that deal with this problem... There's also a note in the installation instructions on http://www.ispconfig.org/manual_installation.htm:
Yes, I did.

Thanks.....
Reply With Quote
  #7  
Old 23rd September 2005, 06:27
dianer dianer is offline
Member
 
Join Date: Sep 2005
Location: Dover, PA, USA
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Red face ISPConfig

Quote:
Originally Posted by falko
I guess you tried to install ISPConfig several times, without deleting the original install_ispconfig directory first. If your first installation fails, then delete the directory install_ispconfig, unpack the tar.gz file again. go to the new install_ispconfig directory and start the installation again. In your case I'd suggest that you also delete /root/ispconfig and /home/ispconfig before.

BTW, there are 3 or 4 threads that deal with this problem... There's also a note in the installation instructions on http://<br /> <br /> <br /> :o h...tallation.htm:
I've finally gotten ispconfig installed. I can access it using my 192.168.1.XXX ip address. Now I need to know how to login to the ispconfig panel....i never got a place to enter a username or password during setup....how do I go about setting up an administrator username and password?
Reply With Quote
  #8  
Old 23rd September 2005, 08:58
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,388
Thanks: 833
Thanked 5,485 Times in 4,317 Posts
Default

Quote:
Originally Posted by dianer
I've finally gotten ispconfig installed. I can access it using my 192.168.1.XXX ip address. Now I need to know how to login to the ispconfig panel....i never got a place to enter a username or password during setup....how do I go about setting up an administrator username and password?
Hi Dianer,

we are all trying to help you with the installation of ISPConfig and i know it's not easy to learn linux if you came from the windows world, but asking questions here can not be an replacement for reading the installation manual. Falko has posted the link above, i will post it here again for you:

http://www.ispconfig.org/manual_installation.htm

There you will find this text:

Quote:
After you have answered the questions ISPConfig should be duly installed. If you indicated www as host and xyz.com as the domain during the installation, you will find the ISPConfig interface under
https://www.xyz.de:81 or http://www.xyz.de:81. Here you can login first with the user name admin and password
admin.
It is recommended to change the password immediately! This can be done under Tools
-> Change password.
Reply With Quote
  #9  
Old 23rd September 2005, 13:19
dianer dianer is offline
Member
 
Join Date: Sep 2005
Location: Dover, PA, USA
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Default Thank you

Quote:
Originally Posted by till
Hi Dianer,

we are all trying to help you with the installation of ISPConfig and i know it's not easy to learn linux if you came from the windows world, but asking questions here can not be an replacement for reading the installation manual. Falko has posted the link above, i will post it here again for you:

http://www.ispconfig.org/manual_installation.htm

There you will find this text:
I understand....I appreciate all your help...I should be good to go from here.
Reply With Quote
  #10  
Old 25th September 2005, 05:40
dianer dianer is offline
Member
 
Join Date: Sep 2005
Location: Dover, PA, USA
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

we have everything installed....the last issue is: when we try to access the information under the management tab and system configurations or anything further down the page we get page cannot be displayed errors....when we open the link in another window, our domain name appears and we get the page cannot be displayed but when we change the url to show the ip address of the server, it works. how do we change the information so that this works correctly?....i've read the manual and cannot find the answer to this question anywher.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot login via ssh after installation sone Installation/Configuration 40 2nd March 2007 17:29
Installation problem: PHP problem? hgoor Installation/Configuration 7 21st August 2005 22:15
Installation Problem _InFeCtOr Installation/Configuration 5 8th August 2005 15:34
Trouble with Installation. cjkeeme Installation/Configuration 3 3rd August 2005 18:46
I think I am almost there one major problem left benkong2 Installation/Configuration 2 2nd August 2005 07:58


All times are GMT +2. The time now is 12:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.