Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 4th September 2006, 18:51
chewtoy chewtoy is offline
Junior Member
 
Join Date: Sep 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Ubuntu Samba -- 'Unknown User' error in Win2k?

Greetings, and thank-you to till for the clear & concise Ubuntu Samba HOWTO!

I think I've almost got it working, but I'm having trouble logging onto the domain from my Win2k box. I'm sure it's something simple, but it's apparently beyond me. Can someone point me in the right direction?

When I try to configure the Win2k box to logon to the domain for the first time, I get this: "The following error occurred attempting to join the domain 'JGENET': Logon failure: unknown user name or bad password." This happens whether I try to logon as 'root' or as my username (which I think is configured as a domain admin Samba). I've tried both my Samba root password and my system root password (which I didn't expect to work).

Note that I can see the Ubuntu box on the network (otherwise I'd get a 'domain not found' error, instead of an 'unknown user'). I can also logon successfully (I think?) from the Ubuntu box to localhost using smbclient, for both my root account and my user account. That tells me that I don't have a smbpasswd problem, right?

So it seems like there's some kind of mismatch between what Windows is sending the server and what the server wants. I tried changing my Windows username to match my Ubuntu user account, but that was no help. I also tried setting the Samba log level higher, but the output was too cryptic (and too voluminous) for me to parse it.

I've done all the flailing that I can think of, and so now I'm crying out for help. Any advice? I can provide plenty more details -- I've just left them out for brevity here. Thanks!

Last edited by chewtoy; 4th September 2006 at 18:57.
Reply With Quote
Sponsored Links
  #2  
Old 4th September 2006, 19:18
chewtoy chewtoy is offline
Junior Member
 
Join Date: Sep 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Example log.smbd output

As an additional bit of information, here is the output of cat log.smbd | grep -B 1 root.

From what's below, it looks to me like Samba thinks it's authorizing the Win2k client correctly?!? Am I insane, or just naive? What's going on here?

(As a side note, the block below appears twice in the log.smbd file. One block right after the other. I'd love to know why that happens, unless it's just Windows being persistent and trying to authenticate twice after (it thinks) the first attempt failed.)

The domain is JGENET. This is correct.
The Win2k workstation is SNUGGLES. Don't ask.

cat log.smbd | grep -B 1 root:
Code:
--
[2006/09/04 13:12:43, 3] libsmb/ntlmssp.c:ntlmssp_server_auth(662)
  Got user=[root] domain=[JGENET] workstation=[SNUGGLES] len1=24 len2=24
--
[2006/09/04 13:12:43, 3] auth/auth.c:check_ntlm_password(219)
  check_ntlm_password:  Checking password for unmapped user [JGENET]\[root]@[SNU
GGLES] with the new password interface
[2006/09/04 13:12:43, 3] auth/auth.c:check_ntlm_password(222)
  check_ntlm_password:  mapped user is: [JGENET]\[root]@[SNUGGLES]
--
[2006/09/04 13:12:43, 3] auth/auth.c:check_ntlm_password(268)
  check_ntlm_password: sam authentication for user [root] succeeded
--
[2006/09/04 13:12:43, 2] auth/auth.c:check_ntlm_password(307)
  check_ntlm_password:  authentication for user [root] -> [root] -> [root] succe
eded
--
[2006/09/04 13:12:43, 3] smbd/password.c:register_vuid(257)
  User name: root       Real name: root
[2006/09/04 13:12:43, 3] smbd/password.c:register_vuid(276)
  UNIX uid 0 is UNIX user root, and will be vuid 101
[2006/09/04 13:12:43, 3] smbd/password.c:register_vuid(305)
  Adding homes service for user 'root' using home directory: '/root'
[2006/09/04 13:12:43, 3] param/loadparm.c:lp_add_home(2547)
  adding home's share [root] for user 'root' at '/root'
--
[2006/09/04 13:12:43, 3] smbd/service.c:make_connection_snum(693)
  snuggles (192.168.1.5) connect to service IPC$ initially as user root (uid=0,
gid=0) (pid 14318)
--
Reply With Quote
  #3  
Old 5th September 2006, 15:21
linuxgh linuxgh is offline
Junior Member
 
Join Date: Sep 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

ggsbbb
gkgcg

Last edited by linuxgh; 22nd March 2007 at 17:50.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29
Samba as PDC using Ubuntu or Debian macaruchi HOWTO-Related Questions 5 1st August 2006 12:47
php script injections Grizzly General 21 18th July 2006 08:55
configuring IPTABLES firewall adityavpratap HOWTO-Related Questions 9 27th May 2006 21:42


All times are GMT +2. The time now is 04:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.