Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th September 2006, 09:29
phiberz phiberz is offline
Junior Member
 
Join Date: Sep 2006
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Enable php5 in ispconfig..

Hi!
Why isnt php5 enabled in ispconfig?

i see that the dev. version has it..

how do I run it as default? is it even possible?

atleast is it possible to run both php4 and 5?

RGDS Phiberz

Great Guides by the way
Reply With Quote
Sponsored Links
  #2  
Old 5th September 2006, 10:45
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

All ISPConfig versions support php4 and php5. ISPConfig uses the php that you installed on your server.

So this is not a question to enable or disable anything in ISPConfig.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 5th September 2006, 10:57
phiberz phiberz is offline
Junior Member
 
Join Date: Sep 2006
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok, but ive followed the http://www.howtoforge.com/perfect_setup_ubuntu_6.06
guide so i know php5 is installed (ive done exactly like the guide)
.... and it still reports php4 in phpinfo..
Reply With Quote
  #4  
Old 5th September 2006, 11:06
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Quote:
Originally Posted by phiberz
ok, but ive followed the http://www.howtoforge.com/perfect_setup_ubuntu_6.06
guide so i know php5 is installed (ive done exactly like the guide)
.... and it still reports php4 in phpinfo..
But php4 is not part of ISPConfig. Did you create a website in ISPConfig, put a PHP file with the phpinfo command inside in the webroot and called this in the browser?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 5th September 2006, 11:28
phiberz phiberz is offline
Junior Member
 
Join Date: Sep 2006
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok, strange then, yes did create a site and called the phpinfo file i uploaded to the new site folder, basic stuff.
Reply With Quote
  #6  
Old 6th September 2006, 08:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

What's the output of
Code:
ls -l /etc/apache2/mods-enabled
? What's in /etc/apache2/mods-enabled/php5.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 6th September 2006, 08:55
phiberz phiberz is offline
Junior Member
 
Join Date: Sep 2006
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

no enabled php5 mod. and no php5.conf...
Reply With Quote
  #8  
Old 6th September 2006, 10:59
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Then plaese install the php5 packages (mod_php) from your linux distribution.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 6th September 2006, 13:30
phiberz phiberz is offline
Junior Member
 
Join Date: Sep 2006
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

simply did a reinstall of the php5 and it worked... strange..
thanks!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
eaccelerator installation - can't find php5-config tom Programming/Scripts 9 15th May 2006 15:36
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 15:16
Install Error Alpha Installation/Configuration 9 6th April 2006 19:48
setup fails on debian 3.1 dtrumbower Installation/Configuration 7 7th March 2006 13:42
ISPConfig Failure on SuSe 9.3 gimhan90 Installation/Configuration 13 2nd February 2006 10:29


All times are GMT +2. The time now is 20:56.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.