#1  
Old 4th September 2006, 19:13
godsdog godsdog is offline
Member
 
Join Date: Apr 2006
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Default mb2md problems

Hi, I backed up all the user email files before performing a fresh install, and now trying to convert those files to maildir format.

I have mb2md installed and it constantly returns errors
Code:
perl mb2md-3.20.pl -s someone -d /var/www/www.domain.ca/user/someone/Maildir/
Fatal: Source is not an mbox file or a directory!
I'm left beleiving that my source files are not mbox...however I've popped one of the files open and notice that the emails are all separated by a
Code:
________________________________
line so it's more than likely me. Please help.
Reply With Quote
Sponsored Links
  #2  
Old 4th September 2006, 19:31
sjau sjau is offline
Local Meanie
 
Join Date: Apr 2006
Location: Switzerland
Posts: 1,145
Thanks: 4
Thanked 55 Times in 51 Posts
Default

maybe this helps:

http://batleth.sapienti-sat.org/projects/mb2md/

Just have a look at the commands available...
Reply With Quote
  #3  
Old 4th September 2006, 20:01
godsdog godsdog is offline
Member
 
Join Date: Apr 2006
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Default

This is the page I've been working from and it's pretty straight forward. I'm trying to figure out why my source file is apparently not mbox format. thanks anyways.
Reply With Quote
  #4  
Old 5th September 2006, 10:29
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,717
Thanks: 820
Thanked 5,322 Times in 4,175 Posts
Default

Have you tried the "-c" option? It might help if your mbox format is not recognized correctly.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 5th September 2006, 16:47
godsdog godsdog is offline
Member
 
Join Date: Apr 2006
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've tried that with the same results.
Reply With Quote
  #6  
Old 5th September 2006, 19:27
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Quote:
Originally Posted by godsdog
I'm left beleiving that my source files are not mbox...however I've popped one of the files open and notice that the emails are all separated by a
Code:
________________________________
line so it's more than likely me. Please help.
The mails should be separated by blank lines...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 5th September 2006, 19:54
sjau sjau is offline
Local Meanie
 
Join Date: Apr 2006
Location: Switzerland
Posts: 1,145
Thanks: 4
Thanked 55 Times in 51 Posts
Default

Hmmm, if the mails should be separated with a blank line you could do the following:

Have a script replace this

Code:
________________________________
by a blank line.
Reply With Quote
  #8  
Old 6th September 2006, 15:53
godsdog godsdog is offline
Member
 
Join Date: Apr 2006
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

There are many blank lines throughout the text file and I'm left believing this was not a standard file created by ISPconfig and is impossible to run a script on.

What I did was setup the old email server with an internal ip, and create both old and new email accounts in good ol' Outlook Express using IMAP and just clicked and dragged from inbox to inbox, changing the account names as I went along.

I am now a fan of maildir.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with groups/grpconv linuxfast General 28 21st April 2008 09:35
Empty Recycle Bin jon335 General 40 6th May 2006 11:56
Help! Real newbie having problems installing Linux t-kiss Kernel Questions 5 4th April 2006 15:14
Suse 10.0 Installation Problems protocol Installation/Configuration 16 9th February 2006 05:07
Problems getting through the installation klausagnoletti Installation/Configuration 4 26th September 2005 12:23


All times are GMT +2. The time now is 09:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.