#1  
Old 28th August 2006, 06:08
byteme byteme is offline
Junior Member
 
Join Date: Jun 2006
Location: Elkhart Indiana - US
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default Another Cant recieve mail

Have reinstalled twice now from susie 10.1 perfect-setup. Searched for the last several days before posting here.
Can send mail fine and mail is not returned to sender when sending to my email address. I also see no maillog files generated when I send or recieve.
Have Server set to Save log and maildir checked.

Output of netstat -tap below:
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:mysql *:* LISTEN 25880/mysqld
tcp 0 0 *:sunrpc *:* LISTEN 2750/portmap
tcp 0 0 *:ndmp *:* LISTEN 11796/perl
tcp 0 0 localhost:novell-zen *:* LISTEN 3000/zmd
tcp 0 0 *:hosts2-ns *:* LISTEN 16224/ispconfig_htt
tcp 0 0 *:ftp *:* LISTEN 17907/proftpd: (acc
tcp 0 0 linux-suse.djmil:domain *:* LISTEN 17886/named
tcp 0 0 localhost:domain *:* LISTEN 17886/named
tcp 0 0 *:ipp *:* LISTEN 3091/cupsd
tcp 0 0 *:smtp *:* LISTEN 21794/master
tcp 0 0 localhost:953 *:* LISTEN 17886/named
tcp 0 0 *:imaps *:* LISTEN 7307/couriertcpd
tcp 0 0 *op3s *:* LISTEN 7282/couriertcpd
tcp 0 0 *op3 *:* LISTEN 7208/couriertcpd
tcp 0 0 *:imap *:* LISTEN 7223/couriertcpd
tcp 0 0 *:www-http *:* LISTEN 16291/httpd2-prefor
tcp 0 0 *:ssh *:* LISTEN 2985/sshd
tcp 0 0 *:smtp *:* LISTEN 21794/master
tcp 0 0 localhost:953 *:* LISTEN 17886/named
tcp 0 0 *:https *:* LISTEN 16291/httpd2-prefor
tcp 0 0 linux-suse.djmiller:ssh 192.168.15.3%30864:esip ESTABLISHED 3298/0
tcp 0 148 linux-suse.djmiller:ssh 192.168.15:d-cinema-rrp ESTABLISHED 21204/2
---------------------------

Mail log below: only errors shown

Aug 26 23:39:41 linux postfix/postmap[4918]: warning: My hostname linux-suse is not a fully qualified name - set myhostname or mydomain in /etc/postfix/main.cf - I probobly missed this one in the set-up so edited the mail.cf file. which now is:


#
readme_directory = /usr/share/doc/packages/postfix/README_FILES
inet_protocols = all
biff = no
mail_spool_directory = /var/mail
canonical_maps = hash:/etc/postfix/canonical
#virtual_alias_maps = hash:/etc/postfix/virtual
virtual_alias_domains = hash:/etc/postfix/virtual
relocated_maps = hash:/etc/postfix/relocated
transport_maps = hash:/etc/postfix/transport
sender_canonical_maps = hash:/etc/postfix/sender_canonical
masquerade_exceptions = root
masquerade_classes = envelope_sender, header_sender, header_recipient
myhostname = linux-suse.djmiller.us
program_directory = /usr/lib/postfix
inet_interfaces = all
masquerade_domains =
#mydestination = $myhostname, localhost.$mydomain
defer_transports =
mynetworks_style = subnet
disable_dns_lookups = no
relayhost =
mailbox_command =
mailbox_transport =
strict_8bitmime = no
disable_mime_output_conversion = no
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
strict_rfc821_envelopes = no
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_ rel$
smtp_sasl_auth_enable = no
smtpd_sasl_auth_enable = yes
smtpd_use_tls = yes
smtp_use_tls = yes
alias_maps = hash:/etc/aliases
mailbox_size_limit = 0
message_size_limit = 10240000
mydomain = djmiller.us
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_tls_auth_only = no
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

Hope I have supplied enough info.

Thanks,
Dan
Reply With Quote
Sponsored Links
  #2  
Old 28th August 2006, 11:56
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,001
Thanks: 840
Thanked 5,650 Times in 4,460 Posts
Default

Did you install ISPConfig on this server or did you reinstall postfix with yast after you installed ISPConfig? The includes of the ISPConfig postfix configuration files are missing.

Please add:
Quote:
virtual_maps = hash:/etc/postfix/virtusertable
mydestination = /etc/postfix/local-host-names
at the end of your main.cf file and restart postfix.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 28th August 2006, 20:02
byteme byteme is offline
Junior Member
 
Join Date: Jun 2006
Location: Elkhart Indiana - US
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Till, I am sorry I did not include the last two entries when I posted my mail.cf file. Those 2 lines are the last two lines in the file already.
My last two installs were from the perfect set-up on a completely clean box.

Just noticed something that may be of interest.
While inside the network I can telnet to the box on both ports 25 and 110
From the outside world cannot telnet on port 25, 110 only.
My routers ports are open however I am using comcast cable. I called them today and got usless information as who I spoke with does not even understand the concept of ports. I was given another number to call but that number was no good.

I am assuming comcast is blocking incoming connections on port 25. Is there any work around on this? Anyone have similar issues?

After an hour or so on the phone with comcast I convinced them to force a new ip address for me. They said they were not blocking post 25 but after I got a new public IP all is fine.

Last edited by byteme; 29th August 2006 at 07:24.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Not receiving any incoming mail. Jcorrea920 General 11 3rd April 2010 14:08
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 09:27
:D All recieved mails goes to the system admin user ??help Mounir Installation/Configuration 8 31st July 2006 13:22
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs mholownych HOWTO-Related Questions 10 29th May 2006 04:39
Can't send or recieve mail either.. Geoinline Installation/Configuration 10 20th November 2005 19:40


All times are GMT +2. The time now is 03:56.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.