#1  
Old 25th August 2006, 23:09
LeoLinux LeoLinux is offline
Senior Member
 
Join Date: Jul 2006
Location: Ellwangen
Posts: 119
Thanks: 16
Thanked 0 Times in 0 Posts
Send a message via ICQ to LeoLinux
Default FTP won't work correctly ;-/

Hi there,

I want to access my FTP but it only works with the microsoft internet explorer ?! when I do the same with filezilla or other ftp programmes I wont get a tree of my files and file zilla gives me an error message:

Code:
Status:	Verbunden mit web2_leander.pc1service.gotdns.com. Warten auf Willkommens-Meldung...
Antwort:	220 ProFTPD 1.2.10 Server (WebServer) [192.168.1.101]
Befehl:	USER web2_leander
Antwort:	331 Password required for web2_leander.
Befehl:	PASS ********
Antwort:	230 User web2_leander logged in.
Befehl:	FEAT
Antwort:	211-Features:
Antwort:	211-MDTM
Antwort:	211-REST STREAM
Antwort:	211-SIZE
Antwort:	211 End
Befehl:	SYST
Antwort:	215 UNIX Type: L8
Status:	Verbindung hergestellt
Status:	Verzeichnisinhalt wird abgeholt...
Befehl:	PWD
Antwort:	257 "/" is current directory.
Befehl:	TYPE A
Antwort:	200 Type set to A
Befehl:	PASV
Antwort:	227 Entering Passive Mode (192,168,1,101,194,28).
Befehl:	LIST
Fehler:	Transferkanal konnte nicht geöffnet werden. Grund: Ein Verbindungsversuch ist fehlgeschlagen, da die Gegenstelle nach einer bestimmten Zeitspanne nicht ordnungsgemäß reagiert hat, oder die hergestellte Verbindung war fehlerhaft, da der verbundene Host nicht reagiert hat.
Fehler:	Dateiliste konnte nicht empfangen werden
Befehl:	TYPE A
what's the matter?

here my proftpd.conf:

Code:
ServerName                      "WebServer"
ServerType                      standalone
DeferWelcome                    off

MultilineRFC2228                on
DefaultServer                   on
ShowSymlinks                    on

TimeoutNoTransfer              6000
TimeoutStalled                 6000
TimeoutIdle                    12000


DisplayLogin                    welcome.msg
DisplayFirstChdir               .message
ListOptions                     "-l"

DenyFilter                      \*.*/

#PersistentPasswd               off

#TLSEngine                      on

#Quotas                         on

#Ratios                         on

Port                            21

#MaxInstances                   30
MaxInstances                    50

User                            nobody
Group                           nogroup

Umask                           022  022
AllowOverwrite                  on

#DelayEngine                    off

#################################################

DefaultRoot ~
IdentLookups off
ServerIdent on "FTP Server ready."


Include /etc/proftpd_ispconfig.conf

and here my /etc/proftpd_ispconfig.conf:

Code:
###################################
#
# ISPConfig proftpd Configuration File
#         Version 1.0
#
###################################
DefaultAddress 127.0.0.1
<VirtualHost 192.168.1.101>
        DefaultRoot             ~
        AllowOverwrite          on
        Umask                   002
</VirtualHost>
What's the matter with it? When I use Microsofts Internet Exploerer then everything seems to be ok, every web is reachable and and adn.. but the totaly opposit seems to be with firefox filezilla and other ftp programmes ... I don't know ...

thanks for helping.

best regards Leander
Reply With Quote
Sponsored Links
  #2  
Old 26th August 2006, 14:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Did you try both active and passive transfers in your FTP client? Did you try with the firewall on and off?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 27th August 2006, 23:55
LeoLinux LeoLinux is offline
Senior Member
 
Join Date: Jul 2006
Location: Ellwangen
Posts: 119
Thanks: 16
Thanked 0 Times in 0 Posts
Send a message via ICQ to LeoLinux
Default

Hi Falko,

it was the active passive mode ... :-) thx !

do you know how to change that in the proftpd.conf, so that I don't have to worry about anymore? because I don't want to describe that to everybody wich wants to connect to the server?!
that would be great, thx !

Leo
Reply With Quote
  #4  
Old 28th August 2006, 10:44
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,381
Thanks: 833
Thanked 5,482 Times in 4,316 Posts
Default

Quote:
Originally Posted by LeoLinux
Hi Falko,

it was the active passive mode ... :-) thx !

do you know how to change that in the proftpd.conf, so that I don't have to worry about anymore? because I don't want to describe that to everybody wich wants to connect to the server?!
that would be great, thx !
The problem is not in the proftpd.conf, the problem is either your router or firewall that blocks the upper FTP ports.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 27th October 2006, 16:47
LeoLinux LeoLinux is offline
Senior Member
 
Join Date: Jul 2006
Location: Ellwangen
Posts: 119
Thanks: 16
Thanked 0 Times in 0 Posts
Send a message via ICQ to LeoLinux
Default

Hi,

but I told my M0n0wall to forward port 21 - and nmap is also telling me that it works fine .... what's the matter?

Leo
Reply With Quote
  #6  
Old 28th October 2006, 15:23
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,381
Thanks: 833
Thanked 5,482 Times in 4,316 Posts
Default

Please double check that you forwarded the port to the correct server IP if you are in a NAT enviroment.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 28th November 2006, 22:00
LeoLinux LeoLinux is offline
Senior Member
 
Join Date: Jul 2006
Location: Ellwangen
Posts: 119
Thanks: 16
Thanked 0 Times in 0 Posts
Send a message via ICQ to LeoLinux
 
Default

Ok - it really was a firewall problem - I reinstalled m0n0wall and reconfigured the NAT settings and voilà it worked out fine ;-)

Thanks a lot ;-)

Leander
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! qvindesland Installation/Configuration 22 21st May 2007 16:05
No user logins work the_billness Installation/Configuration 1 10th August 2006 17:34
Ver nice work, but ftp didnt work deb1an Installation/Configuration 3 24th July 2006 11:05
Restoring email accounts doesnt work godsdog Installation/Configuration 2 20th July 2006 12:27
problem getting mod_rewrite to work stenzlem Server Operation 3 16th June 2006 02:33


All times are GMT +2. The time now is 00:10.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.