Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th August 2006, 08:34
dtrotter dtrotter is offline
Member
 
Join Date: Aug 2006
Location: Colorado
Posts: 36
Thanks: 1
Thanked 0 Times in 0 Posts
Send a message via AIM to dtrotter Send a message via MSN to dtrotter Send a message via Yahoo to dtrotter
Default ispconfig login error (mysql)

Hey all! I recently installed ispConfig and it was working great until I had some mysql issues. I thought that I got things figured out until I tried logging in to ispconfig as admin (or anyone else as far as that goes). Here is the error that I receive:

>>

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: YES) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: YES) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77

Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php:77) in /home/admispconfig/ispconfig/web/login/login.php on line 60

<<

I know it has to do with authentication between the mysql database and ispconfig, but I cant figure out how to resolve it.

Thank in advance everyone!

Thanks!

Devin
Reply With Quote
Sponsored Links
  #2  
Old 16th August 2006, 09:37
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,037
Thanks: 841
Thanked 5,656 Times in 4,464 Posts
Default

Plese check that the username and password for the mysql database in the file /home/admispconfig/ispconfig/lib/config.inc.php are correct for your mysql database. Then check with "netstat -tap" that your mysql database is listening on a tcp socket.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 17th August 2006, 01:29
dtrotter dtrotter is offline
Member
 
Join Date: Aug 2006
Location: Colorado
Posts: 36
Thanks: 1
Thanked 0 Times in 0 Posts
Send a message via AIM to dtrotter Send a message via MSN to dtrotter Send a message via Yahoo to dtrotter
Default

Ha! Go figure... I had already changed that to match the mysql password, but of course I had a typo. Thanks for getting me back on track! I reset it and restarted ispconfig and all is well now! Thanks a ton!

Devin
Reply With Quote
  #4  
Old 17th August 2006, 05:04
tommytomato tommytomato is offline
Senior Member
 
Join Date: Aug 2006
Posts: 129
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
Plese check that the username and password for the mysql database in the file /home/admispconfig/ispconfig/lib/config.inc.php are correct for your mysql database. Then check with "netstat -tap" that your mysql database is listening on a tcp socket.
I followed all the step in this tutorial
http://www.howtoforge.com/perfect_se...n_sarge_strato
and I cant seem to log into ISPconfig using admin admin. is there anyway to change it or reset it please.

I did check the above Quote details and Its all ok

TT
Reply With Quote
  #5  
Old 17th August 2006, 11:17
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,037
Thanks: 841
Thanked 5,656 Times in 4,464 Posts
Default

Quote:
Originally Posted by tommytomato
I followed all the step in this tutorial
http://www.howtoforge.com/perfect_se...n_sarge_strato
and I cant seem to log into ISPconfig using admin admin. is there anyway to change it or reset it please.

I did check the above Quote details and Its all ok
If this is your first login, then the problem is not the admin password, the problem is that ISPConfig is not able to connect to your mysql database or the sys_user table does not exist.

Please post the output of: netstat -tap

Have you created the database for ispconfig manually or did you run the ispconfig setup script several times?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 17th August 2006, 19:24
tommytomato tommytomato is offline
Senior Member
 
Join Date: Aug 2006
Posts: 129
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
If this is your first login, then the problem is not the admin password, the problem is that ISPConfig is not able to connect to your mysql database or the sys_user table does not exist.

Please post the output of: netstat -tap

Have you created the database for ispconfig manually or did you run the ispconfig setup script several times?

I re did this again, I'm having troubles with the https now
I did create the database this time as where before I may of miss it

any way to get it to load http instead of https




TT

Last edited by tommytomato; 17th August 2006 at 19:27.
Reply With Quote
  #7  
Old 18th August 2006, 01:17
dtrotter dtrotter is offline
Member
 
Join Date: Aug 2006
Location: Colorado
Posts: 36
Thanks: 1
Thanked 0 Times in 0 Posts
Send a message via AIM to dtrotter Send a message via MSN to dtrotter Send a message via Yahoo to dtrotter
Default

Are you sure you created the SSL Certificate correctly? Somtimes there is an error in the output that can very easily go unnoticed...

Here is a fairly good site for creating and using SSL certs:

http://www.akadia.com/services/ssh_t...rtificate.html
Reply With Quote
  #8  
Old 18th August 2006, 03:22
tommytomato tommytomato is offline
Senior Member
 
Join Date: Aug 2006
Posts: 129
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by dtrotter
Are you sure you created the SSL Certificate correctly? Somtimes there is an error in the output that can very easily go unnoticed...

Here is a fairly good site for creating and using SSL certs:

http://www.akadia.com/services/ssh_t...rtificate.html
what do they mean by enter pass phrase is like that a password ?

TT
Reply With Quote
  #9  
Old 18th August 2006, 08:17
tommytomato tommytomato is offline
Senior Member
 
Join Date: Aug 2006
Posts: 129
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm going through it again
here is my netstat -tap

Code:
members:~# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 *:imaps                 *:*                     LISTEN     1015/inetd
tcp        0      0 localhost.localdo:mysql *:*                     LISTEN     2428/mysqld
tcp        0      0 *:pop3                  *:*                     LISTEN     1015/inetd
tcp        0      0 *:imap2                 *:*                     LISTEN     1015/inetd
tcp        0      0 *:sunrpc                *:*                     LISTEN     816/portmap
tcp        0      0 *:auth                  *:*                     LISTEN     1015/inetd
tcp        0      0 192.168.1.4:domain      *:*                     LISTEN     2107/named
tcp        0      0 localhost.locald:domain *:*                     LISTEN     2107/named
tcp        0      0 *:790                   *:*                     LISTEN     1032/rpc.statd
tcp        0      0 *:ssh                   *:*                     LISTEN     1027/sshd
tcp        0      0 localhost.localdoma:953 *:*                     LISTEN     2107/named
tcp        0      0 *:smtp                  *:*                     LISTEN     1009/exim4
tcp        0    148 192.168.1.4:ssh         192.168.1.7:3208        ESTABLISHED1050/0
tcp        0      0 192.168.1.4:ssh         192.168.1.7:3213        ESTABLISHED1956/sshd: root@not
tcp        0      0 192.168.1.4:ssh         192.168.1.7:3212        ESTABLISHED1950/sshd: root@not
members:~#
TT
Reply With Quote
  #10  
Old 18th August 2006, 09:55
tommytomato tommytomato is offline
Senior Member
 
Join Date: Aug 2006
Posts: 129
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I got it going

just have to learn how to use it now

TT
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
User/Administrator Cannot login to ISPConfig... businesshost.ca Installation/Configuration 1 30th June 2006 00:08
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 16:16
User Login to ISPConfig DiOmega General 7 7th March 2006 20:44
Web-FTP Login, sits and then logs out of ISPConfig w/ errors teleriddler General 6 3rd March 2006 20:37
Total Frustration-HELP palkat Installation/Configuration 17 3rd September 2005 18:28


All times are GMT +2. The time now is 14:58.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.