#1  
Old 24th August 2006, 12:41
nvn nvn is offline
Member
 
Join Date: Apr 2006
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problems with FTP autologin

Hi...

SUSE 10.1, ISPCOnfig 2.2.6

I am writing a script to make a backup of my web-folders...

When i try to make an automated ftp transfer I'm asked for password.... ?

I'm using a file with the commands:

Code:
ftp < autoftp
File: autoftp

Code:
open ftpserver.dk
user
password
put *.*
bye
Then i get this:

Code:
web1:/backup # ftp < autoftp
Connected to ftpserver.dk.
220 ProFTPD 1.3.0 Server (ProFTPD Default Installation) [192.168.1.151]
Name (ftpserver.dk:root): 331 Password required for user.
Password:
If i enter the password the files are transmitted as it should.

I have tried it on windows XP

Same command:
Code:
ftp -i:autoftp
working perfect.


Please help me...
Reply With Quote
Sponsored Links
  #2  
Old 26th August 2006, 01:11
falko falko is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Did you have a look at these backup solutions? http://www.howtoforge.com/linux_rdiff_backup
http://www.howtoforge.com/mirroring_with_rsync
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 29th August 2006, 08:45
nvn nvn is offline
Member
 
Join Date: Apr 2006
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
 
Thumbs up

Hi Falko...

I found a solution..

I used a ".netrc" file in the ROOT home-dir

Not the best solution, but it works.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with groups/grpconv linuxfast General 28 21st April 2008 10:35
Empty Recycle Bin jon335 General 40 6th May 2006 12:56
Help! Real newbie having problems installing Linux t-kiss Kernel Questions 5 4th April 2006 16:14
problems mysql rayit General 15 1st April 2006 05:57
Suse 10.0 Installation Problems protocol Installation/Configuration 16 9th February 2006 06:07


All times are GMT +2. The time now is 01:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.