#1  
Old 28th August 2006, 13:58
web-worlds web-worlds is offline
Member
 
Join Date: Jan 2006
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
Default Trouble in paradise...

Hi,

I am allready since some time a happy ISPconfig user and mostly everything runs smootly, but this morning I wanted to create a MySQL database via the ISPconfig site, and something went wrong, I dont know what everything seems te be okay, but when I loged out of the ISPConfig and tried to re-login it gives me the following message...

Quote:
Warning: mysql_connect() [function.mysql-connect]: Access denied for user: 'root@localhost' (Using password: YES) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 76

Warning: mysql_connect() [function.mysql-connect]: Access denied for user: 'root@localhost' (Using password: YES) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 76

Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php:76) in /home/admispconfig/ispconfig/web/login/login.php on line 56
Anybody have a clue ghow to solve this ?

Thanks in advance,
Etienne (web-worlds)
Reply With Quote
Sponsored Links
  #2  
Old 28th August 2006, 14:04
web-worlds web-worlds is offline
Member
 
Join Date: Jan 2006
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Backtracing my steps I think that I know what happened...

I created a database for a site where I named the DB owner root, with the root password, then I removed the database, so I am afraid that I also deleted the root database user, because also via phpMyAdmin I cannot
login anymore as root ...


HELP

Etienne (web-worlds)
Reply With Quote
  #3  
Old 28th August 2006, 23:42
web-worlds web-worlds is offline
Member
 
Join Date: Jan 2006
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Anybody that can help out ???

Thanks in advance
Etienne (web-worlds)
Reply With Quote
  #4  
Old 29th August 2006, 08:38
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,717
Thanks: 820
Thanked 5,321 Times in 4,174 Posts
Default

Quote:
Originally Posted by web-worlds
Backtracing my steps I think that I know what happened...

I created a database for a site where I named the DB owner root, with the root password, then I removed the database, so I am afraid that I also deleted the root database user, because also via phpMyAdmin I cannot
login anymore as root ...
How did you do that, in ISPConfig?

To create a new root user for mysql, stop the mysql daemon, then you will be able to start the mysql daemon with the option --skip-grant-tables, then login with the root user without providing a password on the shell and create a new root user entry in the users database.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 29th August 2006, 12:00
web-worlds web-worlds is offline
Member
 
Join Date: Jan 2006
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Till,

Thanks for your reply, yes I did it in ISPConfig, I am willing to recreate it, but I still cant get into my MySQL, here is what I did:

In a terminal window:

Code:
 /etc/init.d/mysql stop
It tells me that the service is stopped, and I type:

Code:
mysqld_safe --skip-grant-tables
It then tells me:

Quote:
[1] 24632
server1:~ # Starting mysqld daemon with databases from /var/lib/mysql
Then it doesnt show a prompt, but I can go on, so I type:

Code:
 mysql -u root
Then it tells me 'Welcome t mySQL monitor etc, and I type:

Code:
use mysql;
It tells me that it changed the database, so I type:

Code:
update user set password=PASSWORD("new-password") where User='root';
It tells me:

Quote:
Query OK, 1 row affected (0.00 sec)
Rows matched: 1 Changed: 1 Warnings: 0
So I type:

Code:
flush privileges;
Then it tells:

Quote:
Query OK, 0 rows affected (0.00 sec)
Then I type:

Code:
quit
It then quits the MySQL monitor and brings me back to prompt, there I type:

Code:
/etc/init.d/mysql stop
It then tells me that MySQL safe is stopped, and I type:

Code:
 /etc/init.d/mysql start
It then starts the MySQL service, then I type:

Code:
   mysql -u root -p
Then it asks me for the password, I type the password that I just set, and it tells me:

Quote:
ERROR 1045: Access denied for user: 'root@localhost' (Using password: YES)
And I end up with the prompt

What do I do wrong???

Thanks in advance,
Etienne (web-worlds)
Reply With Quote
  #6  
Old 29th August 2006, 14:06
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,717
Thanks: 820
Thanked 5,321 Times in 4,174 Posts
Default

I guess you will have to insert a new root user for the host localhost instead of updating it.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 29th August 2006, 14:20
web-worlds web-worlds is offline
Member
 
Join Date: Jan 2006
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Oef...

And how will I do that, can you assist me in this ?

Kind regards,
Etienne
Reply With Quote
  #8  
Old 29th August 2006, 14:41
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,717
Thanks: 820
Thanked 5,321 Times in 4,174 Posts
 
Default

Just answered your pm.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Videocard trouble tanya004 Technical 1 5th August 2006 16:41
install trouble Boon-Dog-Danny Installation/Configuration 8 27th July 2006 11:56
Ethereal Trouble mcrosby Installation/Configuration 8 25th June 2006 03:50
Mail trouble web-worlds Installation/Configuration 15 27th January 2006 10:45
Trouble with sub/co domains allen Installation/Configuration 1 18th December 2005 19:38


All times are GMT +2. The time now is 18:23.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.