Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 21st August 2006, 01:11
vistree vistree is offline
Member
 
Join Date: Aug 2006
Posts: 61
Thanks: 2
Thanked 4 Times in 3 Posts
Default problem with vmware-image on an already running server

Hello,
I am new to this great software and the forum ;-)
I am running an already configured server with another ISP. Now I want to change to ispconfig - but first want my customers to try it out.

My idea: I installed vmware-server on the webserver an than I download the great out-of-the-box ISPConfig image from vmware-website.

It is now running but I can't reach the control panel or any website (which are different from the already existing ones !) out of the internet.

The server has a public ip and I setup the vmware-image to use NAT. On both now run an apache2 and postfix ....

The server is reachable but the vmware-image not ;-(
I tried to work with apache proxypass and .htaccess and apache mod_rewrite - but did't come to a result.

Does anyone in this forum tried out an equal solution?
Or does someone knows "out-of-the-box" ( ;-) what to do, that the websites and mails on the vmware-ISPconfig reach there target?

Thank you a lot
Kai
Reply With Quote
Sponsored Links
  #2  
Old 22nd August 2006, 12:55
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Quote:
Originally Posted by vistree
The server has a public ip and I setup the vmware-image to use NAT. On both now run an apache2 and postfix ....
Did you configure your server to forward requests to your virtual machine? Why didn't you use bridging?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 22nd August 2006, 16:58
vistree vistree is offline
Member
 
Join Date: Aug 2006
Posts: 61
Thanks: 2
Thanked 4 Times in 3 Posts
Default

Quote:
Originally Posted by falko
Did you configure your server to forward requests to your virtual machine? Why didn't you use bridging?
Hi Falco,
thank you for reply.

I want to install on a hosted webserver - and there is only one public IP included

The Forwarding is exact the problem I can't fit. I tried to find rules for iptables to portforward incomming on port 81 to port 81 of the vm-guest. I think I have not the accect way how to implement.

The same is on using apaches mod_rewrite.

May knowledge is to small to get it work ....

Any hints?

Kai
Reply With Quote
  #4  
Old 23rd August 2006, 15:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Quote:
Originally Posted by vistree
The Forwarding is exact the problem I can't fit. I tried to find rules for iptables to portforward incomming on port 81 to port 81 of the vm-guest. I think I have not the accect way how to implement.
Have a look here: http://www.howtoforge.com/perfect_setup_xen3_debian_p6
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 24th August 2006, 01:01
vistree vistree is offline
Member
 
Join Date: Aug 2006
Posts: 61
Thanks: 2
Thanked 4 Times in 3 Posts
Default

Hi Falca,
thank you for replying again - and for the link.

Quote:
Originally Posted by falko
It is a mess, but it still does not work. I tried to forward port 81 to receive the IPSConfig control panel and to forward all request to port 80 (both to the virtual machine). There is a long request time in the webbrowser, but result is a connection error.

I also tried the XEN 2.6 steps - but still no result. Also tried to disable all the rules on my host (iptables -F / iptables -t nat -F) and then inserting your rules - but still no result.

The host-machine uses a physical network adapter eth0 with public IP, a NAT-adapter from vmware (vmnet8 - ip 192.168.30.1) and lo. The vm has eth0 with 192.168.30.129 and lo.

Are there any rules in addition to your XEN tutorial to include in iptables?

Thank you a lot
Kai
Reply With Quote
  #6  
Old 24th August 2006, 12:37
vistree vistree is offline
Member
 
Join Date: Aug 2006
Posts: 61
Thanks: 2
Thanked 4 Times in 3 Posts
Thumbs up I got it!!

I found a first solution on my vmware-problems. I can now redirect tcp-request from a incomming port (e. g. 81) to the virtual machine.

What I did not know is: vmware-server has a configuration file for NAT, where you can enable port-forwarding.

Including 81:192.168.30.129:81

in

/etc/vmware/vmnet8/nat/nat.conf

does the job without any additional changes (e.g. on iptables).

Regards
Kai
Reply With Quote
  #7  
Old 24th August 2006, 13:25
freeborn freeborn is offline
Member
 
Join Date: Jul 2006
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Using bridge network more easier but you need one more real IP for vmware.
________
NEXIUM LAWSUIT
________
Breeana

Last edited by freeborn; 16th August 2011 at 01:50.
Reply With Quote
  #8  
Old 24th August 2006, 17:30
vistree vistree is offline
Member
 
Join Date: Aug 2006
Posts: 61
Thanks: 2
Thanked 4 Times in 3 Posts
 
Lightbulb ISPconfig on vmware virtual machine solved

Quote:
Originally Posted by freeborn
Using bridge network more easier but you need one more real IP for vmware.
He freeborn, as I mentioned out above - I have only ONE public IP so I need NAT.

After several hours of "trial and error" I found the solution.
1. I had to include 2 lines in vmware nat.conf
80=IP.of.the.vmwareguest:80
81=IP.of.the.vmwareguest:81

Nothing else as portforwarding using iptables!

Than - and this seems to be a bug within vmware-server - I had to start the vmware-image using a vmware console tool (vmware-cmd /pathtoimage/image.vmx start) instead of using the remote "VMWare Server Console".

And: now it works ;-)

Thank you for all the hints!
Kai
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 17:58
php Apps email not going through palkat General 8 21st September 2011 05:35
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
Email - Ueb-Miau mazhar Installation/Configuration 5 21st December 2005 10:01
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 02:30


All times are GMT +2. The time now is 19:50.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.