#1  
Old 4th October 2013, 14:38
ssd532 ssd532 is offline
Junior Member
 
Join Date: Oct 2013
Posts: 7
Thanks: 2
Thanked 0 Times in 0 Posts
Default Postfix with TLS not working

I have followed The Perfect Server - Debian Wheezy (Apache2, BIND, Dovecot, ISPConfig 3) Howto.

Postfix set up is not working. I am not able to receive mails. Relevant lines in main.cf are as following.

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_use_tls = yes


What I have observed is following.

- Postfix does not throw any error upon restart

- When I do telnet localhost 25, it successfully connects. But when I do ehlo localhost it simply closes the session

root@sun:/etc/postfix# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
ehlo localhost
Connection closed by foreign host.


- At this time I get following logs in mail.log

Oct 4 12:13:29 sun postfix/smtps/smtpd[19923]: SSL_accept error from localhost[127.0.0.1]: -1
Oct 4 12:13:29 sun postfix/smtps/smtpd[19923]: warning: TLS library problem: 19923:error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown protocol:s23_srvr.c:628:
Oct 4 12:13:29 sun postfix/smtps/smtpd[19923]: lost connection after CONNECT from localhost[127.0.0.1]
Oct 4 12:13:29 sun postfix/smtps/smtpd[19923]: disconnect from localhost[127.0.0.1]


I have tried using different pairs of certificate and key. But nothing is working. Please help.

Thank you.

Regards,
Sachin Divekar
Reply With Quote
Sponsored Links
  #2  
Old 4th October 2013, 14:51
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,991
Thanks: 825
Thanked 5,375 Times in 4,222 Posts
Default

Did you enable smtps and submission ports in postfix master.cf file?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
ssd532 (4th October 2013)
  #3  
Old 4th October 2013, 14:58
ssd532 ssd532 is offline
Junior Member
 
Join Date: Oct 2013
Posts: 7
Thanks: 2
Thanked 0 Times in 0 Posts
 
Smile Solved

Quote:
Originally Posted by till View Post
Did you enable smtps and submission ports in postfix master.cf file?
Thanks a lot Till. That was the problem. I forgot to uncomment smtps and submission port directives in master.cf

Thank you very much

Regards,
Sachin Divekar

Last edited by ssd532; 4th October 2013 at 14:58. Reason: correcting
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting Email Working ISPConfig3 Squirrelmail and Courier etc Ian Wilson Installation/Configuration 17 19th June 2013 22:58
How cai remove amavis from postfix ? gabrix Server Operation 16 2nd October 2012 09:58
Email from server driving me crazy chaloum General 29 13th April 2012 13:45
421 Unexpected failure Lizard King Installation/Configuration 20 7th July 2009 20:43
CentoS doesn't send the emails vaio1 Installation/Configuration 18 5th November 2008 17:51


All times are GMT +2. The time now is 16:04.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.