#1  
Old 3rd October 2013, 17:41
paka paka is offline
Junior Member
 
Join Date: Sep 2013
Posts: 14
Thanks: 9
Thanked 1 Time in 1 Post
Default Postfix: user unknown error

New installed v3.0.5.3 following:

Debian Wheezy (nginx, BIND, Dovecot, ISPConfig 3)

Outbound email functions normally.

Inbound email is bouncing due to unknown user:

Code:
Reporting-MTA: dns; xxxx.eu
X-Postfix-Queue-ID: 4F77A4240F
X-Postfix-Sender: rfc822; xxxx@xxxxxxxx.com
Arrival-Date: Thu,  3 Oct 2013 17:09:31 +0200 (CEST)

Final-Recipient: rfc822; tester@xxxxxx.xxx
Original-Recipient: rfc822;tester@xxxxxx.xxx
Action: failed
Status: 5.1.1
Diagnostic-Code: X-Postfix; unknown user: "tester"
There is one email account with the user 'tester' created from ISPConfig 3.0.5.3.

The directory for this user does exist:

Code:
[..]/tester/Maildir# ls
courierimapsubscribed  cur  dovecot.index.log  dovecot-uidlist	dovecot-uidvalidity  dovecot-uidvalidity.524d6e26  new	subscriptions  tmp
Any thoughts on this?

Update:
From the Mail Warning log:

Code:
Oct 4 01:10:20 fluffybunny postfix/trivial-rewrite[2705]: warning: do not list domain fluffybunny.eu in BOTH mydestination and virtual_mailbox_domains
Thanks

Last edited by paka; 4th October 2013 at 02:04. Reason: Added warning log entry.
Reply With Quote
Sponsored Links
  #2  
Old 4th October 2013, 08:37
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,402
Thanks: 834
Thanked 5,494 Times in 4,325 Posts
Default

Please edit the postfix main.cf file (/etc/postfix/main.cf) and replace all occurrences of "fluffy.......eu with a subdomain of that dmain like "mail.fluffy.......eu". Then restart postfix.

AS last step, add a dns a-record for mail.fluffy.......eu that points to the IP address of your server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
paka (4th October 2013)
  #3  
Old 4th October 2013, 13:49
paka paka is offline
Junior Member
 
Join Date: Sep 2013
Posts: 14
Thanks: 9
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by till View Post
Please edit the postfix main.cf file (/etc/postfix/main.cf) and replace all occurrences of "fluffy.......eu with a subdomain of that dmain like "mail.fluffy.......eu". Then restart postfix.
Cheers. Email being received after the simple edit you suggested.

I noticed the domain when reviewing main.cf but didn't think to add the subdomain.

Was this an error of mine when setting up ISPConfig? I ask as my preference is to learn from my mistakes.

Again, thank you.
Reply With Quote
  #4  
Old 4th October 2013, 14:32
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,402
Thanks: 834
Thanked 5,494 Times in 4,325 Posts
Default

Quote:
Was this an error of mine when setting up ISPConfig?
If you installed the operting system and postfix, then most likely yes. The hostname of the server is set as one of the first steps in the perfect setup guide and postfix asks for the mailname when it gets installed. In general, the hostname of a server (and also the mailname) should be a subdomain (in the guides we use server1.example.com as placeholder / example) to avoid problems in apache and postfix.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
paka (5th October 2013)
  #5  
Old 5th October 2013, 14:09
paka paka is offline
Junior Member
 
Join Date: Sep 2013
Posts: 14
Thanks: 9
Thanked 1 Time in 1 Post
 
Default

Quote:
Originally Posted by till View Post
The hostname of the server is set as one of the first steps in the perfect setup guide and postfix asks for the mailname when it gets installed. In general, the hostname of a server (and also the mailname) should be a subdomain (in the guides we use server1.example.com as placeholder / example) to avoid problems in apache and postfix.
Ah. So I must have used no subdomain at that point. Possibly accepting the default if there was one.

It would seem for a flawless ISPConfig install one requires two things:
  1. The Perfect Setup Guide ...
  2. The Perfect Admin

<sigh>

FWIW, excellent install guide.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3 system installation script Mark_NL Tips/Tricks/Mods 12 7th March 2014 06:30
Postfix not working after update SpeedyB ISPConfig 3 Priority Support 4 14th May 2013 16:11
postfix DoS Spam attack arraken Installation/Configuration 29 4th April 2013 14:08
Multiple postfix errors iandoug Server Operation 4 6th February 2013 22:40
Help configure Postfix to use alt port 465 or 587 BoloMarkIII Installation/Configuration 10 16th March 2009 17:57


All times are GMT +2. The time now is 16:58.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.