#1  
Old 27th February 2006, 20:55
guidovanh guidovanh is offline
Senior Member
 
Join Date: Feb 2006
Location: Leusden, The Netherlands
Posts: 104
Thanks: 0
Thanked 0 Times in 0 Posts
Default Spamassassin

My manual describes about Spamassassin to run after the installation of ISPConfig:

/home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamasssassin

and tells:

If errors appear you have to install some Perl modules:, followed by a list how to do that.

When I enter above mentioned command, the cursor comes onto a new line and no more.

I think this is ok, there are no errors. Is that right?
Reply With Quote
Sponsored Links
  #2  
Old 27th February 2006, 21:02
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,411
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

Yes, that's OK. You can return to the prompt by pressing [ctrl] + c
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 25th August 2006, 16:22
tarndt tarndt is offline
Junior Member
 
Join Date: Jun 2006
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Default

What about if you run:
/home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamasssassin

And you get the error:
bash: /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamasssassin: No such file or directory

?
Reply With Quote
  #4  
Old 25th August 2006, 17:56
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,411
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

Please execute:

ls -la /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 25th August 2006, 23:00
tarndt tarndt is offline
Junior Member
 
Join Date: Jun 2006
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Nevermind LOL I see the axtra s in spassassin...My spam assassin is not working however. Anything I can try? When I try the line mentioned (dropping the extra 's') I do get the blank line and need to Ctrl+C to get out.
Reply With Quote
  #6  
Old 25th August 2006, 23:10
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,259
Thanks: 215
Thanked 648 Times in 294 Posts
Default One more hint

Sometimes Spamassassin is not running after you started your server because in the file /etc/default/spamassassin there is a line like:

ENABLED=0

To enable Spamassassin after a reboot you have to change this line into:

ENABLED=1

You can try this, maybe it helps you one step further...

__________________
Hans

MrHostman | Master in managed hosting

Last edited by Hans; 25th August 2006 at 23:35.
Reply With Quote
  #7  
Old 26th August 2006, 14:33
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Quote:
Originally Posted by tarndt
I do get the blank line and need to Ctrl+C to get out.
That's the normal behaviour - spamassassin is waiting for input (e.g. a mail message). Normally you pipe email messages through it.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 29th August 2006, 18:11
tarndt tarndt is offline
Junior Member
 
Join Date: Jun 2006
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Default

/etc/default/spamassassin does not exist, howver the spamd daemon is running, and I can also execute spamassissin and spamc.

Anything else I can look for?
Reply With Quote
  #9  
Old 30th August 2006, 16:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Have a look at the directories in /home/admispconfig/ispconfig/tools/spamassassin.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 30th August 2006, 17:43
tarndt tarndt is offline
Junior Member
 
Join Date: Jun 2006
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

What should I be looking for here? All looks well. It just appears as though postfix is not piping the mail through spamassassin.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Autolearn=no SpamAssassin hendry Installation/Configuration 4 12th May 2007 10:24
Stopping Spamassassin DarkBen General 1 8th February 2006 15:46
Daemonized version of Spamassassin ddelbia General 1 6th January 2006 16:09
Spamassassin configuration DarkBen Installation/Configuration 1 4th January 2006 10:58
SpamAssassin Version? stiffmeister Technical 1 10th May 2005 22:43


All times are GMT +2. The time now is 18:02.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.