#1  
Old 16th July 2013, 17:40
keshwarsingh keshwarsingh is offline
Member
 
Join Date: Apr 2013
Posts: 31
Thanks: 2
Thanked 1 Time in 1 Post
Exclamation Disable ipv6 debian wheezy..

Hello,

Is the a proper way to disable ipv6 on wheezy ?
Sponsored Links
  #2  
Old 16th July 2013, 17:48
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,483
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

The following command works for squueze and I expect that it works for wheezy as well:

Code:
echo 'net.ipv6.conf.all.disable_ipv6=1' > /etc/sysctl.d/disableipv6.conf
and then reboot the server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
  #3  
Old 16th July 2013, 17:52
keshwarsingh keshwarsingh is offline
Member
 
Join Date: Apr 2013
Posts: 31
Thanks: 2
Thanked 1 Time in 1 Post
Default

Did that..

Upon reboot, i can still see some service listening on v6
  #4  
Old 16th July 2013, 19:53
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,483
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

Please check the file /etc/sysctl.d/disableipv6.conf, if the line in that file is enclosed in ', then remove ' at the beginning and the end of the line and reboot.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
  #5  
Old 18th July 2013, 22:49
keshwarsingh keshwarsingh is offline
Member
 
Join Date: Apr 2013
Posts: 31
Thanks: 2
Thanked 1 Time in 1 Post
Default

There is no ' ...

This workaround works on squeeze, but not on wheezy
  #6  
Old 19th July 2013, 09:11
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,483
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
 
Default

I had a typo in the path, please use this path:

/etc/sysctl.d/disable-ipv6.conf
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Installation just stops, and dies. cosmicsafari Installation/Configuration 3 19th July 2011 10:24
Something blocking port 53 stigge2000 Installation/Configuration 4 5th April 2011 14:46
[debian 5 + ispconfig 3] Unable to send mail tanakskool HOWTO-Related Questions 6 4th November 2009 18:20
Bind Failed christoph2k HOWTO-Related Questions 4 28th April 2007 00:57
e-mail problem!!! Debian 3.1 maroonworks Installation/Configuration 18 6th December 2005 14:42


All times are GMT +2. The time now is 10:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.