#1  
Old 8th July 2013, 06:34
skoena skoena is offline
Senior Member
 
Join Date: Sep 2009
Location: Emmen, Netherlands
Posts: 421
Thanks: 77
Thanked 13 Times in 11 Posts
Send a message via MSN to skoena Send a message via Skype™ to skoena
Default inboxes empty after migration

I did a migration to a new server. I copied /var/vmail to the new server. But all the inboxes of the email accounts are empty. How to migrate them without knowing the users passwords?
Reply With Quote
Sponsored Links
  #2  
Old 8th July 2013, 12:24
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,060
Thanks: 826
Thanked 5,395 Times in 4,239 Posts
Default

Does the old and new server use the same imap server (courier or dovecot) If not, then inboxes will be empty as courier and dovecot used different folder structures.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 8th July 2013, 12:27
skoena skoena is offline
Senior Member
 
Join Date: Sep 2009
Location: Emmen, Netherlands
Posts: 421
Thanks: 77
Thanked 13 Times in 11 Posts
Send a message via MSN to skoena Send a message via Skype™ to skoena
Default

Hi Till,
Yes you are right. One uses dovecot and the other courier.

Any way to get the emails somewhere into some folders back? Or should I create old folder names?
Reply With Quote
  #4  
Old 8th July 2013, 12:52
skoena skoena is offline
Senior Member
 
Join Date: Sep 2009
Location: Emmen, Netherlands
Posts: 421
Thanks: 77
Thanked 13 Times in 11 Posts
Send a message via MSN to skoena Send a message via Skype™ to skoena
Default

Can I use your Courier to Dovecot script on the old server to rename the folder structure and than do a rsync of the /var/vmail folder to the new server that hads Dovecot?

http://www.howtoforge.com/forums/sho...80&postcount=3
Reply With Quote
  #5  
Old 8th July 2013, 13:18
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,060
Thanks: 826
Thanked 5,395 Times in 4,239 Posts
Default

That should work.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
skoena (8th July 2013)
  #6  
Old 8th July 2013, 20:27
skoena skoena is offline
Senior Member
 
Join Date: Sep 2009
Location: Emmen, Netherlands
Posts: 421
Thanks: 77
Thanked 13 Times in 11 Posts
Send a message via MSN to skoena Send a message via Skype™ to skoena
Default

Yes tnx Till, it worked!
Reply With Quote
  #7  
Old 8th July 2013, 22:15
skoena skoena is offline
Senior Member
 
Join Date: Sep 2009
Location: Emmen, Netherlands
Posts: 421
Thanks: 77
Thanked 13 Times in 11 Posts
Send a message via MSN to skoena Send a message via Skype™ to skoena
 
Default

Strange thing is.
I installed new server and configured server (The Perfect Server). I think it configures Dovecot and Sieve. After that I migrated from the old server, it is configured like Courier and Maildrop. I also copied the ispconfig database I guess it changed the setting in ispconfig back to courier and maildrop. Because when I open the new server and go to System > Server Config > Mail it sais:

Quote:
POP3/IMAP Daemon: Courier
Mailfilter Syntax: Maildrop
Should I change it to Dovecot and Sieve? Because I think everything works fine...?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
problem in using : perfect-server-ubuntu-12.10-apache2-bind-dovecot-ispconfig-3, rezabagheri Installation/Configuration 7 30th October 2012 22:55
DNS ISSUES connect failed: 127.0.0.1 # 953: connection refused BrainyForge Installation/Configuration 10 28th January 2012 12:31
Bind9 failed to start after server restart laptop_user Installation/Configuration 2 1st October 2011 10:35
Vhosts...conf not synced to changes crypted General 50 24th April 2010 00:54
Ubuntu Hardy chrooted bind9 fails to start Djamu Server Operation 35 21st April 2010 08:28


All times are GMT +2. The time now is 16:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.