Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 18th October 2013, 08:23
Der-Tim Der-Tim is offline
Junior Member
 
Join Date: Aug 2012
Posts: 4
Thanks: 0
Thanked 1 Time in 1 Post
Default Apache mod_geoip - Protect folders?

Hi there,

I tried to use the "additional Apache directives" function to protect some webfolders from being accessed from some countries using geoip. I did it like I did it some times before with other apache hosted sites (not using ISPConfig) like in this example:

Code:
<Directory /var/www/clients/clientX/webXX/web/ProtectedDir>
 <Limit GET POST>
  SetEnvIf GEOIP_COUNTRY_CODE DE AllowCountry
  order deny,allow
  deny from all
  allow from env=AllowCountry
 </Limit>
</Directory>
It works like a charm on any standalone apache, but not with ISPConfig. Does anyone have a recommendation how to solve this problem? It's caused by an Allow from ALL in the main / generated part of the configuration file per VHost.

Specs: Ubuntu 13.04, Apache 2.2.22, PHP 5.4.9, MySQL 5.5.32, ISPConfig 3.0.5.3

Regards, Tim
Reply With Quote
Sponsored Links
  #2  
Old 18th October 2013, 18:22
Der-Tim Der-Tim is offline
Junior Member
 
Join Date: Aug 2012
Posts: 4
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

I actually managed it by using an .htaccess file within the webroot ... But it would be more comfortable (even for the user) to have configuration snippets for the apache directives within ISPConfig, am I right? ;-)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sessions not being saved gavimobile General 6 15th January 2012 15:05
trying to install roundcubemail ressel Installation/Configuration 13 24th December 2009 20:13
problems with suexec gobokster Installation/Configuration 7 7th May 2009 13:33
CENTOS 5 Ping Problem gAnDo Server Operation 11 28th March 2008 20:58
Problem with the installation of Dokeos (LMS) in ISPConfig jofranco General 4 28th April 2006 00:45


All times are GMT +2. The time now is 18:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.