Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th June 2013, 06:55
sipherdee sipherdee is offline
HowtoForge Supporter
 
Join Date: Jun 2013
Location: Montreal, QC, Canada
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to sipherdee Send a message via Skype™ to sipherdee
Default Unable to generate a CSR using the control panel

"To create a self-signed certificate, please fill out the fields State, Locality, Organisation, Organisation Unit, Country, and SSL Domain, and then select Create Certificate from the SSL Action drop-down menu, and click on Save. Leave the fields SSL Key, SSL Request, SSL Certificate, and SSL Bundle empty - the fields SSL Key, SSL Request and SSL Certificate will be filled out by the system."

I am following those instructions and nothing is happening. "SSL Key", "SSL Request" and "SSL Certificate" are not filled out as they should. What do you suggest? In fact, I want to create a certificate signing request to get one from a certificate authority. I tried restarting Apache, looked at the 'ssl' directory for my sites and nothing is getting created. Also, I did not find anything in the logs. Correct data is entered for 'State', 'Locality', 'Organisation', 'Organisation Unit' and 'Country'. Thanks in advance for your help!

Last edited by sipherdee; 12th June 2013 at 18:00.
Reply With Quote
Sponsored Links
  #2  
Old 12th June 2013, 17:27
sipherdee sipherdee is offline
HowtoForge Supporter
 
Join Date: Jun 2013
Location: Montreal, QC, Canada
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to sipherdee Send a message via Skype™ to sipherdee
Lightbulb

Is it possible that this could be because "IPv4-Address" = "*" for our websites? "Enable SNI" is checked under 'ISPConfig > System > Server Config > Web > SSL Settings'.

Thanks in advance if you have any idea!
Reply With Quote
  #3  
Old 12th June 2013, 17:37
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
Default

The ssl csr generation does not depend on the IP address, so thats not related. The most common problem is that one of the ssl data fields contains wrong data, e.g. openssl is sensitive when it comes to special chars.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 12th June 2013, 18:00
sipherdee sipherdee is offline
HowtoForge Supporter
 
Join Date: Jun 2013
Location: Montreal, QC, Canada
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to sipherdee Send a message via Skype™ to sipherdee
 
Default

Thanks for your answer but no special characters are being used, i.e.:

State = QC
Locality = Montreal
Organisation = Organisation Name
Organisation Unit = Name
Country = Canada
SSL Domain = host.domain.ca

I also tried to change the state to 'Quebec' which gave the same result. Is there a log file or something that I could check for troubleshooting?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ubuntu and nginx delgado2061 Installation/Configuration 0 27th November 2011 23:36
Cannot login to phpmyadmin penkku HOWTO-Related Questions 1 24th February 2011 09:26
Forbidden 403; Samba access; config of maildeamon fawkes Installation/Configuration 4 14th January 2010 18:16
HotSaNIC domino Tips/Tricks/Mods 23 6th November 2006 05:19
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29


All times are GMT +2. The time now is 22:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.