#1  
Old 11th June 2013, 02:42
m33ts4k0z m33ts4k0z is offline
Junior Member
 
Join Date: Jun 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Can't send or receive emails.

Hello all and thanks for this wonderful project,

I'm new to linux and yesterday I setup a new Debian 7.0 server. I installed ISPConfig3 succesfully using the guides on this site and I'm able to access the control panel. However trying to receive an email looks impossible. Ive spent many hours today without being able to identify the cause.

I'm able to connect to the mail server using outlook 2010 and the server doesn't respond any errors on the connection. However sending an email using gmail doesnt pop anything up in my mailbox and the connection in Outlook just opens and closes without error.

I'm using a dyndns address and my router has the ports: 110,143 and 25 forwarded. I know I'm not able to send emails on port 25 because my ISP is blocking it but for starters I would like to be able to receive messages.

Here are the logs:

mail.err:

Code:
Jun 10 22:09:02 techcity amavis[30033]: (30033-01) (!!)TROUBLE in process_request: connect_to_sql: unable to connect to any dataset at (eval 111) line 247.
mail.info:

Code:
 Jun 11 02:14:28 techcity amavis[27514]: Found decoder for    .cab  at /usr/bin/cabextract
Jun 11 02:14:28 techcity amavis[27514]: No decoder for       .tnef
Jun 11 02:14:28 techcity amavis[27514]: Internal decoder for .tnef
Jun 11 02:14:28 techcity amavis[27514]: Found decoder for    .exe  at /usr/bin/arj
Jun 11 02:14:28 techcity amavis[27514]: Using primary internal av scanner code for ClamAV-clamd
Jun 11 02:14:28 techcity amavis[27514]: Found secondary av scanner ClamAV-clamscan at /usr/bin/clamscan
Jun 11 02:14:28 techcity amavis[27514]: Deleting db files __db.003,__db.001,nanny.db,snmp.db,__db.002,__db.004 in /var/lib/amavis/db
Jun 11 02:14:28 techcity amavis[27514]: Creating db in /var/lib/amavis/db/; BerkeleyDB 0.51, libdb 5.1
Jun 11 02:14:46 techcity dovecot: auth-worker(27522): mysql(localhost): Connected to database dbispconfig
Jun 11 02:14:46 techcity dovecot: pop3-login: Login: user=<dimitris@techcity.dyndns.org>, method=PLAIN, rip=83.253.71.166, lip=192.168.0.180, mpid=27524, session=<uzfjyNXeRwBT/Uem>
Jun 11 02:14:46 techcity dovecot: pop3(dimitris@techcity.dyndns.org): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
Jun 11 02:14:47 techcity dovecot: pop3-login: Login: user=<dimitris@techcity.dyndns.org>, method=PLAIN, rip=83.253.71.166, lip=192.168.0.180, mpid=27526, session=<por3yNXeSwBT/Uem>
Jun 11 02:14:47 techcity dovecot: pop3(dimitris@techcity.dyndns.org): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
Jun 11 02:14:50 techcity postfix/anvil[27433]: statistics: max connection rate 2/60s for (smtp:80.76.146.172) at Jun 11 02:11:30
Jun 11 02:14:50 techcity postfix/anvil[27433]: statistics: max connection count 1 for (smtp:74.125.82.170) at Jun 11 02:10:27
Jun 11 02:14:50 techcity postfix/anvil[27433]: statistics: max message rate 2/60s for (smtp:80.76.146.172) at Jun 11 02:11:30
Jun 11 02:14:50 techcity postfix/anvil[27433]: statistics: max cache size 3 at Jun 11 02:11:24
Jun 11 02:15:00 techcity postfix/smtpd[27529]: warning: database /var/lib/mailman/data/virtual-mailman.db is older than source file /var/lib/mailman/data/virtual-mailman
Jun 11 02:15:00 techcity postfix/smtpd[27529]: connect from mail-wi0-f180.google.com[209.85.212.180]
Jun 11 02:15:00 techcity postfix/trivial-rewrite[27532]: warning: do not list domain techcity.dyndns.org in BOTH mydestination and virtual_mailbox_domains
Jun 11 02:15:00 techcity postfix/cleanup[27537]: warning: database /var/lib/mailman/data/virtual-mailman.db is older than source file /var/lib/mailman/data/virtual-mailman
Jun 11 02:15:00 techcity postfix/smtpd[27529]: D44202001D62: client=mail-wi0-f180.google.com[209.85.212.180]
Jun 11 02:15:00 techcity postfix/cleanup[27537]: D44202001D62: message-id=<CAJ6HFpQ1VX2zw_M5TBfudNW+QWkbHvNpTMJc7_-Eu-9P29XzPA@mail.gmail.com>
Jun 11 02:15:01 techcity postfix/qmgr[21645]: D44202001D62: from=<dkatsigiorgis@gmail.com>, size=2500, nrcpt=1 (queue active)
Jun 11 02:15:01 techcity postfix/smtpd[27529]: disconnect from mail-wi0-f180.google.com[209.85.212.180]
Jun 11 02:15:01 techcity postfix/smtpd[27529]: connect from localhost[::1]
Jun 11 02:15:01 techcity postfix/smtpd[27529]: lost connection after CONNECT from localhost[::1]
Jun 11 02:15:01 techcity postfix/smtpd[27529]: disconnect from localhost[::1]
Jun 11 02:15:01 techcity dovecot: imap-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=::1, lip=::1, secured, session=<5N3HydXe/gAAAAAAAAAAAAAAAAAAAAAB>
Jun 11 02:15:01 techcity dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=::1, lip=::1, secured, session=<597HydXewgAAAAAAAAAAAAAAAAAAAAAB>
Jun 11 02:15:03 techcity postfix/smtpd[27596]: warning: database /var/lib/mailman/data/virtual-mailman.db is older than source file /var/lib/mailman/data/virtual-mailman
Jun 11 02:15:03 techcity postfix/smtpd[27596]: connect from localhost[127.0.0.1]
Jun 11 02:15:03 techcity postfix/trivial-rewrite[27532]: warning: do not list domain techcity.dyndns.org in BOTH mydestination and virtual_mailbox_domains
Jun 11 02:15:03 techcity postfix/smtpd[27596]: 0801F2002B4F: client=localhost[127.0.0.1]
Jun 11 02:15:03 techcity postfix/cleanup[27537]: 0801F2002B4F: message-id=<CAJ6HFpQ1VX2zw_M5TBfudNW+QWkbHvNpTMJc7_-Eu-9P29XzPA@mail.gmail.com>
Jun 11 02:15:03 techcity postfix/qmgr[21645]: 0801F2002B4F: from=<dkatsigiorgis@gmail.com>, size=2980, nrcpt=1 (queue active)
Jun 11 02:15:03 techcity postfix/trivial-rewrite[27532]: warning: do not list domain techcity.dyndns.org in BOTH mydestination and virtual_mailbox_domains
Jun 11 02:15:03 techcity amavis[27515]: (27515-01) Passed CLEAN {RelayedInbound}, [209.85.212.180]:63221 [209.85.212.180] <dkatsigiorgis@gmail.com> -> <dimitris@techcity.dyndns.org>, Queue-ID: D44202001D62, Message-ID: <CAJ6HFpQ1VX2zw_M5TBfudNW+QWkbHvNpTMJc7_-Eu-9P29XzPA@mail.gmail.com>, mail_id: qI9Z9od367VB, Hits: -0.799, size: 2501, queued_as: 0801F2002B4F, 2061 ms
Jun 11 02:15:03 techcity postfix/smtp[27538]: D44202001D62: to=<dimitris@techcity.dyndns.org>, relay=127.0.0.1[127.0.0.1]:10024, delay=2.3, delays=0.21/0.01/0.01/2.1, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as 0801F2002B4F)
Any help would be much appreciated.

EDIT: I've solved the receiving emails part by removing my domain name from mydestinations inside postfix's main.cf. However I have some questions about sending emails that I will start a new thread for.

Last edited by m33ts4k0z; 12th June 2013 at 10:19.
Reply With Quote
Sponsored Links
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I can send emails, but not receive adobe Installation/Configuration 7 25th June 2010 20:22
PostFix can receive but can not send emails cjsdfw Server Operation 10 8th December 2009 08:11
I can receive emails but i cant send any... Makis77 Installation/Configuration 1 3rd July 2009 08:30
can receive emails but can't send terryoleary1981 Installation/Configuration 3 6th November 2008 21:32
Can send but not receive emails (Ubuntu 7.10) chillifire Installation/Configuration 7 15th December 2007 21:35


All times are GMT +2. The time now is 06:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.