#1  
Old 5th June 2013, 15:58
ifuXz ifuXz is offline
Junior Member
 
Join Date: May 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default Mail Problem

Hello,

i a problem with the mail server. When i send a mail to google mail all is fine. When i send a mail to another mail (on a other server from me) i see no mail in the inbox.

All mails on this mail-adress are hanging in the queue. What can be the problem?

In the log are no error only the message:
Jun 5 09:39:31 host postfix/qmgr[3558]: 01B9D3A63F0: from=<root@host>, size=1490, nrcpt=1 (queue active)
Reply With Quote
Sponsored Links
  #2  
Old 5th June 2013, 18:15
monkfish monkfish is offline
HowtoForge Supporter
 
Join Date: Mar 2013
Posts: 106
Thanks: 9
Thanked 15 Times in 14 Posts
Default

Hello ifuXz

Do you have access to the server you are trying to send mail to? If so, are there any entries in the mail log on that server?

Also, on the sending server, try a "postqueue -p".

This will list your messages that are queued and will probably give you any reason as to why its queued and not been processed.

HTH
Reply With Quote
The Following User Says Thank You to monkfish For This Useful Post:
alexeyttsy3922 (7th June 2013)
  #3  
Old 5th June 2013, 18:26
ifuXz ifuXz is offline
Junior Member
 
Join Date: May 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I monkfish,

i have access to both servers.

The error is: -Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
C98DD6E0605 62730 Sun Jun 2 22:44:07 xx@host.de
(connect to mail.xy.de[8x.xx.xx.xx]:25: No route to host)
bill@xy.de
Reply With Quote
  #4  
Old 5th June 2013, 18:35
monkfish monkfish is offline
HowtoForge Supporter
 
Join Date: Mar 2013
Posts: 106
Thanks: 9
Thanked 15 Times in 14 Posts
Default

Quote:
(connect to mail.xy.de[8x.xx.xx.xx]:25: No route to host)
Things to check;

- is a mail daemon running on the destination machine
- is it set to listen on the correct ip address and correct tcp port (do a "netstat -nlp" to check)
- if necessary restart the mail server on receiving machine - any errors in the log?
- is your networking config good (probably is, as you said you can send email to gmail)
- perhaps watch both mail logs (use "tail -f /var/log/maillog" or similar) and try a "postqueue -f" on the sending server to see if you can flush the queue. Look for any errors to show you why its not being delivered.

HTH

Last edited by monkfish; 5th June 2013 at 18:36. Reason: spelling
Reply With Quote
  #5  
Old 5th June 2013, 18:40
ifuXz ifuXz is offline
Junior Member
 
Join Date: May 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Things to check;

- is a mail daemon running on the destination machine

Yes
- is it set to listen on the correct ip address and correct tcp port

Yes

- if necessary restart the mail server on receiving machine - any errors in the log?
Error no only that the mail is in the queue

status=deferred (connect to mail.xx.de[8x.xx.xx.xx]:25: No route to host) - 1 example

- is your networking config good (probably is, as you said you can send email to gmail)

I think it is all right because a mail to gmail is send without problem


//Edit:
it can be the rdns/ptr dns record i think but this one is already set

Last edited by ifuXz; 5th June 2013 at 18:42.
Reply With Quote
  #6  
Old 6th June 2013, 15:55
ifuXz ifuXz is offline
Junior Member
 
Join Date: May 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

It was a bug in the switch configuration which blocks internal traffic
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sending email issue lezelf Installation/Configuration 15 9th August 2011 11:20
dovecot: lda: Fatal: Unknown user dpicella Installation/Configuration 1 22nd August 2010 02:59
ERROR: Connection dropped by IMAP server. [Centos 5.4, courier imap,squirrel, etc] darevil HOWTO-Related Questions 7 9th June 2010 14:49
Problem with dcc-client installation (Postfix) swap-as Installation/Configuration 9 18th September 2008 20:47
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 08:27


All times are GMT +2. The time now is 11:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.