#1  
Old 14th April 2008, 09:56
chasxmd chasxmd is offline
Junior Member
 
Join Date: Apr 2008
Posts: 10
Thanks: 2
Thanked 3 Times in 1 Post
Default Spam stats

Hello,

I've tried/am using Munin, AwStats, and MailGraph (which I highly recommend). I just can't seem to get the stat's I want. I want a graph or some kind of stats displaying how many valid e-mails vs. e-mail's tagged spam come through my server. Has anyone ran into something they really like or can recomment?

I recently installed ispconfig about a month ago and despite the long hours of trying to tweak it to my liking I'm very happy with it. I am running the latest stable on Fedora Core 8.

Thanks you,
Charles
Reply With Quote
Sponsored Links
  #2  
Old 15th April 2008, 03:06
chasxmd chasxmd is offline
Junior Member
 
Join Date: Apr 2008
Posts: 10
Thanks: 2
Thanked 3 Times in 1 Post
Default

Nevermind, I ran into this:
http://midnightcode.org/projects/spamstats/

I highly recommend it. Looks sharp and is fairly easy to install.
Reply With Quote
The Following 3 Users Say Thank You to chasxmd For This Useful Post:
bswinnerton (7th June 2008), falko (15th April 2008), leonz (8th May 2008)
  #3  
Old 9th May 2008, 09:15
mumbly mumbly is offline
Member
 
Join Date: Jun 2007
Posts: 69
Thanks: 4
Thanked 1 Time in 1 Post
Default Don't work ...

Hi !
Thanx for the trick ...
but it seems it does not work with Ubuntu 8.04 Hardy Heron ...
this is not the same paths ... and there is no /etc/mail/spamassassin/ repository ...

The database is filled correctly (as i can see spam field increasing) but there is no graph on the Reports/spam statistics page !
Moreover, the summury are empty :

The summary of analysis for today (since midnight local time);
A total volume of 0 email messages have been processed in the past 10 hours.
Of these, 0 messages (0.00%) have been rejected as spam.
The remaining 0 messages were processed and routed as mail.

... but i know there are more than 15 spam in the last few minutes ...

Any idea ?
THANX !

Last edited by mumbly; 9th May 2008 at 10:17.
Reply With Quote
  #4  
Old 10th May 2008, 16:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,711
Thanks: 1,900
Thanked 2,702 Times in 2,545 Posts
Default

Did you switch off Apparmor?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 10th May 2008, 17:20
mumbly mumbly is offline
Member
 
Join Date: Jun 2007
Posts: 69
Thanks: 4
Thanked 1 Time in 1 Post
Default

Yes !!!
Apparmor is switched off
I've redone /etc/init.d/apparmor stop to be sure ...
But the graphs and the stats are still empty
And that's what i have in MySQL :
day username domain spam ham
2008-05-09 web1_admins2ii 152 4
2008-05-09 web1_mumbly 68 1
2008-05-10 web1_admins2ii 79 0
2008-05-10 web1_mumbly 37 1
Reply With Quote
  #6  
Old 11th May 2008, 22:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,711
Thanks: 1,900
Thanked 2,702 Times in 2,545 Posts
Default

Any errors in your logs?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 6th June 2008, 17:34
mumbly mumbly is offline
Member
 
Join Date: Jun 2007
Posts: 69
Thanks: 4
Thanked 1 Time in 1 Post
Default

No errors in my logs ...
I've installed again spamstats on another server with Ubuntu 8.04 and this is the same result ...
Hard luck ...
PS : i must say that the .pkg file did not install the spam database correctly. I had to do it by hand ...
Reply With Quote
  #8  
Old 6th June 2008, 19:00
mumbly mumbly is offline
Member
 
Join Date: Jun 2007
Posts: 69
Thanks: 4
Thanked 1 Time in 1 Post
Default

IT WORKS !
In fact, the pkg file did not instal all the requested files : Stats.pm was not installed at all and local.cf was not updated with the spamstats SQL infos.
I have just read the readme file included in the pkg file and it was the clear for me !
Moreover, the readme file says that one must do some "changes" for the spamassassin "server" AND for the spamassassin ispconfig. as i have no spamassassin "server" following the perfect server setup, it has mistaken me for some times ...
But it's clearer now !
... and the mysql database was NOT installed at all ! I've done it by hand !
Do some other people had the same issue ???
Reply With Quote
  #9  
Old 9th June 2008, 13:42
MTvermoes MTvermoes is offline
Junior Member
 
Join Date: Dec 2007
Posts: 17
Thanks: 1
Thanked 10 Times in 5 Posts
 
Question

Problems after install (CentOS Perfect Setup):

Viewing report after install (Clicking 'Spam Statistics') :

MSIE : Stats is Reported OK, but the flash graphs just shows the loading anim.

Firefox : Left frame (where the 'Spam Statistics' Link is located) just turns blank.

Any Quick Fixes

/Mark
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Redirect Postfix Spam TimmBo Server Operation 6 5th March 2008 17:08
No Spam Headers after upgrading to Etch snowfly Server Operation 2 11th October 2007 00:13
In ISPconfig whitelist but still seen as spam edge Installation/Configuration 12 5th September 2007 00:30
How to kill spam when spamassassin marks it spam kpimichael Suggest HOWTO 15 6th August 2007 16:44
complete spam protection with postfix - howto alexnz Server Operation 1 22nd June 2006 14:06


All times are GMT +2. The time now is 07:57.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.