#1  
Old 30th May 2013, 04:40
SudoCat SudoCat is offline
Junior Member
 
Join Date: May 2013
Posts: 5
Thanks: 2
Thanked 0 Times in 0 Posts
Default Issues with multiple domains

I have recently got my web server set up, It's running Debian 7.0 x64 with the latest ISPConfig and nginx. I managed to get it all working with one domain, but when I attempted to add the clients domain, my own domain will now only show the content of the newest domain.

I am using digital ocean to manage the DNS settings, I understood what I read, I shouldn't have to set up DNS within ISPconfig if I manage it elsewhere (?)

I also have attempted to set up Wordpress on said server, but it's just giving me a Error 500, and all I've done is upload a blank Wordpress installation.

I have no real idea what I'm doing, so any suggestions would be helpful!
Reply With Quote
Sponsored Links
  #2  
Old 30th May 2013, 05:37
bch bch is offline
Junior Member
 
Join Date: Feb 2013
Posts: 12
Thanks: 1
Thanked 2 Times in 2 Posts
Default

Have you added any IP-addresses in 'System -> IP adresses' and if so, have you choosen one of those IP-addresses or '*' in your Web Domain settings for your domains?

When you're using an external DNS service for your domains, any DNS records for those domains in ISPConfig will not have any effect.

What's the output of /var/www/YourWordpressDomain/log/error.log ?
Reply With Quote
  #3  
Old 30th May 2013, 10:36
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,769
Thanks: 840
Thanked 5,609 Times in 4,420 Posts
Default

Quote:
I also have attempted to set up Wordpress on said server, but it's just giving me a Error 500, and all I've done is upload a blank Wordpress installation.
Maybe the file have the wrong owner if you uploaded them as root user. see error.log of the website for details.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 30th May 2013, 11:56
SudoCat SudoCat is offline
Junior Member
 
Join Date: May 2013
Posts: 5
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by bch View Post
Have you added any IP-addresses in 'System -> IP adresses' and if so, have you choosen one of those IP-addresses or '*' in your Web Domain settings for your domains?

When you're using an external DNS service for your domains, any DNS records for those domains in ISPConfig will not have any effect.

What's the output of /var/www/YourWordpressDomain/log/error.log ?
Currently, I have no IP addresses and am using *, I have also tried using the IP address to no avail.

Does it matter about using the external DNS settings, or is that part of the reason the domains are not correctly pointing to their own directories?

Quote:
Originally Posted by till View Post
Maybe the file have the wrong owner if you uploaded them as root user. see error.log of the website for details.
I uploaded them using an FTP user for the site in question.

And this is from the error.log

Code:
2013/05/30 08:36:02 [error] 5920#0: *168 FastCGI sent in stderr: "PHP message: PHP Warning:  file_exists(): open_basedir restriction in effect. File(/var/www/clients/client1/web3/wp-config.php) is not within the allowed path(s): (/var/www/clients/client1/web3/web:/var/www/clients/client1/web3/private:/var/www/clients/client1/web3/tmp:/var/www/420headshop.co.uk/web:/srv/www/420headshop.co.uk/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/usr/share/php) in /var/www/clients/client1/web3/web/wp-load.php on line 31" while reading response header from upstream, client: 94.12.234.163, server: 420headshop.co.uk, request: "GET / HTTP/1.1", upstream: "fastcgi://127.0.0.1:9012", host: "parahost.co.uk"
Reply With Quote
  #5  
Old 30th May 2013, 12:02
Ph1L Ph1L is offline
Junior Member
 
Join Date: Apr 2013
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The fix for me, to get a website working with multiple domain names, was to add more entries in the config file /etc/nginx/sites-enabled/sitename, under server_name
Reply With Quote
  #6  
Old 30th May 2013, 12:33
SudoCat SudoCat is offline
Junior Member
 
Join Date: May 2013
Posts: 5
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Ph1L View Post
The fix for me, to get a website working with multiple domain names, was to add more entries in the config file /etc/nginx/sites-enabled/sitename, under server_name
I'm guessing you mean to have one website with multiple domains? That's the opposite of the issue I have. I need multiple sites, multiple domains, but no matter what domain I go to on my server, it displays the directory associated with whatever domain was set up most recently.

for example:
If I go to: www.domain1.com > It shows the files for www.domain2.com
If I go to: www.domain2.com > It shows the files for www.domain2.com
Even if I go to the IP Address of the server, I see the files for www.domain2.com

I am baffled.
Reply With Quote
  #7  
Old 30th May 2013, 12:34
Ph1L Ph1L is offline
Junior Member
 
Join Date: Apr 2013
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

You have to setup a client for each domain
Reply With Quote
  #8  
Old 30th May 2013, 12:39
SudoCat SudoCat is offline
Junior Member
 
Join Date: May 2013
Posts: 5
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Ph1L View Post
You have to setup a client for each domain
Really? That doesn't sound right, surely a client should be able to have two websites of their own on separate domains.
And do I need to set up a client for the host site? As there is no client for that one.
Reply With Quote
  #9  
Old 30th May 2013, 13:06
SudoCat SudoCat is offline
Junior Member
 
Join Date: May 2013
Posts: 5
Thanks: 2
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by SudoCat View Post
Really? That doesn't sound right, surely a client should be able to have two websites of their own on separate domains.
And do I need to set up a client for the host site? As there is no client for that one.
Okay, I've got a bit closer to fixing it. I now have nginx vhosts correctly set up, it required me to change my nginx.conf to include:
Code:
server_names_hash_bucket_size: 64
I also had to change my vhosts file for the site from
Code:
       root   /var/www/420headshop.co.uk/web;

       index index.html index.htm index.php index.cgi index.pl index.xhtml;
to
Code:
        location / {
                root /var/www/420headshop.co.uk/web;
                index index.html index.htm index.php;
        }
Is this an issue with ISPconfig3 and nginx?
Reply With Quote
Reply

Bookmarks

Tags
dns, domains, error 500, ispconfig 3

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Having issues hosting multiple domains tonyreaper Installation/Configuration 3 5th October 2012 11:48
multiple site with sub domains issues jtullous Installation/Configuration 6 22nd June 2010 03:41
Centos 5.4 ispconfig 3 host multiple domains vuphan Server Operation 0 4th May 2010 20:15
Exim Gateway with mailwatch (Unable to receive emails) siul0_0 HOWTO-Related Questions 10 9th May 2009 00:00
ISPconfig to host multiple domains in one IP with multiple DynDns addresses agelospanagiotakis Installation/Configuration 23 2nd April 2008 12:10


All times are GMT +2. The time now is 03:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.