Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > ISPConfig 3 Priority Support

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 22nd May 2013, 15:09
JESUSSAVES JESUSSAVES is offline
Member
 
Join Date: Sep 2011
Location: U.S.
Posts: 76
Thanks: 10
Thanked 5 Times in 4 Posts
Default ISP not using 25 due to spam

Please could you inform me how to switch smtp to 587.

ISP (Comcast) told me due to spamming they are not using 25 any longer.

I'm not sure how to go about changing to 587.

ROUTER specification was simply SMTP without a port being specified, which routed to my server box. Not sure if default included 25 and 587, so I deactivated it and added a separate line for smtp routed to port 587 going to my server.

SERVER /etc/services has process called submission on 587 tcp and udp. Can you tell me how to change this? Eliminate the line for smtp 25, and rename 587 lines smtp? Or what should I do here?

I think isptables are OK.

Is there anything else that needs to change?

Thanks in advance for assistance with this.
Reply With Quote
Sponsored Links
  #12  
Old 22nd May 2013, 15:51
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,717
Thanks: 820
Thanked 5,322 Times in 4,175 Posts
Default

The problem is that you cant run a "real" mail server without port 25. The submission port 587 is a alternative port to send out emails if you have a mail server located in a datacenter.

I will describe you now how to activte the submission port in case it is not already active, but I fear it wont solve your problem as all external servers will ty to contact your server on port 25.

Take a look into the file /etc/postfix/master.cf, there you will find a line that starts with "submission" plus a few additional lines that are indented similar to this:

Code:
#submission inet n       -       -       -       -       smtpd
#  -o syslog_name=postfix/submission
#  -o smtpd_tls_security_level=encrypt
#  -o smtpd_sasl_auth_enable=yes
#  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
#  -o milter_macro_daemon_name=ORIGINATING
to activate the submission port, change it like this:

Code:
submission inet n       -       -       -       -       smtpd
  -o syslog_name=postfix/submission
  -o smtpd_tls_security_level=encrypt
  -o smtpd_sasl_auth_enable=yes
  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
#  -o milter_macro_daemon_name=ORIGINATING
In my opinion, you cant run a normal mailserver with port 25 closed. You should consider to rent a vps server in a datacenter and use that as mailserver or at least as mail relay which acepts and sends mail for your server on port 25 and forwards these emails on the submission port to your local server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #13  
Old 23rd May 2013, 14:44
JESUSSAVES JESUSSAVES is offline
Member
 
Join Date: Sep 2011
Location: U.S.
Posts: 76
Thanks: 10
Thanked 5 Times in 4 Posts
Default called ISP again

Till, thank your for your response again.

Upon reading your last message I checked the submission and it is already un-commented in roundcube.

I called my ISP again with more information and was told to use either 465 or 995. Could I use either of these? Will Roundcube work with 465, which is smpt ssl?

On the router I opened 995, 465, and 587, while "SMTP" and whatever assignments it is making is disabled.

I tried 995. I changed the /etc/services smtp 25 line to smtp 995 and rebooted the system.

Now I get a message when trying to login to roundcube, "Connection to storage server failed".

In the longer term I can change service providers, but in the short term hopefully I can come up with something. I think it could take weeks to change the IP address of my dns server records.

Apparently roundcube was using port 25? Could either roundcube or squirelmail be assigned another port? Is it easier to use 465 because it's already being used for mail over SSL? I do have a class2 certificate installed.
Reply With Quote
  #14  
Old 23rd May 2013, 16:51
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,717
Thanks: 820
Thanked 5,322 Times in 4,175 Posts
Default

Hi,

roundcube connects to the local server on port 25, this is ok and not related to your problem. Please undo the changes in /etc/services, this change will only break the setup and will not help.

The problem is that your server cant be reached from the internet caused by your isp is blocking port 25, it is not a problem of the local server setup or local mail delivery.

As long as port 25 is closed, you wont be able to receive any mails on your system that were sent to you over the internet.

What your isp suggested to you are settings for running a mail client, not server, with this ISP.

To enable your server to send emails again, you have to use a realy server. Most likely your ISP provides one for its customers if they disallow other methods to send email. You should ask them for the hostname and smtp login details of that relay server and enter them in ispconfig under System > Server config > mail (Relayhost, Relay user, relay password).

For the email receiving I'am not aware of a solution to circumvent the blocked port except of using a server which is located in the internet. Instead of moving the IP to a new ISP, you might be able to change the dns record of your domain name to a new server / virtual server with new ip which is reachable on port 25.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #15  
Old 31st May 2013, 00:14
JESUSSAVES JESUSSAVES is offline
Member
 
Join Date: Sep 2011
Location: U.S.
Posts: 76
Thanks: 10
Thanked 5 Times in 4 Posts
Default new IP service

Thank you again for your response.

Quote:
Instead of moving the IP to a new ISP, you might be able to change the dns record of your domain name to a new server / virtual server with new ip which is reachable on port 25.
Wasn't really sure how to point to a new virtual server so I went with a new ISP and got a new static IP address. The previous IP address was dynamic but it hadn't changed since I first got the service 2 years ago.

I figured I don't yet have all that many sites and I would just change them all manually.

OK, new ISP service up and running and I obviously can access the internet and I'm doing so thru my same old router. Didn't even need a modem, just ran the rs232 cable straight to the router and I was good to go.

But now ISPConfig won't respond @ server.example.tld:8080. Was it because I changed from dynamic to static IP and server network doesn't know?

Thank you once again for your assistance.
Reply With Quote
  #16  
Old 31st May 2013, 09:18
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,717
Thanks: 820
Thanked 5,322 Times in 4,175 Posts
Default

Please try to use the new ip address insstead of server.example.tld. So if the new ip is e.g. 1.2.3.4, then use:

http://1.2.3.4:8080 or https://1.2.3.4:8080 to connect to ispconfig.

If this works, then there is most likely a dns problem with server.example.tld subdomain.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #17  
Old 31st May 2013, 16:42
JESUSSAVES JESUSSAVES is offline
Member
 
Join Date: Sep 2011
Location: U.S.
Posts: 76
Thanks: 10
Thanked 5 Times in 4 Posts
Default got in with local address

Till, Thanks again for your response.

Couldn't get in with external IP address but switched to internal address and got in.

When I got in here's what I did:

Changes in ISPConfig: Service was dynamic and now is static. Changed Server Config IP address to new external address (was internal address), Netmask to specification ISP gave me, and Gateway was internal (192.168.0.1) and changed to external specification ISP gave me, Host Name remains the same, Nameservers were changed to new ones for new ISP.

Changed all my DNS records for all sites to new IP address as well as template.

(Also Changed Router Internet Setup from Auto Configuration DHCP to Static IP and entered all the specification given to me by ISP, same as the ones I entered in Server Config above. But my local network address server setting is still set DHCP Server enable)

RESULTS:

All native PHP HTML sites working fine.

PROBLEMS:
  • WordPress sites work but all take way too long to come up. It wasn't like this before I switched IP address. Do I need to reinstall these WordPress sites?
  • Mail is still not getting out of my system, but still works internally. My server can't send or receive mail to the outside.


New ISP assures me that port 25 isn't being blocked. But it was working and now it's not working. Does Debian automatically update itself and could it overlay something? What can be wrong?
Reply With Quote
  #18  
Old 31st May 2013, 17:15
JESUSSAVES JESUSSAVES is offline
Member
 
Join Date: Sep 2011
Location: U.S.
Posts: 76
Thanks: 10
Thanked 5 Times in 4 Posts
Default correction

Correction: I can send mail to my server and receive it in Roundcube from outside, just can't send out.

Checked Monitor and it says I'm out of space in root lv partition. Will correct that and see if it fixes mail problem.
Reply With Quote
  #19  
Old 31st May 2013, 18:59
JESUSSAVES JESUSSAVES is offline
Member
 
Join Date: Sep 2011
Location: U.S.
Posts: 76
Thanks: 10
Thanked 5 Times in 4 Posts
Default postfix startup message

Hi,

I extended the root partition and rebooted the server. Got this message
Code:
Starting Postfix Mail Transport agent: postfix.
Unexpected first line <localhost.localdomain: timed out, nothing received
Not sure if that's a problem.

Fixing the out of space error hasn't fixed the mail sending problem. Still can't send mail. Can only receive mail.
Reply With Quote
  #20  
Old 31st May 2013, 19:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,717
Thanks: 820
Thanked 5,322 Times in 4,175 Posts
 
Default

Check your mail log file, the reasons for your mail problems should be logged there.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPconfig 3.0.3.2 postfix not relaying outgoing attachments mychoice2009 Installation/Configuration 3 13th April 2011 17:42
ISPconfig 3 some users cannot send email to outside Rockblade Installation/Configuration 7 29th April 2010 01:40
Why did Squirrelmail, Dovecot/IMAP & Outbound mail break? websissy Technical 4 29th October 2009 22:39
Postfix + postfixadmin = SMTP errors... Rashef Server Operation 4 25th June 2009 16:12
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 17:39


All times are GMT +2. The time now is 00:18.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.