#1  
Old 14th May 2013, 01:19
rodti rodti is offline
Member
 
Join Date: Apr 2007
Posts: 58
Thanks: 6
Thanked 3 Times in 3 Posts
Default Mailman issues in 3.0.5.2

As I'd been having other problems (now resolved) I tried to run the update script with a fresh download of 3.0.5.2. Unfortunately Mailman is now misbehaving.

Initially Mailman threw up the following in mail.warn:

May 13 22:44:04 ***** postfix/cleanup[8114]: warning: database /var/
lib/mailman/data/virtual-mailman.db is older than source file /var/l
ib/mailman/data/virtual-mailman

I've fixed this with postmap /var/lib/mailman/data/virtual-aliases

Now I receive an error when trying to post to a list that shows in mail.log as:

May 13 23:12:58 ***** postfix/smtpd[14680]: NOQUEUE: reject: RCPT fr
om **.myisp.tld[**.**.**.**]: 550 5.1.1 <list@listdomain.tld>: Recipient address rejected: User
unknown in virtual mailbox table; from=<myemail@mydomain.tld> to=<list@listdomain.tld> proto=ESMTP helo=<[10.0.1.16]>

Searching on the forums I saw the 3.0.5.1 issue but my /etc/mailman/virtual_to_transport is correct.

Any ideas?
Reply With Quote
Sponsored Links
  #2  
Old 14th May 2013, 15:35
monkfish monkfish is offline
HowtoForge Supporter
 
Join Date: Mar 2013
Posts: 106
Thanks: 9
Thanked 15 Times in 14 Posts
Default

Have a look at /etc/postfix/main.cf, in particular transport maps.

Mine looks like this:-

/etc/postfix/main.cf
Code:
transport_maps = hash:/var/lib/mailman/data/transport-mailman, proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
but at one time when I broke it the entry for mailman disappeared out of that line. My fault, nowt to do with ispconfig.

If you had backups of previous config try a "diff" on various config files see if you can spot any difference between old and new.
Reply With Quote
  #3  
Old 14th May 2013, 17:48
rodti rodti is offline
Member
 
Join Date: Apr 2007
Posts: 58
Thanks: 6
Thanked 3 Times in 3 Posts
Default

Thanks Monkfish.

I've checked main.cf and the transport maps are as per your post.

The same error is persisting, will try and look through the old config files when I have time.
Reply With Quote
  #4  
Old 14th May 2013, 20:01
rodti rodti is offline
Member
 
Join Date: Apr 2007
Posts: 58
Thanks: 6
Thanked 3 Times in 3 Posts
Default

I've now run a diff between last good archived /etc/mailman and /etc/postfix configuration files and don't see any difference.
Reply With Quote
  #5  
Old 14th May 2013, 20:49
rodti rodti is offline
Member
 
Join Date: Apr 2007
Posts: 58
Thanks: 6
Thanked 3 Times in 3 Posts
 
Default

Hmm, not sure what I've done differently this time as I'd run genaliases and postmap already, but it looks like those in combination with newaliases plus another restart of mailman and postfix has cleared it.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
3.0.5.2 mailman problem compugraphix Installation/Configuration 16 11th August 2014 15:38
Mailman user unknown / User unknown in virtual mailbox table opensuse ralfba Installation/Configuration 1 27th May 2014 02:13
3.0.5.3.2 minor issues monkfish Installation/Configuration 6 13th May 2013 01:05
mailman failure deeeeeeeeeen Installation/Configuration 0 12th February 2013 15:39


All times are GMT +2. The time now is 22:12.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.