Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 12th May 2013, 18:13
cmsits cmsits is offline
Junior Member
 
Join Date: May 2013
Posts: 26
Thanks: 17
Thanked 0 Times in 0 Posts
Default

I'm quite new to this & the tutorial Bottom of page 4 says :
That's it. You can now try to connect using your FTP client; however, you should configure your FTP client to use TLS.
http://www.howtoforge.com/perfect-se...ispconfig-3-p4

this is well before ISPConfig Is Installed ???

I can connect using SFTP

But why is It not showing the details I added when doing this >

In order to use TLS, we must create an SSL certificate. I create it in /etc/ssl/private/, therefore I create that directory first:

mkdir -p /etc/ssl/private/

Afterwards, we can generate the SSL certificate as follows:

openssl req -x509 -nodes -days 7300 -newkey rsa:2048 -keyout /etc/ssl/private/pure-ftpd.pem -out /etc/ssl/private/pure-ftpd.pem

Country Name (2 letter code) [XX]: <-- Enter your Country Name (e.g., "DE").
State or Province Name (full name) []: <-- Enter your State or Province Name.
Locality Name (eg, city) [Default City]: <-- Enter your City.
Organization Name (eg, company) [Default Company Ltd]: <-- Enter your Organization Name (e.g., the name of your company).
Organizational Unit Name (eg, section) []: <-- Enter your Organizational Unit Name (e.g. "IT Department").
Common Name (eg, your name or your server's hostname) []: <-- Enter the Fully Qualified Domain Name of the system (e.g. "server1.example.com").
Email Address []: <-- Enter your Email Address.

Change the permissions of the SSL certificate:

chmod 600 /etc/ssl/private/pure-ftpd.pem
Reply With Quote
Sponsored Links
  #12  
Old 12th May 2013, 18:19
Hairy Hairy is offline
HowtoForge Supporter
 
Join Date: Mar 2013
Location: USA
Posts: 57
Thanks: 6
Thanked 27 Times in 16 Posts
Default

Quote:
Originally Posted by cmsits View Post
I'm quite new to this & the tutorial Bottom of page 4 says :
That's it. You can now try to connect using your FTP client; however, you should configure your FTP client to use TLS.
http://www.howtoforge.com/perfect-se...ispconfig-3-p4

this is well before ISPConfig Is Installed ???

I can connect using SFTP

But why is It not showing the details I added when doing this >

In order to use TLS, we must create an SSL certificate. I create it in /etc/ssl/private/, therefore I create that directory first:

mkdir -p /etc/ssl/private/

Afterwards, we can generate the SSL certificate as follows:

openssl req -x509 -nodes -days 7300 -newkey rsa:2048 -keyout /etc/ssl/private/pure-ftpd.pem -out /etc/ssl/private/pure-ftpd.pem

Country Name (2 letter code) [XX]: <-- Enter your Country Name (e.g., "DE").
State or Province Name (full name) []: <-- Enter your State or Province Name.
Locality Name (eg, city) [Default City]: <-- Enter your City.
Organization Name (eg, company) [Default Company Ltd]: <-- Enter your Organization Name (e.g., the name of your company).
Organizational Unit Name (eg, section) []: <-- Enter your Organizational Unit Name (e.g. "IT Department").
Common Name (eg, your name or your server's hostname) []: <-- Enter the Fully Qualified Domain Name of the system (e.g. "server1.example.com").
Email Address []: <-- Enter your Email Address.

Change the permissions of the SSL certificate:

chmod 600 /etc/ssl/private/pure-ftpd.pem
That certificate will never be used.
AND
It cannot be done before ISPConfig is installed as you stated.

Please look here

http://www.howtoforge.com/forums/showthread.php?t=61799
Reply With Quote
The Following User Says Thank You to Hairy For This Useful Post:
cmsits (13th May 2013)
  #13  
Old 12th May 2013, 18:36
Hairy Hairy is offline
HowtoForge Supporter
 
Join Date: Mar 2013
Location: USA
Posts: 57
Thanks: 6
Thanked 27 Times in 16 Posts
Default

You could move the certificate you created using:
Code:
mv /etc/ssl/private/pure-ftpd.pem /etc/pki/pure-ftpd/pure-ftpd.pem
chmod 600 pure-ftpd.pem
OR

You could create a symbolic link to the certificate you created using:
Code:
ln -s /etc/ssl/private/pure-ftpd.pem /etc/pki/pure-ftpd/pure-ftpd.pem
Reply With Quote
The Following User Says Thank You to Hairy For This Useful Post:
cmsits (13th May 2013)
  #14  
Old 12th May 2013, 19:45
cmsits cmsits is offline
Junior Member
 
Join Date: May 2013
Posts: 26
Thanks: 17
Thanked 0 Times in 0 Posts
Default

I removed the #
from TLS
and saved restarted proftpd & still can't connect with filezilla ftp

I've created website & created ftp user for that website and added the firewall record for the server all in ISPconfig 3 cp

What have I missed ?
Reply With Quote
  #15  
Old 12th May 2013, 19:47
cmsits cmsits is offline
Junior Member
 
Join Date: May 2013
Posts: 26
Thanks: 17
Thanked 0 Times in 0 Posts
Default

Connecting to 192.168.1.121:21...
Status: Connection established, waiting for welcome message...
Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response: 220-You are user number 1 of 50 allowed.
Response: 220-Local time is now 18:43. Server port: 21.
Response: 220-This is a private system - No anonymous login
Response: 220-IPv6 connections are also welcome on this server.
Response: 220 You will be disconnected after 15 minutes of inactivity.
Command: USER cmsits
Response: 331 User cmsits OK. Password required
Command: PASS **********
Response: 530 Login authentication failed
Error: Critical error
Error: Could not connect to server
Reply With Quote
  #16  
Old 12th May 2013, 19:49
cmsits cmsits is offline
Junior Member
 
Join Date: May 2013
Posts: 26
Thanks: 17
Thanked 0 Times in 0 Posts
Default

Connecting to 192.168.1.121:21...
Status: Connection established, waiting for welcome message...
Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response: 220-You are user number 1 of 50 allowed.
Response: 220-Local time is now 18:45. Server port: 21.
Response: 220-This is a private system - No anonymous login
Response: 220-IPv6 connections are also welcome on this server.
Response: 220 You will be disconnected after 15 minutes of inactivity.
Command: AUTH TLS
Response: 234 AUTH TLS OK.
Status: Initializing TLS...
Status: Verifying certificate...
Command: USER cmsits
Status: TLS/SSL connection established.
Response: 331 User cmsits OK. Password required
Command: PASS **********
Response: 530 Login authentication failed
Error: Critical error
Error: Could not connect to server
Reply With Quote
  #17  
Old 12th May 2013, 19:52
cmsits cmsits is offline
Junior Member
 
Join Date: May 2013
Posts: 26
Thanks: 17
Thanked 0 Times in 0 Posts
Default

Seems everything goes through ok but refuses password ?
Reply With Quote
  #18  
Old 12th May 2013, 20:02
Hairy Hairy is offline
HowtoForge Supporter
 
Join Date: Mar 2013
Location: USA
Posts: 57
Thanks: 6
Thanked 27 Times in 16 Posts
Default

Quote:
Originally Posted by cmsits View Post
I removed the #
from TLS
and saved restarted proftpd & still can't connect with filezilla ftp
I don't know about proftpd. I am using and referring to pure-ftpd. I also use FileZilla to connect.

Quote:
I've created website & created ftp user for that website and added the firewall record for the server all in ISPconfig 3 cp

What have I missed ?
You shouldn't need to add a firewall record, unless perhaps you've setup an alternate port somewhere, or you've created your own firewall rule that blocks the default port.

Quote:
Seems everything goes through ok but refuses password ?
I don't know. Sorry Maybe, check that the username and passwords you are using are actually correct? .. Just a suggestion.
Reply With Quote
The Following User Says Thank You to Hairy For This Useful Post:
cmsits (13th May 2013)
  #19  
Old 13th May 2013, 09:36
cmsits cmsits is offline
Junior Member
 
Join Date: May 2013
Posts: 26
Thanks: 17
Thanked 0 Times in 0 Posts
Default

Sorry I meant PureFTPd

I added the default firewall record for server. (thought I had to, but removed now)

Its puzzelling me. can't seem to get ftp to work atall.
even on virtual machines I've set up on laptop
checked and re-checked usernames and passwords
Reply With Quote
  #20  
Old 13th May 2013, 10:04
cmsits cmsits is offline
Junior Member
 
Join Date: May 2013
Posts: 26
Thanks: 17
Thanked 0 Times in 0 Posts
 
Default

May 13 08:55:43 centos1 pure-ftpd: (?@192.168.1.100) [INFO] New connection from 192.168.1.100
May 13 08:55:43 centos1 pure-ftpd: (?@192.168.1.100) [INFO] SSL/TLS: Enabled TLSv1/SSLv3 with AES256-SHA, 256 secret bits cipher
May 13 08:55:48 centos1 pure-ftpd: (?@192.168.1.100) [WARNING] Authentication failed for user [cmsits]
May 13 08:55:48 centos1 pure-ftpd: (?@192.168.1.100) [INFO] Logout.
May 13 09:00:01 centos1 pure-ftpd: (?@::1) [INFO] New connection from ::1
May 13 09:00:01 centos1 pure-ftpd: (?@::1) [INFO] Logout.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't get site FTP accounts to work DennyCrane Installation/Configuration 1 28th February 2009 15:07
Troubleshooting FTP bswinnerton Installation/Configuration 4 10th October 2008 19:34
Problems with ftp disconnections! Allmight Server Operation 12 17th April 2008 19:54
Newbie Questions Abound...FTP...Firewall....???? xelf Installation/Configuration 3 23rd August 2007 19:40
Using FTP latcarf Server Operation 29 27th September 2005 02:57


All times are GMT +2. The time now is 13:25.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.