Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th September 2013, 23:58
Nebhead Nebhead is offline
Junior Member
 
Join Date: Oct 2011
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default Updating SMTP server to use SSL/TLS

Hi all,

I've been running ISPConfig 3 on Ubuntu 10.04 for almost 2 years without any problems. However, in all that time, I've only ever received email though it; I've never needed to send mail.

That changed today, and it took me a long time to figure out that somehow my SMTP server (I think I'm using courier) is set up without SSL/TLS on port 25, so my authentication details are sent plain text.

I'm not a server admin (hence why I use ISP Config in the first place), so if someone could give me pointers as to how I go about switching on encryption, that would be awesome. I've done some typical google/forum searches, but nothing comes up which seems to meet my needs.

Any help is appreciated!

Thanks,
Ben
Reply With Quote
Sponsored Links
  #2  
Old 12th September 2013, 09:29
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
 
Default

Th smtp server that you use is postfix, courier is the imap and pop3 server. To enable smtps in postfix, edit the file /etc/postfix/master.cf and remove the # in front of the line that starts with smtps and the 3 next lines after that line. Then restart postfix.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What can be wrong martin_rudowicz Installation/Configuration 10 1st December 2014 10:13
500 internal error after upgrade abintipl Installation/Configuration 9 18th July 2012 13:51
ISPConfig 3 Installation - Postfix queue stuck andrew971218 Installation/Configuration 21 15th July 2011 15:42
subdomain and mail relay configuration aranthorn Installation/Configuration 24 3rd September 2007 23:53
Problems with Postfix Mysql Courier PatrickAdrichem Installation/Configuration 3 13th April 2007 16:44


All times are GMT +2. The time now is 09:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.