Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 18th May 2012, 10:10
Jorem Jorem is offline
Senior Member
 
Join Date: Oct 2005
Posts: 139
Thanks: 5
Thanked 4 Times in 4 Posts
Default phpmyadmin 500 error, just on one server

I have a Ubuntu 10.04 server and a new Ubuntu 12.04 server. On both the servers the phpmyadmin files are the same. But on the 12.04 server I get a 500 server error.

I read multiple posts about the problem and followed the tips there. But still do not get it to work. Not on :8080/phpmyadmin or domain.tld/phpmyadmin

My apache2 logfile does not show a error. Only the init set error, but that is just a warning.

Is there a way to let phpmyadmin log the error's, or is this a apache problem?

On the server I have ossec-hids, apc, memcache, mod_deflate and mod_security installed. Removed theme all, restarted the server, but still not working. Same software is also installed on the 10.04 server, and there phpmyadmin is working.

Where else can I look to find the error?

Thanks for your help.
Reply With Quote
Sponsored Links
  #2  
Old 18th May 2012, 14:33
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,213 Times in 4,088 Posts
Default

Please post the content of the apache phpmyadmin.conf file of that server, it should be in /etc/apache2/conf/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 21st May 2012, 11:25
Jorem Jorem is offline
Senior Member
 
Join Date: Oct 2005
Posts: 139
Thanks: 5
Thanked 4 Times in 4 Posts
Default

In /etc/apache2/conf.d/ i have a symlink file phpmyadmin.conf to /etc/phpmyadmin/apache.conf
I do not have a /etc/apache2/conf directory.

Content of the apache.conf file:

# phpMyAdmin default Apache configuration
Alias /phpmyadmin /usr/share/phpmyadmin

<Directory /usr/share/phpmyadmin>
Options FollowSymLinks
DirectoryIndex index.php

<IfModule mod_php5.c>
AddType application/x-httpd-php .php

php_flag magic_quotes_gpc Off
php_flag track_vars On
php_flag register_globals Off
php_admin_flag allow_url_fopen Off
php_value include_path .
php_admin_value upload_tmp_dir /var/lib/phpmyadmin/tmp
php_admin_value open_basedir /usr/share/phpmyadmin/:/etc/phpmyadmin/:/var/lib/phpmyadmin/
</IfModule>

</Directory>

# Authorize for setup
<Directory /usr/share/phpmyadmin/setup>
<IfModule mod_authn_file.c>
AuthType Basic
AuthName "phpMyAdmin Setup"
AuthUserFile /etc/phpmyadmin/htpasswd.setup
</IfModule>
Require valid-user
</Directory>

# Disallow web access to directories that don't need it
<Directory /usr/share/phpmyadmin/libraries>
Order Deny,Allow
Deny from All
</Directory>
<Directory /usr/share/phpmyadmin/setup/lib>
Order Deny,Allow
Deny from All
</Directory>

Last edited by Jorem; 21st May 2012 at 11:27.
Reply With Quote
  #4  
Old 21st May 2012, 11:33
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,213 Times in 4,088 Posts
Default

Thst ok,it should use mod_php for the phpmyadmin folder. I had a similar issue some time ago related to one of the php_flag and php_admin settings. Please try to comment out the lines starting with php_flag and php_value in the phpmyadmin.conf file and restart apache.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 21st May 2012, 12:54
Jorem Jorem is offline
Senior Member
 
Join Date: Oct 2005
Posts: 139
Thanks: 5
Thanked 4 Times in 4 Posts
Default

<IfModule mod_php5.c>
AddType application/x-httpd-php .php
#php_flag magic_quotes_gpc Off
#php_flag track_vars On
#php_flag register_globals Off
php_admin_flag allow_url_fopen Off
#php_value include_path .
php_admin_value upload_tmp_dir /var/lib/phpmyadmin/tmp
php_admin_value open_basedir /usr/share/phpmyadmin/:/etc/phpmyadmin/:/var/lib/phpmyadmin/
</IfModule>

Still a 500 error and nothing in the apache log file.

I just thought about webmail that also uses a alias and tried that. /webmail is working good.
So is it really a problem with apache (and alias), or is there something wrong with the phpmyadmin files in /usr/share/phpmyadmin then?
Reply With Quote
  #6  
Old 21st May 2012, 14:21
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,213 Times in 4,088 Posts
Default

You missed the lines:

php_admin_flag allow_url_fopen Off
php_admin_value upload_tmp_dir /var/lib/phpmyadmin/tmp
php_admin_value open_basedir /usr/share/phpmyadmin/:/etc/phpmyadmin/:/var/lib/phpmyadmin/

Please comment them out too and restart apache.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 21st May 2012, 14:39
Jorem Jorem is offline
Senior Member
 
Join Date: Oct 2005
Posts: 139
Thanks: 5
Thanked 4 Times in 4 Posts
Default

Still 500 error after restart apache.

Checked the open-basedir setting in ISPConfig but that looks ok too:
/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin

Tried with the ip adress again. But also the 500 server error.

What i did next was I put a index.html in the /usr/share/phpmyadmin folder with some dummy text in it.
When I go to the url http://myip/phpmyadmin/index.html the page with dummy text is shown.

Alias works, but the index.php gives the error I think. How can I check what is going wrong?
Reply With Quote
  #8  
Old 22nd May 2012, 14:57
Jorem Jorem is offline
Senior Member
 
Join Date: Oct 2005
Posts: 139
Thanks: 5
Thanked 4 Times in 4 Posts
Default

My phpmyadmin is working now .

I made a copy of the phpmyadmin folder on my Ubuntu 10.04 server, extracted it on the Ubuntu 12.04 server and it works great now.
Reply With Quote
  #9  
Old 24th May 2012, 12:36
Taken Taken is offline
Junior Member
 
Join Date: May 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Same problem here, Ubuntu Server 11.04, apache+php OK, but phpmyadmin error 500 . Any new idea?

Thanks!
Reply With Quote
  #10  
Old 25th May 2012, 07:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
 
Default

Quote:
Originally Posted by Taken View Post
Same problem here, Ubuntu Server 11.04, apache+php OK, but phpmyadmin error 500 . Any new idea?

Thanks!
What's the content of /etc/apache2/conf.d/phpmyadmin.conf?
Any errors in your Apache logs?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Local mail server - final touch Alexhor Installation/Configuration 4 12th April 2012 22:33
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
ISPConfig3 mail doesn't work Marr General 6 1st September 2010 09:32
Sending mail ISPConfig 3 but not receivind catza Installation/Configuration 20 19th May 2010 12:47
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 16:59


All times are GMT +2. The time now is 20:14.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.