Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th May 2013, 20:06
JohnnyBeGood JohnnyBeGood is offline
HowtoForge Supporter
 
Join Date: Mar 2008
Posts: 40
Thanks: 8
Thanked 4 Times in 4 Posts
Default How to get FXP pure-ftpd ispconfig3 debian to work?

Hi all,

I know there's a similar post but my issue is different.

I'm changing hosts and I need to move all files from one remote server to the other.
I've disabled firewall in ISPconfig added port range and enabled echo "yes" > /etc/pure-ftpd/conf/AllowUserFXP
even added 40110:40210 to the firewall control panel.
Still can't transfer files.
Tried both FlashFXP and Smart FTP client, no joy.
Here's FlashFXP log:

Code:
[R] Connecting to myserver.com -> DNS=myserver.com IP=xxx.x.xxx.xxx PORT=21
[R] Connected to myserver.com
[R] 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
[R] 220-You are user number 1 of 50 allowed.
[R] 220-Local time is now 13:47. Server port: 21.
[R] 220-This is a private system - No anonymous login
[R] 220-IPv6 connections are also welcome on this server.
[R] 220 You will be disconnected after 15 minutes of inactivity.
[R] USER user_username
[R] 331 User user_username OK. Password required
[R] PASS (hidden)
[R] 230-User user_username has group access to:  client1    sshusers  
[R] 230-This server supports FXP transfers
[R] 230 OK. Current restricted directory is /
[R] SYST
[R] 215 UNIX Type: L8
[R] FEAT
[R] 211-Extensions supported:
[R]  EPRT
[R]  IDLE
[R]  MDTM
[R]  SIZE
[R]  REST STREAM
[R]  MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
[R]  MLSD
[R]  AUTH TLS
[R]  PBSZ
[R]  PROT
[R]  UTF8
[R]  ESTA
[R]  PASV
[R]  EPSV
[R]  SPSV
[R]  ESTP
[R] 211 End.
[R] OPTS UTF8 ON
[R] 200 OK, UTF-8 enabled
[R] PWD
[R] 257 "/" is your current location
[R] CWD /
[R] 250 OK. Current directory is /
[R] PWD
[R] 257 "/" is your current location
[R] CWD Pictures
[R] 250 OK. Current directory is /Pictures
[R] PWD
[R] 257 "/Pictures" is your current location
[R] PASV
[R] 227 Entering Passive Mode (xxx,4x,xxx,xxx,156,195)
[R] Opening data connection IP: xxx.x.xxx.xxx PORT: 40131
[R] MLSD
[R] 150 Accepted data connection
[R] 226-Options: -a -l 
[R] 226 8 matches total
[R] List Complete: 895 bytes in 0.33 second (0.9 KB/s)
[R] TYPE I
[R] 200 TYPE is now 8-bit binary
[R] MLST com.miui.lock-1.apk
[R] 550 Can't check for file existence
[L] TYPE I
[L] 200 TYPE is now 8-bit binary
[L] PASV
[L] 227 Entering Passive Mode (xx,xx,xxx,xx,156,192)
[R] PORT xx,xx,xxx,xx,156,192
[R] 200 PORT command successful
[R] STOR com.miui.lock-1.apk
[R] Transfer Failed: com.miui.lock-1.apk
[R] Connection lost: myserver.com (Duration: 1 minute 29 seconds / Idle: 1 minute 0 second)
[L] PASV
Transferred 0 Files (0 bytes) in 1 minute 0 second (0.0 KB/s)
1 File Failed
[L] 227 Entering Passive Mode (xx,xx,xxx,xx,156,177)
[L] Opening data connection IP: xx.xx.xxx.xx PORT: 40113
[L] MLSD
[L] 150 Accepted data connection
[L] 226-Options: -a -l 
[L] 226 54 matches total
[L] List Complete: 6 KB in 0.29 second (7.0 KB/s)
Transfer queue completed
Transferred 0 Files (0 bytes) in 1 minute 0 second (0.0 KB/s)
1 File Failed
Reply With Quote
Sponsored Links
  #2  
Old 11th May 2013, 20:25
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,034
Thanks: 265
Thanked 151 Times in 131 Posts
Default

Did you try both passive mode en active mode in your FTP client?
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
  #3  
Old 12th May 2013, 02:27
JohnnyBeGood JohnnyBeGood is offline
HowtoForge Supporter
 
Join Date: Mar 2008
Posts: 40
Thanks: 8
Thanked 4 Times in 4 Posts
 
Default

Quote:
Originally Posted by edge View Post
Did you try both passive mode en active mode in your FTP client?
Thanks for the reply!

I've tried both passive and active in trial version of FlashFXP. Still the same error.
I'm willing to try any program or setting that is known to work.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Perfect Server Debian, ISPConfig3 cant connect after applying firewall Gigaquad Installation/Configuration 9 9th March 2012 15:55
Please help me whit bind9 astra2000 Server Operation 12 10th October 2007 02:43
Bind Failed christoph2k HOWTO-Related Questions 4 28th April 2007 00:57
chroot in debian doesnt work. 3molo HOWTO-Related Questions 2 20th October 2006 11:32
e-mail problem!!! Debian 3.1 maroonworks Installation/Configuration 18 6th December 2005 14:42


All times are GMT +2. The time now is 16:14.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.