Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 18th July 2006, 00:07
StupidScript StupidScript is offline
Junior Member
 
Join Date: Jul 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default Intrusion Detection With BASE And Snort

Thanks for the tutorial ...

Here's (perhaps) a little help with a potential problem with Step 1 of 5 of the BASE setup program where it cannot verify the Path to ADODB.

Error: "The Path to ADODB does not appear to be correct!"

Following the instructions in the tutorial to the letter, you have an "adodb" directory in /var/www/. Setting "Path to ADODB" in Step 1 of the web-based BASE setup to "/var/www/adodb" returns the error above.

Solution, for me: chown -R apache:apache /var/www/adodb

It was owned by root, before I did that, however the PHP file in BASE's setup routine (setup1.php) requires the ability to check for a particular adodb.inc file in order to validate that location.

As I had php.ini set up to use open_basedir, I needed to add that directory to my /etc/php.ini's open_basedir list of allowed directories and give Apache permission to read it before the setup file worked correctly. (I has previously needed to add the /var/www/html/base-1.2.5 directory to the list and chown it to apache:apache, as well.)

<edit>
I also used the tutorial to make a second installation on another system, and I needed to chmod 755 /var/www/adodb and all of its subdirectories.

Incidentally, I'm running Fedora Core 4 on both systems, however there are some differences between the two.
</edit>

Hope that helps someone ...

Last edited by StupidScript; 18th July 2006 at 01:12.
Reply With Quote
Sponsored Links
  #2  
Old 18th July 2006, 09:55
sjau sjau is offline
Local Meanie
 
Join Date: Apr 2006
Location: Switzerland
Posts: 1,158
Thanks: 4
Thanked 58 Times in 54 Posts
Default

Do the global and local values for allowed directories differ? Maybe that is the problem.
Reply With Quote
  #3  
Old 18th July 2006, 12:00
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,044
Thanks: 269
Thanked 154 Times in 133 Posts
Default

Hmm.. It's me .. the one who made the howto,

I've had a look at some Debian Sarge systems here, and they all have "/var/www/adodb" owned by root:root and set to 755

Could it be a Debian thingy? Also.. It's using Apache2 (not sure if this has anything todo with it)
Reply With Quote
  #4  
Old 19th July 2006, 00:27
StupidScript StupidScript is offline
Junior Member
 
Join Date: Jul 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks a lot for the tutorial, edge. Worked great! Here are my notes about the above stuff.

Running on two servers: Fedora Core 4, Apache 2, PHP 5.x

Both php.ini's using: safe_mode = On , open_basedir = ..allowed dirs..

Both running Bastille (server hardening) HOWEVER the Bastille configurations are a little bit different because one server is sensitive and the other is used for testing things, occasionally, so it's not quite as 'tight' as the other system.

I think the differences in the Bastille setup may account for the owner/permissions differences as noted.

To clarify what I did to get everything working:

1) chown adodb and all children to the user who owns the web server
2) Change permissions on adodb directory and its subdirectories as req.
3) IF using open_basedir: add directories as needed and restart web server

Other than those small tweaks, everything went exactly as you noted in the tutorial, edge. Thanks a lot!

Last edited by StupidScript; 19th July 2006 at 01:00.
Reply With Quote
  #5  
Old 19th July 2006, 01:01
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,044
Thanks: 269
Thanked 154 Times in 133 Posts
Default

I'm (as you might have seen on the way of the howto) new to linux and the howto's :-)

Anyway.. I'll give your things a go tomorrow or the day after on a new (virtual) Debian install, and if all okay I'll add / change it in the howto.
I'm not sure if I will use your nick in it for the thanks to.. (StupidScript)
Reply With Quote
  #6  
Old 11th August 2006, 22:22
wr19026 wr19026 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 172
Thanks: 7
Thanked 1 Time in 1 Post
Default

I'm havibg problems with the following:

./configure --enable-dynamicplugin --with-mysql
make
make install

when I run it it gives the following error:

checking for mysql...

**********************************************
ERROR: unable to find mysql headers (mysql.h)
checked in the following places
/usr/include
/usr/include/mysql
/usr/local/include
/usr/local/include/mysql
**********************************************

root@bla:~/snorttemp/snort-2.6.0# whereis mysql.h
mysql: /usr/bin/mysql /etc/mysql /usr/bin/X11/mysql /usr/share/mysql /usr/share/man/man1/mysql.1.gz

Environment: Ubuntu 6.06 LTS server set up as per the Perfect Setup; also running ISPConfig.

Help and suggestions are much appreciated!
Reply With Quote
  #7  
Old 12th August 2006, 19:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Quote:
Originally Posted by wr19026
**********************************************
ERROR: unable to find mysql headers (mysql.h)
Please run
Code:
apt-get install libmysqlclient12-dev
and try again.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 12th August 2006, 21:02
wr19026 wr19026 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 172
Thanks: 7
Thanked 1 Time in 1 Post
 
Default

I'm getting an error message (in Dutch so I don't think it'll help much ). I'll figure out how to get this installed and try again. Thanks for the tip anyway!

EDIT: As per one of the comments for the Perfect Setup for Ubuntu 6.06 I installed libmysqlclient15-dev which solves the problem.

Last edited by wr19026; 12th August 2006 at 23:47.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SNORT and BASE on a CLEAN "The Perfect Setup - Debian Sarge (3.1)" edge Suggest HOWTO 5 10th September 2006 01:07
req: Snort + BASE setup for Debian edge Suggest HOWTO 3 18th June 2006 21:09


All times are GMT +2. The time now is 19:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.