#1  
Old 10th May 2013, 13:27
martin1977 martin1977 is offline
Junior Member
 
Join Date: May 2009
Posts: 20
Thanks: 0
Thanked 3 Times in 3 Posts
Default mail services got stirred up

I use ISPconfig 3.0.5.2 on Debian 7.0 and Mysql 5.5.30+dfsg-1.1, postfix 2.9.6-2, courier 0.68.2-1 . Since yesterday incoming mails are rejected and I cannot send emails because I get an authentication error. I can however login to imap mailboxes.

Logs:
Trying to send a mail in auth.log
Code:
May 10 12:54:02 BLANKED postfix/smtpd[8448]: sql plugin could not connect to host 127.0.0.1
May 10 12:54:02 BLANKED postfix/smtpd[8448]: sql plugin couldn't connect to any host
May 10 12:55:01 BLANKED mysqld[5718]: refused connect from 127.0.0.1
An incomming mail event in mail.log
Code:
May 10 13:08:29 BLANKED postfix/smtpd[8725]: connect from smtpout.howtoforge.com[78.47.44.38]
May 10 13:08:29 BLANKED postfix/trivial-rewrite[8813]: warning: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf: table lookup problem
May 10 13:08:29 BLANKED postfix/trivial-rewrite[8813]: warning: virtual_mailbox_domains lookup failure
May 10 13:08:29 BLANKED postfix/smtpd[8725]: warning: mysql:/etc/postfix/mysql-virtual_client.cf: table lookup problem
May 10 13:08:29 BLANKED postfix/smtpd[8725]: NOQUEUE: reject: RCPT from smtpout.howtoforge.com[78.47.44.38]: 451 4.3.5 <smtpout.howtoforge.com[78.47.44.38]>: Client host rejected: Server configuration error; from=<www-data@http4.howtoforge.com> to=<BLANKED> proto=ESMTP helo=<smtpout.howtoforge.com>
May 10 13:08:29 BLANKED postfix/smtpd[8725]: disconnect from smtpout.howtoforge.com[78.47.44.38]
Weird thing: When I try to login with
Code:
mysql -u *user* -p
and use the credentials stored in the *.cf files of the postfix configuration, I can login, change to the specified database and place a query.
Any help is appreciated.

P.S.: I already set max_connections and max_user_connections to 500 in the mysql config.
Reply With Quote
Sponsored Links
  #2  
Old 10th May 2013, 17:06
martin1977 martin1977 is offline
Junior Member
 
Join Date: May 2009
Posts: 20
Thanks: 0
Thanked 3 Times in 3 Posts
Default

solved it.
Reply With Quote
  #3  
Old 10th May 2013, 19:16
commentator commentator is offline
Senior Member
 
Join Date: Jul 2008
Location: The Netherlands
Posts: 146
Thanks: 49
Thanked 7 Times in 5 Posts
Default

Quote:
Originally Posted by martin1977 View Post
solved it.
good to see it's fixed. Would be nice if you post the solution here so if someone else has the same problem he/she can fix it too
Reply With Quote
  #4  
Old 10th May 2013, 22:22
martin1977 martin1977 is offline
Junior Member
 
Join Date: May 2009
Posts: 20
Thanks: 0
Thanked 3 Times in 3 Posts
 
Default

you're right. I was a bit upset nobody would respond to my requests - I had one or two more questions in separate threads.
Anyway, in this case localhost got blacklisted by denyhost in /etc/hosts.deny - funny, isn't it?
I added 127.0.0.1 to /etc/hosts.allow - that solved it but I still have not figured how that happened.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
mail recipient linux_red Installation/Configuration 6 9th March 2012 14:24
Sendig mail Error fisherofer Installation/Configuration 12 30th November 2011 07:56
Postfix/courier/Centos 6 cant send email to external email servers maxtorzito Installation/Configuration 14 7th October 2011 10:56
Postfix reject connections gabrix Server Operation 27 25th January 2007 08:37
Can not recieve mail with de virtual mail adress Mounir Installation/Configuration 9 24th July 2006 23:16


All times are GMT +2. The time now is 15:01.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.