Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th May 2013, 19:32
chessman2212 chessman2212 is offline
Junior Member
 
Join Date: May 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Several domains (sites) on the same directory.

Hello,

I need to get 2 websites using the same directory and DB but having their proper URL

The objective is I get a .com website for the international version and a .fr one with the French content

How can I configure the sites to use the same directory ?

I tryed to use the alias feature but can't get it configured well

NOTA : the sites are both on the same "customer" in the panel.

thanks for your help.
Reply With Quote
Sponsored Links
  #2  
Old 8th May 2013, 20:07
darinpeterson darinpeterson is offline
HowtoForge Supporter
 
Join Date: Nov 2011
Posts: 153
Thanks: 35
Thanked 13 Times in 13 Posts
Default

Why doesn't aliasing work? You should be able to detect which host is being used and set the languages by that...
Reply With Quote
  #3  
Old 8th May 2013, 20:46
chessman2212 chessman2212 is offline
Junior Member
 
Join Date: May 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello,

when you create a site with ISPconfig it creates automatically a specific directory for it. And the sites are kind of "chrooted" so when I ask domain2 to redirect to the first directory ISP ask me for a directory like /test/ and not ../toto
Reply With Quote
  #4  
Old 9th May 2013, 15:30
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
 
Default

Yust add the second domain as aliasdomain of the first one and do not activate any redirects for the alias domain, it will then point zo the same directory then the main site automatically.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't receive mails baicunko Server Operation 12 3rd August 2011 22:02
I can't finish install due a problem Sam9999 Installation/Configuration 7 17th September 2010 22:33
Webmin upgrade lishaw1968 Installation/Configuration 15 26th August 2010 15:23
Email problem 'Cannot set my user or group id.' (using ISPConfig 3 + OpenSuSE 11.2) urosm Installation/Configuration 5 19th June 2010 22:41
add web site serr57 Installation/Configuration 18 13th April 2008 11:40


All times are GMT +2. The time now is 15:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.